summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/liborcus')
-rw-r--r--dev-libs/liborcus/liborcus-9999.ebuild25
1 files changed, 18 insertions, 7 deletions
diff --git a/dev-libs/liborcus/liborcus-9999.ebuild b/dev-libs/liborcus/liborcus-9999.ebuild
index e175a1e15171..e87413f36da0 100644
--- a/dev-libs/liborcus/liborcus-9999.ebuild
+++ b/dev-libs/liborcus/liborcus-9999.ebuild
@@ -1,13 +1,15 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
EGIT_REPO_URI="https://gitlab.com/orcus/orcus.git"
+PYTHON_COMPAT=( python{3_4,3_5} )
+
[[ ${PV} == 9999 ]] && GITECLASS="git-r3 autotools"
-inherit eutils ${GITECLASS}
+inherit eutils python-single-r1 ${GITECLASS}
unset GITECLASS
DESCRIPTION="Standalone file import filter library for spreadsheet documents"
@@ -15,27 +17,36 @@ HOMEPAGE="https://gitlab.com/orcus/orcus/blob/master/README.md"
[[ ${PV} == 9999 ]] || SRC_URI="http://kohei.us/files/orcus/src/${P}.tar.xz"
LICENSE="MIT"
-SLOT="0/0.10"
+SLOT="0/0.11" # based on SONAME of liborcus.so
[[ ${PV} == 9999 ]] || \
KEYWORDS="~amd64 ~arm ~ppc ~x86"
-IUSE="static-libs"
+IUSE="python static-libs"
RDEPEND="
>=dev-libs/boost-1.51.0:=
- =dev-libs/libixion-0.9*:=
+ =dev-libs/libixion-9999:=
sys-libs/zlib:=
+ python? ( ${PYTHON_DEPS} )
"
DEPEND="${RDEPEND}
- >=dev-util/mdds-0.11
+ dev-util/mdds:1
"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
src_prepare() {
+ eapply_user
[[ ${PV} == 9999 ]] && eautoreconf
}
src_configure() {
econf \
--disable-werror \
+ $(use_enable python) \
$(use_enable static-libs static)
}