summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/glib')
-rw-r--r--dev-libs/glib/glib-2.76.4.ebuild21
-rw-r--r--dev-libs/glib/glib-2.78.3.ebuild21
-rw-r--r--dev-libs/glib/glib-2.78.4-r1.ebuild21
-rw-r--r--dev-libs/glib/glib-2.78.6.ebuild25
-rw-r--r--dev-libs/glib/glib-2.80.4.ebuild21
5 files changed, 55 insertions, 54 deletions
diff --git a/dev-libs/glib/glib-2.76.4.ebuild b/dev-libs/glib/glib-2.76.4.ebuild
index f296a348fdf3..52b264f3f701 100644
--- a/dev-libs/glib/glib-2.76.4.ebuild
+++ b/dev-libs/glib/glib-2.76.4.ebuild
@@ -178,17 +178,7 @@ multilib_src_configure() {
#esac
#fi
- local native_file="${T}"/meson.${CHOST}.ini.local
- # Workaround for bug #938302
- if use systemtap && ! has_version "dev-debug/systemtap[dtrace-symlink(-)]" ; then
- cat >> ${native_file} <<-EOF || die
- [binaries]
- dtrace='stap-dtrace'
- EOF
- fi
-
local emesonargs=(
- --native-file "${native_file}"
-Dbuildtype=$(usex debug debug plain)
-Ddefault_library=$(usex static-libs both shared)
-Druntime_dir="${EPREFIX}"/run
@@ -207,6 +197,17 @@ multilib_src_configure() {
$(meson_native_use_feature elf libelf)
-Dmultiarch=false
)
+
+ # Workaround for bug #938302
+ if use systemtap && ! has_version "dev-debug/systemtap[dtrace-symlink(-)]" ; then
+ local native_file="${T}"/meson.${CHOST}.ini.local
+ cat >> ${native_file} <<-EOF || die
+ [binaries]
+ dtrace='stap-dtrace'
+ EOF
+ emesonargs+=( --native-file "${native_file}" )
+ fi
+
meson_src_configure
}
diff --git a/dev-libs/glib/glib-2.78.3.ebuild b/dev-libs/glib/glib-2.78.3.ebuild
index f296a348fdf3..52b264f3f701 100644
--- a/dev-libs/glib/glib-2.78.3.ebuild
+++ b/dev-libs/glib/glib-2.78.3.ebuild
@@ -178,17 +178,7 @@ multilib_src_configure() {
#esac
#fi
- local native_file="${T}"/meson.${CHOST}.ini.local
- # Workaround for bug #938302
- if use systemtap && ! has_version "dev-debug/systemtap[dtrace-symlink(-)]" ; then
- cat >> ${native_file} <<-EOF || die
- [binaries]
- dtrace='stap-dtrace'
- EOF
- fi
-
local emesonargs=(
- --native-file "${native_file}"
-Dbuildtype=$(usex debug debug plain)
-Ddefault_library=$(usex static-libs both shared)
-Druntime_dir="${EPREFIX}"/run
@@ -207,6 +197,17 @@ multilib_src_configure() {
$(meson_native_use_feature elf libelf)
-Dmultiarch=false
)
+
+ # Workaround for bug #938302
+ if use systemtap && ! has_version "dev-debug/systemtap[dtrace-symlink(-)]" ; then
+ local native_file="${T}"/meson.${CHOST}.ini.local
+ cat >> ${native_file} <<-EOF || die
+ [binaries]
+ dtrace='stap-dtrace'
+ EOF
+ emesonargs+=( --native-file "${native_file}" )
+ fi
+
meson_src_configure
}
diff --git a/dev-libs/glib/glib-2.78.4-r1.ebuild b/dev-libs/glib/glib-2.78.4-r1.ebuild
index 07caf94eb0dc..6ae0c3800fd5 100644
--- a/dev-libs/glib/glib-2.78.4-r1.ebuild
+++ b/dev-libs/glib/glib-2.78.4-r1.ebuild
@@ -187,17 +187,7 @@ multilib_src_configure() {
#esac
#fi
- local native_file="${T}"/meson.${CHOST}.ini.local
- # Workaround for bug #938302
- if use systemtap && ! has_version "dev-debug/systemtap[dtrace-symlink(-)]" ; then
- cat >> ${native_file} <<-EOF || die
- [binaries]
- dtrace='stap-dtrace'
- EOF
- fi
-
local emesonargs=(
- --native-file "${native_file}"
$(meson_feature debug glib_debug)
-Ddefault_library=$(usex static-libs both shared)
-Druntime_dir="${EPREFIX}"/run
@@ -216,6 +206,17 @@ multilib_src_configure() {
$(meson_native_use_feature elf libelf)
-Dmultiarch=false
)
+
+ # Workaround for bug #938302
+ if use systemtap && ! has_version "dev-debug/systemtap[dtrace-symlink(-)]" ; then
+ local native_file="${T}"/meson.${CHOST}.ini.local
+ cat >> ${native_file} <<-EOF || die
+ [binaries]
+ dtrace='stap-dtrace'
+ EOF
+ emesonargs+=( --native-file "${native_file}" )
+ fi
+
meson_src_configure
}
diff --git a/dev-libs/glib/glib-2.78.6.ebuild b/dev-libs/glib/glib-2.78.6.ebuild
index 45509edc58e9..004b9796f159 100644
--- a/dev-libs/glib/glib-2.78.6.ebuild
+++ b/dev-libs/glib/glib-2.78.6.ebuild
@@ -168,10 +168,6 @@ src_prepare() {
-e '/AvailabilityMacros.h/d' \
gio/giomodule.c || die
- # Add meson.${CHOST}.ini.local file that the build system expects to find,
- # #938822
- touch "${T}/meson.${CHOST}.ini.local" || die
-
default
gnome2_environment_reset
# TODO: python_name sedding for correct python shebang? Might be relevant mainly for glib-utils only
@@ -190,17 +186,7 @@ multilib_src_configure() {
#esac
#fi
- local native_file="${T}"/meson.${CHOST}.ini.local
- # Workaround for bug #938302
- if use systemtap && ! has_version "dev-debug/systemtap[dtrace-symlink(-)]" ; then
- cat >> ${native_file} <<-EOF || die
- [binaries]
- dtrace='stap-dtrace'
- EOF
- fi
-
local emesonargs=(
- --native-file "${native_file}"
$(meson_feature debug glib_debug)
-Ddefault_library=$(usex static-libs both shared)
-Druntime_dir="${EPREFIX}"/run
@@ -219,6 +205,17 @@ multilib_src_configure() {
$(meson_native_use_feature elf libelf)
-Dmultiarch=false
)
+
+ # Workaround for bug #938302
+ if use systemtap && ! has_version "dev-debug/systemtap[dtrace-symlink(-)]" ; then
+ local native_file="${T}"/meson.${CHOST}.ini.local
+ cat >> ${native_file} <<-EOF || die
+ [binaries]
+ dtrace='stap-dtrace'
+ EOF
+ emesonargs+=( --native-file "${native_file}" )
+ fi
+
meson_src_configure
}
diff --git a/dev-libs/glib/glib-2.80.4.ebuild b/dev-libs/glib/glib-2.80.4.ebuild
index 2d87ba9d7a69..79fbaf94dbc0 100644
--- a/dev-libs/glib/glib-2.80.4.ebuild
+++ b/dev-libs/glib/glib-2.80.4.ebuild
@@ -187,17 +187,7 @@ multilib_src_configure() {
use debug && EMESON_BUILD_TYPE=debug
- local native_file="${T}"/meson.${CHOST}.ini.local
- # Workaround for bug #938302
- if use systemtap && ! has_version "dev-debug/systemtap[dtrace-symlink(-)]" ; then
- cat >> ${native_file} <<-EOF || die
- [binaries]
- dtrace='stap-dtrace'
- EOF
- fi
-
local emesonargs=(
- --native-file "${native_file}"
-Ddefault_library=$(usex static-libs both shared)
-Druntime_dir="${EPREFIX}"/run
$(meson_feature selinux)
@@ -216,6 +206,17 @@ multilib_src_configure() {
-Dmultiarch=false
$(meson_native_use_feature introspection)
)
+
+ # Workaround for bug #938302
+ if use systemtap && ! has_version "dev-debug/systemtap[dtrace-symlink(-)]" ; then
+ local native_file="${T}"/meson.${CHOST}.ini.local
+ cat >> ${native_file} <<-EOF || die
+ [binaries]
+ dtrace='stap-dtrace'
+ EOF
+ emesonargs+=( --native-file "${native_file}" )
+ fi
+
meson_src_configure
}