summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/x509-store')
-rw-r--r--dev-haskell/x509-store/Manifest2
-rw-r--r--dev-haskell/x509-store/metadata.xml14
-rw-r--r--dev-haskell/x509-store/x509-store-1.4.4.ebuild37
-rw-r--r--dev-haskell/x509-store/x509-store-1.5.0.ebuild37
4 files changed, 90 insertions, 0 deletions
diff --git a/dev-haskell/x509-store/Manifest b/dev-haskell/x509-store/Manifest
new file mode 100644
index 000000000000..f46e352896f1
--- /dev/null
+++ b/dev-haskell/x509-store/Manifest
@@ -0,0 +1,2 @@
+DIST x509-store-1.4.4.tar.gz 2992 SHA256 882fc144a6819dd9182e14297f3af9087c45840cca1c550e759783dc5a767044 SHA512 b7a1ef5e25889ada9e654a52cf2606630c40b536359d7e1df01c96bf047816addfebdd2b0b3c7326a9b41a2b3034c641238f5fdee2f437eb29e0bc89a20e78c6 WHIRLPOOL 3fbd8e44e7f5570fc3df60d0fbfe40f03647b506c0654d070f05e7ec531e8ea00d8e12692f1b4c12e24a6325d1147c781248049c5ccf09c3686dc0821936d1b1
+DIST x509-store-1.5.0.tar.gz 2981 SHA256 c5dbc4ec7fd9eb302843753c2ae081481446d40898b7bcbfdc8ae803c0c23af1 SHA512 fdad44693615f832aafc0fc2b804bc7255d411241f669dc7396a5df958f128d6e94c1637a4b38860c4967a482915549aa94912821110477134d83095d27623d8 WHIRLPOOL 1841cbd41f1e6dc9ce23371328e5e0fe83a020bce28a6a5f107a099acd2dea5763ec39f53cb2f00ab2748166087d101053972d3eb64ce0c52ca4a95e93801a25
diff --git a/dev-haskell/x509-store/metadata.xml b/dev-haskell/x509-store/metadata.xml
new file mode 100644
index 000000000000..e94695b8bbf4
--- /dev/null
+++ b/dev-haskell/x509-store/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <use>
+ <flag name="executable">Build the executable</flag>
+ </use>
+ <longdescription>
+ X.509 collection accessing and storing methods for certificate, crl, exception list
+ </longdescription>
+ <upstream>
+ <remote-id type="github">vincenthz/hs-certificate</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/x509-store/x509-store-1.4.4.ebuild b/dev-haskell/x509-store/x509-store-1.4.4.ebuild
new file mode 100644
index 000000000000..6932d7c4c823
--- /dev/null
+++ b/dev-haskell/x509-store/x509-store-1.4.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="X.509 collection accessing and storing methods"
+HOMEPAGE="http://github.com/vincenthz/hs-certificate"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="executable test"
+
+RDEPEND=">=dev-haskell/asn1-encoding-0.8:=[profile?] <dev-haskell/asn1-encoding-0.9:=[profile?]
+ >=dev-haskell/asn1-types-0.2:=[profile?] <dev-haskell/asn1-types-0.3:=[profile?]
+ >=dev-haskell/crypto-pubkey-types-0.3:=[profile?] <dev-haskell/crypto-pubkey-types-0.5:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/pem-0.1:=[profile?] <dev-haskell/pem-0.3:=[profile?]
+ >=dev-haskell/x509-1.4.3:=[profile?] <dev-haskell/x509-1.5:=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable) \
+ $(cabal_flag test test)
+}
diff --git a/dev-haskell/x509-store/x509-store-1.5.0.ebuild b/dev-haskell/x509-store/x509-store-1.5.0.ebuild
new file mode 100644
index 000000000000..0dcc886fbe4f
--- /dev/null
+++ b/dev-haskell/x509-store/x509-store-1.5.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="X.509 collection accessing and storing methods"
+HOMEPAGE="http://github.com/vincenthz/hs-certificate"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="executable test"
+
+RDEPEND=">=dev-haskell/asn1-encoding-0.9:=[profile?] <dev-haskell/asn1-encoding-0.10:=[profile?]
+ >=dev-haskell/asn1-types-0.3:=[profile?] <dev-haskell/asn1-types-0.4:=[profile?]
+ >=dev-haskell/crypto-pubkey-types-0.3:=[profile?] <dev-haskell/crypto-pubkey-types-0.5:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/pem-0.1:=[profile?] <dev-haskell/pem-0.3:=[profile?]
+ >=dev-haskell/x509-1.5.0:=[profile?] <dev-haskell/x509-1.6:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable) \
+ $(cabal_flag test test)
+}