summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/wxhaskell/wxhaskell-0.13.2.1-r1.ebuild')
-rw-r--r--dev-haskell/wxhaskell/wxhaskell-0.13.2.1-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/wxhaskell/wxhaskell-0.13.2.1-r1.ebuild b/dev-haskell/wxhaskell/wxhaskell-0.13.2.1-r1.ebuild
new file mode 100644
index 000000000000..1163c41089aa
--- /dev/null
+++ b/dev-haskell/wxhaskell/wxhaskell-0.13.2.1-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="2.8"
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN=wx
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="wxHaskell is a portable and native GUI library for Haskell"
+HOMEPAGE="http://haskell.org/haskellwiki/WxHaskell"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="wxWinLL-3.1"
+SLOT="${WX_GTK_VER}/${PV}"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/stm:=[profile?]
+ >=dev-haskell/wxcore-0.13.1:${WX_GTK_VER}=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ CABAL_FILE=${MY_PN}.cabal cabal_chdeps \
+ 'wxcore >= 0.13.1' 'wxcore >= 0.13.1 && < 0.90' \
+ 'wxcore >= 0.12.1.6' 'wxcore >= 0.12.1.6 && < 0.90'
+}