summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/quickcheck/quickcheck-1.2.0.1-r1.ebuild')
-rw-r--r--dev-haskell/quickcheck/quickcheck-1.2.0.1-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-haskell/quickcheck/quickcheck-1.2.0.1-r1.ebuild b/dev-haskell/quickcheck/quickcheck-1.2.0.1-r1.ebuild
new file mode 100644
index 000000000000..4dca7b2151de
--- /dev/null
+++ b/dev-haskell/quickcheck/quickcheck-1.2.0.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+CABAL_FEATURES="lib profile haddock"
+inherit eutils haskell-cabal
+
+MY_PN="QuickCheck"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Automatic testing of Haskell programs"
+HOMEPAGE="http://www.math.chalmers.se/~rjmh/QuickCheck/"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.6.1
+ dev-haskell/random:=[profile?]
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ghc-7.10.patch
+}