summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/nonce/nonce-1.0.2.ebuild')
-rw-r--r--dev-haskell/nonce/nonce-1.0.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-haskell/nonce/nonce-1.0.2.ebuild b/dev-haskell/nonce/nonce-1.0.2.ebuild
new file mode 100644
index 000000000000..0a40dbf8bdd7
--- /dev/null
+++ b/dev-haskell/nonce/nonce-1.0.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Generate cryptographic nonces"
+HOMEPAGE="https://github.com/prowdsponsor/nonce"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/base64-bytestring-1.0:=[profile?] <dev-haskell/base64-bytestring-1.1:=[profile?]
+ >=dev-haskell/cprng-aes-0.5:=[profile?] <dev-haskell/cprng-aes-0.7:=[profile?]
+ >=dev-haskell/crypto-random-0.0:=[profile?] <dev-haskell/crypto-random-0.1:=[profile?]
+ >=dev-haskell/text-0.9:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"