summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/json/json-0.9.ebuild')
-rw-r--r--dev-haskell/json/json-0.9.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-haskell/json/json-0.9.ebuild b/dev-haskell/json/json-0.9.ebuild
new file mode 100644
index 000000000000..041b25701a7c
--- /dev/null
+++ b/dev-haskell/json/json-0.9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Support for serialising Haskell to and from JSON"
+HOMEPAGE="http://hackage.haskell.org/package/json"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux"
+IUSE="+generic mapdict +parsec +pretty"
+
+RDEPEND="dev-haskell/mtl:=[profile?]
+ dev-haskell/text:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ generic? ( >=dev-haskell/syb-0.3.3:=[profile?] )
+ parsec? ( dev-haskell/parsec:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag generic generic) \
+ $(cabal_flag mapdict mapdict) \
+ $(cabal_flag parsec parsec) \
+ $(cabal_flag pretty pretty)
+}