summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/hjsmin/hjsmin-0.1.4.1.ebuild')
-rw-r--r--dev-haskell/hjsmin/hjsmin-0.1.4.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-haskell/hjsmin/hjsmin-0.1.4.1.ebuild b/dev-haskell/hjsmin/hjsmin-0.1.4.1.ebuild
new file mode 100644
index 000000000000..bb4c5a29afd3
--- /dev/null
+++ b/dev-haskell/hjsmin/hjsmin-0.1.4.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Haskell implementation of a javascript minifier"
+HOMEPAGE="http://github.com/alanz/hjsmin"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/blaze-builder-0.2:=[profile?]
+ <dev-haskell/blaze-builder-1:=[profile?]
+ >=dev-haskell/language-javascript-0.5.1:=[profile?]
+ <dev-haskell/language-javascript-0.6:=[profile?]
+ >=dev-haskell/text-0.8:=[profile?]
+ <dev-haskell/text-1:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.9.2
+ test? ( dev-haskell/hunit
+ =dev-haskell/quickcheck-2*
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit
+ )"