summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-dotnet/mono-zeroconf/mono-zeroconf-0.9.0.ebuild')
-rw-r--r--dev-dotnet/mono-zeroconf/mono-zeroconf-0.9.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-dotnet/mono-zeroconf/mono-zeroconf-0.9.0.ebuild b/dev-dotnet/mono-zeroconf/mono-zeroconf-0.9.0.ebuild
new file mode 100644
index 000000000000..1065caefd250
--- /dev/null
+++ b/dev-dotnet/mono-zeroconf/mono-zeroconf-0.9.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit base mono
+
+DESCRIPTION="a cross platform Zero Configuration Networking library for Mono and .NET"
+HOMEPAGE="http://www.mono-project.com/Mono.Zeroconf"
+SRC_URI="http://banshee-project.org/files/${PN}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="doc"
+
+RDEPEND=">=dev-lang/mono-2.0
+ >=net-dns/avahi-0.6[mono]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf $(use_enable doc docs) --enable-avahi
+}
+
+src_compile() {
+ emake -j1 || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README || die "docs failed"
+ mono_multilib_comply
+}