summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/freetds/Manifest1
-rw-r--r--dev-db/freetds/files/freetds-1.2.18-xfail-tests.patch22
-rw-r--r--dev-db/freetds/freetds-1.2.18.ebuild60
3 files changed, 83 insertions, 0 deletions
diff --git a/dev-db/freetds/Manifest b/dev-db/freetds/Manifest
index 79267daa4608..57f15daa805d 100644
--- a/dev-db/freetds/Manifest
+++ b/dev-db/freetds/Manifest
@@ -1 +1,2 @@
DIST freetds-dev.1.00.558.tar.gz 3151542 BLAKE2B e7b7eb1d4bad1472a675e7657d524837a27ba18176cf410ebad6dcb949cd59bb50e932526790c816c05cf0ba02fb750a1cfbcda10073e5cbf8908bdc4ceb9cc5 SHA512 763f04ae36be8385f9be955defd2d91698389836e80e19019f0da0ee15515d8b7e3733f7659362a307b492dc83830f0a7f27d2a68cb5b56e2ef171ac1dcfeeca
+DIST freetds-dev.1.2.18.tar.gz 3406990 BLAKE2B f0134ee0a322cb9e7a7fefbf9e85c60b826318b546febde78e53d5ec22dc2c8e269b7e830da6d84267d16a2dc2cf367a54354765017a40e07af2c3c6be54676e SHA512 315f40ba0d97281f852ec99fac457ec4b2a30879a2384bfa2d7c680aad6c056b6ae23fc192c18db4fba75caff552ef86de7bbfc5d7b608ea5a12531bf9eadc4c
diff --git a/dev-db/freetds/files/freetds-1.2.18-xfail-tests.patch b/dev-db/freetds/files/freetds-1.2.18-xfail-tests.patch
new file mode 100644
index 000000000000..57a63b80be33
--- /dev/null
+++ b/dev-db/freetds/files/freetds-1.2.18-xfail-tests.patch
@@ -0,0 +1,22 @@
+From 47b73a60b488dff539e493b29e774c1e3cbb3db4 Mon Sep 17 00:00:00 2001
+From: John Helmert III <jchelmert3@posteo.net>
+Date: Wed, 6 Jan 2021 21:03:28 -0600
+Subject: [PATCH] Xfail tests which fail due to network-sandbox
+
+---
+ src/tds/unittests/Makefile.am | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/tds/unittests/Makefile.am b/src/tds/unittests/Makefile.am
+index 66f48f5b..f3d25ea2 100644
+--- a/src/tds/unittests/Makefile.am
++++ b/src/tds/unittests/Makefile.am
+@@ -78,3 +78,5 @@ LDADD = libcommon.a ../libtds.la ../../replacements/libreplacements.la $(LTLIBI
+ CLEANFILES = tdsdump.out
+ EXTRA_DIST = CMakeLists.txt
+
++XFAIL_TESTS = t0001 t0002 t0003 t0004 t0005 t0006 dynamic1 dataread \
++ utf8_1 utf8_2 utf8_3 toodynamic nulls corrupt
+--
+2.30.0
+
diff --git a/dev-db/freetds/freetds-1.2.18.ebuild b/dev-db/freetds/freetds-1.2.18.ebuild
new file mode 100644
index 000000000000..10fde9e9f6b5
--- /dev/null
+++ b/dev-db/freetds/freetds-1.2.18.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# This is from the "current" release series, because the "stable" series
+# is a little too stable for us (missing bug fixes, and so on).
+MY_PN="${PN}-dev"
+
+DESCRIPTION="Tabular Datastream Library"
+HOMEPAGE="https://www.freetds.org/"
+SRC_URI="ftp://ftp.freetds.org/pub/${PN}/current/${MY_PN}.${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-macos"
+
+IUSE="debug gnutls iconv kerberos libressl mssql iodbc odbc ssl static-libs"
+# iODBC and unixODBC are mutually-exclusive choices for
+# the ODBC driver manager. Future versions of FreeTDS
+# will throw an error if you specify both.
+REQUIRED_USE="?? ( iodbc odbc )"
+
+RESTRICT="test"
+
+COMMON_DEPEND="virtual/awk
+ gnutls? ( net-libs/gnutls:= )
+ iconv? ( virtual/libiconv )
+ iodbc? ( dev-db/libiodbc )
+ kerberos? ( virtual/krb5 )
+ odbc? ( dev-db/unixODBC )
+ ssl? ( dev-libs/openssl:0= )"
+DEPEND="${COMMON_DEPEND}"
+
+# bind-tools is needed because the osql script calls "host".
+RDEPEND="${COMMON_DEPEND}
+ net-dns/bind-tools"
+
+S="${WORKDIR}/${MY_PN}.${PV}"
+
+src_configure() {
+ econf \
+ --enable-shared \
+ --disable-static \
+ $(use_enable debug) \
+ $(use_enable iconv libiconv) \
+ $(use_enable kerberos krb5) \
+ $(use_enable mssql msdblib) \
+ $(use_with iodbc) \
+ $(use_with odbc unixodbc "${EPREFIX}/usr") \
+ $(use_with iconv libiconv-prefix "${EPREFIX}/usr") \
+ $(use_with gnutls) \
+ $(use_with ssl openssl "${EPREFIX}/usr")
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}