summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/cmark/cmark-0.27.1.ebuild')
-rw-r--r--app-text/cmark/cmark-0.27.1.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/app-text/cmark/cmark-0.27.1.ebuild b/app-text/cmark/cmark-0.27.1.ebuild
index b7ae5b0f010e..a69f2b36f50b 100644
--- a/app-text/cmark/cmark-0.27.1.ebuild
+++ b/app-text/cmark/cmark-0.27.1.ebuild
@@ -3,7 +3,9 @@
EAPI=6
-inherit cmake-utils
+PYTHON_COMPAT=( python3_{4,5} )
+
+inherit cmake-utils python-any-r1
DESCRIPTION="CommonMark parsing and rendering library and program in C"
HOMEPAGE="https://github.com/jgm/cmark"
@@ -15,9 +17,13 @@ KEYWORDS="~amd64 ~x86"
IUSE="test"
DEPEND="
- test? ( || ( dev-lang/python:3.4 dev-lang/python:3.5 ) )"
+ test? ( ${PYTHON_DEPS} )"
RDEPEND=""
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
src_prepare() {
cmake-utils_src_prepare
# Remove static library from installing