summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/man-pages-pl')
-rw-r--r--app-i18n/man-pages-pl/Manifest1
-rw-r--r--app-i18n/man-pages-pl/man-pages-pl-0_pre20070628-r2.ebuild43
-rw-r--r--app-i18n/man-pages-pl/man-pages-pl-20070628-r2.ebuild43
-rw-r--r--app-i18n/man-pages-pl/metadata.xml7
4 files changed, 94 insertions, 0 deletions
diff --git a/app-i18n/man-pages-pl/Manifest b/app-i18n/man-pages-pl/Manifest
new file mode 100644
index 000000000000..7e999f08f02b
--- /dev/null
+++ b/app-i18n/man-pages-pl/Manifest
@@ -0,0 +1 @@
+DIST man-PL28-06-2007.tar.gz 3436680 SHA256 9cd783f5b6e42fd53b7cc929225824f3b8e9e8cb1615e481ac02a43ac29a510b SHA512 cc5de191b5dc7963018db8c2e7094b8e4e6db0dc0afefaa3a36e73a0bc70a3889d68ce78c4a900862dc5590a00bf57a3897050ed25c45d2f6f33765858cc4c8b WHIRLPOOL e490e6c12c31a55959473299364cff5009b2d97f9f98c2aea2252588e2f6b0e5fb7a6ddf0756ef46bda03369c4ada77646407c5d96642e77be141f468065bc3a
diff --git a/app-i18n/man-pages-pl/man-pages-pl-0_pre20070628-r2.ebuild b/app-i18n/man-pages-pl/man-pages-pl-0_pre20070628-r2.ebuild
new file mode 100644
index 000000000000..a0527f2aab56
--- /dev/null
+++ b/app-i18n/man-pages-pl/man-pages-pl-0_pre20070628-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools
+
+DESCRIPTION="A collection of Polish translations of Linux manual pages"
+HOMEPAGE="http://www.batnet.pl/ptm/"
+SRC_URI="http://www.batnet.pl/ptm/man-PL28-06-2007.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+DOCS=(AUTHORS ChangeLog FAQ NEWS README TODO)
+
+S="${WORKDIR}/pl_PL"
+
+src_prepare() {
+ # missing manpages
+ sed -i -e '/\tpasswd.1/ d' man1/Makefile.am || die
+
+ # manpages provided by other packages
+ mans="gendiff.1 groups.1 apropos.1 man.1 su.1 newgrp.1 whatis.1 gpasswd.1 chsh.1 \
+ chfn.1 limits.5 login.1 expiry.1 porttime.5 lastlog.8 faillog.8 logoutd.8 \
+ rpm.8 rpmdeps.8 rpmbuild.8 rpmcache.8 rpmgraph.8 rpm2cpio.8 evim.1 vim.1 \
+ vimdiff.1 vimtutor.1 ex.1 rview.1 rvim.1 view.1 suauth.5 mc.1"
+ # bug #375623:
+ mans="${mans} manpath.5 catman.8 mandb.8 zsoelim.1 manpath.1"
+ # bug #403379:
+ mans="${mans} shadow.3"
+ for page in ${mans} ; do
+ sed -i -e "/\\t${page}/d; \$s,\\\,,;" man${page: -1}/Makefile.am || die
+ done
+
+ eautoreconf
+}
diff --git a/app-i18n/man-pages-pl/man-pages-pl-20070628-r2.ebuild b/app-i18n/man-pages-pl/man-pages-pl-20070628-r2.ebuild
new file mode 100644
index 000000000000..ae69052ea8bf
--- /dev/null
+++ b/app-i18n/man-pages-pl/man-pages-pl-20070628-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools
+
+DESCRIPTION="A collection of Polish translations of Linux manual pages"
+HOMEPAGE="http://www.batnet.pl/ptm/"
+SRC_URI="http://www.batnet.pl/ptm/man-PL${PV:6:2}-${PV:4:2}-${PV:0:4}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+DOCS=(AUTHORS ChangeLog FAQ NEWS README TODO)
+
+S="${WORKDIR}/pl_PL"
+
+src_prepare() {
+ # missing manpages
+ sed -i -e '/\tpasswd.1/ d' man1/Makefile.am || die
+
+ # manpages provided by other packages
+ mans="gendiff.1 groups.1 apropos.1 man.1 su.1 newgrp.1 whatis.1 gpasswd.1 chsh.1 \
+ chfn.1 limits.5 login.1 expiry.1 porttime.5 lastlog.8 faillog.8 logoutd.8 \
+ rpm.8 rpmdeps.8 rpmbuild.8 rpmcache.8 rpmgraph.8 rpm2cpio.8 evim.1 vim.1 \
+ vimdiff.1 vimtutor.1 ex.1 rview.1 rvim.1 view.1 suauth.5 mc.1"
+ # bug #375623:
+ mans="${mans} manpath.5 catman.8 mandb.8 zsoelim.1 manpath.1"
+ # bug #403379:
+ mans="${mans} shadow.3"
+ for page in ${mans} ; do
+ sed -i -e "/\\t${page}/d; \$s,\\\,,;" man${page: -1}/Makefile.am || die
+ done
+
+ eautoreconf
+}
diff --git a/app-i18n/man-pages-pl/metadata.xml b/app-i18n/man-pages-pl/metadata.xml
new file mode 100644
index 000000000000..aba833ed90e0
--- /dev/null
+++ b/app-i18n/man-pages-pl/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>