summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/kimera/kimera-2.11-r1.ebuild')
-rw-r--r--app-i18n/kimera/kimera-2.11-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-i18n/kimera/kimera-2.11-r1.ebuild b/app-i18n/kimera/kimera-2.11-r1.ebuild
new file mode 100644
index 000000000000..f4dd8e3d39e2
--- /dev/null
+++ b/app-i18n/kimera/kimera-2.11-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+inherit qt4-r2 eutils multilib
+
+DESCRIPTION="A Japanese input method which supports the XIM protocol"
+SRC_URI="mirror://sourceforge.jp/kimera/37271/${P}.tar.gz"
+HOMEPAGE="http://kimera.sourceforge.jp/"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="amd64 x86"
+IUSE="+anthy"
+
+DEPEND="dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qt3support:4
+ anthy? ( app-i18n/anthy )
+ !anthy? ( app-i18n/canna )"
+RDEPEND="${DEPEND}"
+
+DOCS="AUTHORS README*"
+
+src_configure() {
+ local myconf="target.path=/usr/$(get_libdir)/${P}"
+ use anthy || myconf="${myconf} no_anthy=1"
+ eqmake4 kimera.pro ${myconf}
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-underlinking.patch
+}