summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/fcitx-rime/fcitx-rime-0.3.1.ebuild')
-rw-r--r--app-i18n/fcitx-rime/fcitx-rime-0.3.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-i18n/fcitx-rime/fcitx-rime-0.3.1.ebuild b/app-i18n/fcitx-rime/fcitx-rime-0.3.1.ebuild
new file mode 100644
index 000000000000..8b1623ca36bd
--- /dev/null
+++ b/app-i18n/fcitx-rime/fcitx-rime-0.3.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Rime support for Fcitx"
+HOMEPAGE="http://fcitx-im.org/"
+SRC_URI="http://download.fcitx-im.org/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.8.1
+ >=app-i18n/librime-1.0
+ app-i18n/rime-data
+ x11-libs/libnotify"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # dont build data resource here, already provided by app-i18n/rime-data
+ sed -i -e 's|add_subdirectory(data)||' CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DRIME_DATA_DIR=/usr/share/rime-data
+ )
+ cmake-utils_src_configure
+}