summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/runc/runc-1.0.0_rc10.ebuild14
1 files changed, 2 insertions, 12 deletions
diff --git a/app-emulation/runc/runc-1.0.0_rc10.ebuild b/app-emulation/runc/runc-1.0.0_rc10.ebuild
index 2338fa34630c..00d4ecb746d0 100644
--- a/app-emulation/runc/runc-1.0.0_rc10.ebuild
+++ b/app-emulation/runc/runc-1.0.0_rc10.ebuild
@@ -31,17 +31,6 @@ RDEPEND="
!app-emulation/docker-runc
"
-src_prepare() {
- pushd src/${EGO_PN}
- default
- sed -i -e "/^GIT_BRANCH/d"\
- -e "/^GIT_BRANCH_CLEAN/d"\
- -e "/^COMMIT_NO/d"\
- -e "s/COMMIT :=.*/COMMIT := ${RUNC_COMMIT}/"\
- Makefile || die
- popd || die
-}
-
src_compile() {
# Taken from app-emulation/docker-1.7.0-r1
export CGO_CFLAGS="-I${ROOT}/usr/include"
@@ -56,7 +45,8 @@ src_compile() {
$(usex kmem '' 'nokmem')
)
- GOPATH="${S}" emake BUILDTAGS="${options[*]}" -C src/${EGO_PN}
+ COMMIT=${RUNC_COMMIT} GOPATH="${S}" emake BUILDTAGS="${options[*]}" \
+ -C src/${EGO_PN}
}
src_install() {