summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/skopeo/skopeo-0.2.0.ebuild')
-rw-r--r--app-emulation/skopeo/skopeo-0.2.0.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/app-emulation/skopeo/skopeo-0.2.0.ebuild b/app-emulation/skopeo/skopeo-0.2.0.ebuild
index 41797bfbd1bb..c6caefe701f8 100644
--- a/app-emulation/skopeo/skopeo-0.2.0.ebuild
+++ b/app-emulation/skopeo/skopeo-0.2.0.ebuild
@@ -12,11 +12,12 @@ SRC_URI="https://github.com/containers/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.g
LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT"
SLOT="0"
KEYWORDS="~amd64"
+IUSE="btrfs"
COMMON_DEPEND=">=app-crypt/gpgme-1.5.5:=
>=dev-libs/libassuan-2.4.3:=
dev-libs/libgpg-error:=
- >=sys-fs/btrfs-progs-4.0.1
+ btrfs? ( >=sys-fs/btrfs-progs-4.0.1 )
>=sys-fs/lvm2-2.02.145:="
DEPEND="${COMMON_DEPEND}
dev-go/go-md2man"
@@ -25,7 +26,8 @@ RDEPEND="${COMMON_DEPEND}"
RESTRICT="test"
src_compile() {
- local BUILDTAGS="containers_image_ostree_stub"
+ local BUILDTAGS
+ BUILDTAGS="containers_image_ostree_stub $(usex btrfs "" exclude_graphdriver_btrfs)"
set -- go build -mod=vendor -ldflags "-X main.gitCommit=${COMMIT}" \
-gcflags "${GOGCFLAGS}" -tags "${BUILDTAGS}" \
-o skopeo ./cmd/skopeo