summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/emacs/emacs-23.4-r17.ebuild')
-rw-r--r--app-editors/emacs/emacs-23.4-r17.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/app-editors/emacs/emacs-23.4-r17.ebuild b/app-editors/emacs/emacs-23.4-r17.ebuild
index 92884cb78c16..b331aae1a49c 100644
--- a/app-editors/emacs/emacs-23.4-r17.ebuild
+++ b/app-editors/emacs/emacs-23.4-r17.ebuild
@@ -223,10 +223,11 @@ src_configure() {
}
src_compile() {
- export SANDBOX_ON=0 # for the unbelievers, see Bug #131505
+ # Disable sandbox when dumping. For the unbelievers, see bug #131505
emake CC="$(tc-getCC)" \
AR="$(tc-getAR) cq" \
- RANLIB="$(tc-getRANLIB)"
+ RANLIB="$(tc-getRANLIB)" \
+ RUN_TEMACS="env SANDBOX_ON=0 LD_PRELOAD= ./temacs"
}
src_install () {