summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/asedriveiiie-serial')
-rw-r--r--app-crypt/asedriveiiie-serial/Manifest1
-rw-r--r--app-crypt/asedriveiiie-serial/asedriveiiie-serial-3.5.ebuild46
-rw-r--r--app-crypt/asedriveiiie-serial/metadata.xml5
3 files changed, 52 insertions, 0 deletions
diff --git a/app-crypt/asedriveiiie-serial/Manifest b/app-crypt/asedriveiiie-serial/Manifest
new file mode 100644
index 000000000000..a433234ec628
--- /dev/null
+++ b/app-crypt/asedriveiiie-serial/Manifest
@@ -0,0 +1 @@
+DIST asedriveiiie-serial-3.5.tar.bz2 32461 SHA256 77743ecb79f08ebd70d9c254d4fd35331eaa06bef528cc813ecdbb378b274120 SHA512 b74ea2225990c36e86d106fa7e9e844e1f99d87f9869416faf3dfaa1ecaca34b4bdd4e5887746c6b039de325e03ede3ee78aadeaf20d0fabc8deba48a72a93b3 WHIRLPOOL 1adacde0df7dbedf5edb120dfaff9b341c40b5220467412ce58e04fc6a7dd7083b7b757305aa86cc2e2492e54a39f732c068f1f0fabe8bd711a21dea0bf3c211
diff --git a/app-crypt/asedriveiiie-serial/asedriveiiie-serial-3.5.ebuild b/app-crypt/asedriveiiie-serial/asedriveiiie-serial-3.5.ebuild
new file mode 100644
index 000000000000..f2047fd1a927
--- /dev/null
+++ b/app-crypt/asedriveiiie-serial/asedriveiiie-serial-3.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="ASEDriveIIIe Serial Card Reader"
+HOMEPAGE="http://www.athena-scs.com"
+SRC_URI="http://www.athena-scs.com/downloads/${P}.tar.bz2"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+RDEPEND=">=sys-apps/pcsc-lite-1.3.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_install() {
+ local conf="/etc/reader.conf.d/${PN}.conf"
+
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc ChangeLog README
+
+ dodir "$(dirname "${conf}")"
+ insinto "$(dirname "${conf}")"
+ newins "etc/reader.conf" "$(basename "${conf}")"
+}
+
+pkg_postinst() {
+ elog "NOTICE:"
+ elog "1. Update ${conf} file"
+ elog "2. Run update-reader.conf, yes this is a command..."
+ elog "3. Restart pcscd"
+}
+
+pkg_postrm() {
+ #
+ # Without this, pcscd will not start next time.
+ #
+ local conf="/etc/reader.conf.d/${PN}.conf"
+ if ! [ -f "$(grep LIBPATH "${conf}" | sed 's/LIBPATH *//' | sed 's/ *$//g' | head -n 1)" ]; then
+ rm "${conf}"
+ update-reader.conf
+ elog "NOTICE:"
+ elog "You need to restart pcscd"
+ fi
+}
diff --git a/app-crypt/asedriveiiie-serial/metadata.xml b/app-crypt/asedriveiiie-serial/metadata.xml
new file mode 100644
index 000000000000..d68fe974c15a
--- /dev/null
+++ b/app-crypt/asedriveiiie-serial/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>crypto</herd>
+</pkgmetadata>