summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/duktape-rb/duktape-rb-2.3.0.0-r2.ebuild2
-rw-r--r--dev-ruby/execjs/execjs-2.7.0-r1.ebuild35
-rw-r--r--dev-ruby/pdf-reader/pdf-reader-1.4.1-r3.ebuild51
-rw-r--r--eclass/ruby-utils.eclass4
4 files changed, 89 insertions, 3 deletions
diff --git a/dev-ruby/duktape-rb/duktape-rb-2.3.0.0-r2.ebuild b/dev-ruby/duktape-rb/duktape-rb-2.3.0.0-r2.ebuild
index cb4afb5e8307..ae7052fef742 100644
--- a/dev-ruby/duktape-rb/duktape-rb-2.3.0.0-r2.ebuild
+++ b/dev-ruby/duktape-rb/duktape-rb-2.3.0.0-r2.ebuild
@@ -21,7 +21,7 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ppc"
-COMMON_DEPEND="dev-lang/duktape"
+COMMON_DEPEND="dev-lang/duktape:="
DEPEND+="${COMMON_DEPEND}"
RDEPEND+="${COMMON_DEPEND}"
diff --git a/dev-ruby/execjs/execjs-2.7.0-r1.ebuild b/dev-ruby/execjs/execjs-2.7.0-r1.ebuild
new file mode 100644
index 000000000000..b49c7109de2c
--- /dev/null
+++ b/dev-ruby/execjs/execjs-2.7.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+inherit ruby-fakegem
+
+DESCRIPTION="ExecJS lets you run JavaScript code from Ruby"
+HOMEPAGE="https://github.com/rails/execjs"
+SRC_URI="https://github.com/rails/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x64-macos"
+
+IUSE="test"
+
+# execjs supports various javascript runtimes. They are listed in order
+# as per the documentation. For now only include the ones already in the
+# tree.
+
+RDEPEND+=" || ( dev-ruby/duktape-rb net-libs/nodejs )"
+
+all_ruby_prepare() {
+ sed -i -e "/bundler/d" Rakefile || die
+ # Avoid test requiring network connectivity. We could potentially
+ # substitute dev-ruby/coffee-script-source for this.
+ sed -i -e '/test_coffeescript/,/end/ s:^:#:' test/test_execjs.rb || die
+}
diff --git a/dev-ruby/pdf-reader/pdf-reader-1.4.1-r3.ebuild b/dev-ruby/pdf-reader/pdf-reader-1.4.1-r3.ebuild
new file mode 100644
index 000000000000..f2a8095194bb
--- /dev/null
+++ b/dev-ruby/pdf-reader/pdf-reader-1.4.1-r3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+GITHUB_USER=yob
+
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc TODO"
+
+RUBY_FAKEGEM_GEMSPEC="pdf-reader.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="PDF parser conforming as much as possible to the PDF specification from Adobe"
+HOMEPAGE="https://github.com/yob/pdf-reader/"
+
+# We cannot use the gem distributions because they don't contain the
+# tests' data, we have to rely on the git tags.
+SRC_URI="https://github.com/${GITHUB_USER}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/afm-0.2.1
+ =dev-ruby/ascii85-1*
+ =dev-ruby/hashery-2*
+ dev-ruby/ttfunk:*
+ dev-ruby/ruby-rc4"
+
+all_ruby_prepare() {
+ # Remove bundler support
+ sed -i -e '/[Bb]undler/d' spec/spec_helper.rb || die
+
+ sed -i -e '/Ascii85/ s/1.0.0/1.0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/*
+}
diff --git a/eclass/ruby-utils.eclass b/eclass/ruby-utils.eclass
index 3f2acc023a5f..45ad3d274028 100644
--- a/eclass/ruby-utils.eclass
+++ b/eclass/ruby-utils.eclass
@@ -28,10 +28,10 @@ if [[ ! ${_RUBY_UTILS} ]]; then
# provide for a better first installation experience.
# All stable RUBY_TARGETS
-RUBY_TARGETS_PREFERENCE="ruby25 "
+RUBY_TARGETS_PREFERENCE="ruby26 ruby25 "
# All other active ruby targets
-RUBY_TARGETS_PREFERENCE+="ruby26 ruby27"
+RUBY_TARGETS_PREFERENCE+="ruby27"
_ruby_implementation_depend() {