summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/selenium-webdriver/Manifest1
-rw-r--r--dev-ruby/selenium-webdriver/selenium-webdriver-2.49.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-ruby/selenium-webdriver/Manifest b/dev-ruby/selenium-webdriver/Manifest
index c4ad0186715d..bcaff3dfd73b 100644
--- a/dev-ruby/selenium-webdriver/Manifest
+++ b/dev-ruby/selenium-webdriver/Manifest
@@ -1,3 +1,4 @@
DIST selenium-webdriver-2.46.2.gem 2919424 SHA256 cb6575396f62f86f015c4905970d48da546c59109ed0aa318af061468d19a85c SHA512 b19bd428090381a12b577d82678ea8dfd2eec64c41e7c070c066ad8e9f106c3821a476038132f49862e1e01a5e940fa4e7a15f3655493753303dcedcccc55943 WHIRLPOOL e2413479641c6a4e687a824016af023f76286a0b89af3733e421d103d38e4dd73c8fcbc30b72135699c178060bfa2978ad15941864715c90f5a65311ae10b016
DIST selenium-webdriver-2.47.1.gem 2872832 SHA256 0140306e064fc40eb2dc632a88fd47dabe786ec2b29f7c59ee425d58113f7b86 SHA512 2973983dfca3ae1c97f55edc9db9480a7595676439c57ae58ec8af18ae6c5e210e2a2efcab630036079c4fed0513ce2e961b36dec3501b41e787a92ebf8cca98 WHIRLPOOL 137327e3066f9cdd52fc41ef1a36ee7a1ebb669b0a5dcbb9aafe7f49d180d2b41850b60089592b2ae9db8c9127764db2108543a173853b1ba4edf16131e8858c
DIST selenium-webdriver-2.48.1.gem 884736 SHA256 b804174665cbc2086c24a98f5331dcc6e1ab313db0852849c6a4d0779deb2484 SHA512 b78e20f382210e73bee24e6ea6cf9ff1bcae6bc77e5ed23ccc0ce9db307f4974140e47b29896850eaaa4c315100e50b3dc2756856defb447405a8c8a509ae966 WHIRLPOOL 7b89a4ad412bdd80fe956af413b75d45144597c6cb0d2bba1d7ec599b3d8f63dab06ac416a276df2ab9293263c22023fb092b8cf0c9848b02765edc9430e7480
+DIST selenium-webdriver-2.49.0.gem 887808 SHA256 c3ceba30bcecfb2e6d0f53bed34ac046f740793871ebfd011c339860f79d4bc8 SHA512 bad495b5d5d97d7f3d7133dd47bc5a2b1695634f18b5b565b17effcd894f18006c015e975be89883ac583cf9b531af7130985fc555d40c9e97bac808461d6a4d WHIRLPOOL 3272fd223fd7eaca858663b52f92a3fd622a2a3707c9f005e871efe4aa40c7cdf2f95921a5ce9d94de30f2185a8ba310e7020905daaa1eb1c855c3c06487e86d
diff --git a/dev-ruby/selenium-webdriver/selenium-webdriver-2.49.0.ebuild b/dev-ruby/selenium-webdriver/selenium-webdriver-2.49.0.ebuild
new file mode 100644
index 000000000000..dffb511bdbba
--- /dev/null
+++ b/dev-ruby/selenium-webdriver/selenium-webdriver-2.49.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22"
+
+# NOTE: this package contains precompiled code. It appears that all
+# source code can be found at https://code.google.com/p/selenium/ but the
+# repository is not organized in a way so that we can easily rebuild the
+# suited shared object. We'll just try our luck with the precompiled
+# objects for now.
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES README.md"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_QA_ALLOWED_LIBS="x_ignore_nofocus.so"
+QA_PREBUILT="*/x_ignore_nofocus.so"
+
+inherit ruby-fakegem
+
+DESCRIPTION="This gem provides Ruby bindings for WebDriver"
+HOMEPAGE="http://gemcutter.org/gems/selenium-webdriver"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/childprocess-0.5.0
+ >=dev-ruby/multi_json-1.0.4
+ dev-ruby/rubyzip:1"
+
+all_ruby_prepare() {
+ # Make websocket a development dependency since it is only needed
+ # for the safari driver which we don't support on Gentoo.
+ sed -i -e '/websocket/,/version_requirements/ s/runtime/development/' ../metadata || die
+}