summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-qt/qtscxml/Manifest1
-rw-r--r--dev-qt/qtscxml/qtscxml-5.15.8.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-qt/qtscxml/Manifest b/dev-qt/qtscxml/Manifest
index 9e750223bbb6..d7e848c423c9 100644
--- a/dev-qt/qtscxml/Manifest
+++ b/dev-qt/qtscxml/Manifest
@@ -1 +1,2 @@
DIST qtscxml-everywhere-opensource-src-5.15.7.tar.xz 436832 BLAKE2B 1ea08582ab5c64157cb1ac34fdfa66c7f96897007cd0d27dd64834dc9c0d7ee5634636d009bea07d5ba140daa11e4f5ff7f3f948c4e1efafb6b90d5d23f8b1f3 SHA512 ff3fd21b0bba3f092d236d875559d4e992180a2d9e8ffd8a628a5c82518329c99587eeddd90fdd10c340d1bc4c9077a4d439be1a3d7aa0dfe3f1a557ee934bd3
+DIST qtscxml-everywhere-opensource-src-5.15.8.tar.xz 436864 BLAKE2B ada2ac54eaef077da132929a658a461151e5b1c15a02874b80da6334eb5fdca5737126e5caff308fccd0bec96cd07a36b188113b8d26beb7dab9d1e9278598e8 SHA512 f1e560e3091eb60b70e5b7ab187511708d16c1b2e8a0c1a6d7a95358eb3ed998bdf0e57b7855e38a773509805790603e3e8e64627f52f05f305d8a29108db9f2
diff --git a/dev-qt/qtscxml/qtscxml-5.15.8.ebuild b/dev-qt/qtscxml/qtscxml-5.15.8.ebuild
new file mode 100644
index 000000000000..df03cf101cc7
--- /dev/null
+++ b/dev-qt/qtscxml/qtscxml-5.15.8.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt5-build
+
+DESCRIPTION="State Chart XML (SCXML) support library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+IUSE=""
+
+DEPEND="
+ =dev-qt/qtcore-${QT5_PV}*
+ =dev-qt/qtdeclarative-${QT5_PV}*
+"
+RDEPEND="${DEPEND}"