summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/jsonschema-specifications/Manifest1
-rw-r--r--dev-python/jsonschema-specifications/jsonschema-specifications-2024.10.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/jsonschema-specifications/Manifest b/dev-python/jsonschema-specifications/Manifest
index 9003b4f491b0..96721ca33f53 100644
--- a/dev-python/jsonschema-specifications/Manifest
+++ b/dev-python/jsonschema-specifications/Manifest
@@ -1 +1,2 @@
DIST jsonschema_specifications-2023.12.1.tar.gz 13983 BLAKE2B db3cad7a900b114eff4827b6653da9e88b80cedae8f724fe030f373d98c7771f427a9960fa47cbe4d4b677805385a059aca08665271659b3e5ab43719c9d74d1 SHA512 7027641c65a6f7c618fd8c3b91af10bc45604966b6cf50780ca72c31f2135ec9d8b14de35049b4897586ad651b65392bb650d162f3bb546c9d250a8cd257ad30
+DIST jsonschema_specifications-2024.10.1.tar.gz 15561 BLAKE2B 3587ca9c5525f3a8bf91c7e0619fda6d052ec89e11acce0a1aa5c7962fb1b89d54c952d81a5116f596aabfe769c8e9ae687821929d5bf1ad76346b480b2cd2fb SHA512 333efbd81ad787da841fe8526257b4213bff508c91a6a655f2dbe62b22a0347ac8f97230b52e00aabcf626e91026a6c2f5760d54c2078eccd2f033a8599e7484
diff --git a/dev-python/jsonschema-specifications/jsonschema-specifications-2024.10.1.ebuild b/dev-python/jsonschema-specifications/jsonschema-specifications-2024.10.1.ebuild
new file mode 100644
index 000000000000..049d7a5b7174
--- /dev/null
+++ b/dev-python/jsonschema-specifications/jsonschema-specifications-2024.10.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="The JSON Schema meta-schemas and vocabularies, exposed as a Registry"
+HOMEPAGE="
+ https://github.com/python-jsonschema/jsonschema-specifications/
+ https://pypi.org/project/jsonschema-specifications/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/referencing-0.31.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest