summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-benchmarks/interbench/interbench-0.31.ebuild5
-rw-r--r--eclass/ecm.eclass2
-rw-r--r--media-plugins/vdr-joystick/vdr-joystick-0.0.3.ebuild15
-rw-r--r--media-plugins/xbmc-addon-xvdr/xbmc-addon-xvdr-9999.ebuild5
-rw-r--r--media-sound/csound/csound-9999.ebuild21
-rw-r--r--sys-apps/cpuid/Manifest1
-rw-r--r--sys-apps/cpuid/cpuid-20180419.ebuild33
-rw-r--r--sys-apps/cpuid/files/cpuid-20170122-Makefile.patch28
-rw-r--r--sys-apps/cpuid/files/cpuid-20170122-missing-include-sysmacros.patch12
-rw-r--r--x11-plugins/pidgin-telegram/Manifest1
-rw-r--r--x11-plugins/pidgin-telegram/pidgin-telegram-1.4.1.ebuild50
11 files changed, 19 insertions, 154 deletions
diff --git a/app-benchmarks/interbench/interbench-0.31.ebuild b/app-benchmarks/interbench/interbench-0.31.ebuild
index 37ddd5060336..dfa772bcebbb 100644
--- a/app-benchmarks/interbench/interbench-0.31.ebuild
+++ b/app-benchmarks/interbench/interbench-0.31.ebuild
@@ -6,10 +6,7 @@ EAPI=7
inherit toolchain-funcs
DESCRIPTION="A Linux interactivity benchmark"
-HOMEPAGE="
- http://interbench.kolivas.org/
- https://github.com/ckolivas/interbench/
-"
+HOMEPAGE="https://github.com/ckolivas/interbench/"
SRC_URI="https://github.com/ckolivas/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="amd64 x86"
diff --git a/eclass/ecm.eclass b/eclass/ecm.eclass
index ddfe92c1d0b9..1616df9aab57 100644
--- a/eclass/ecm.eclass
+++ b/eclass/ecm.eclass
@@ -159,7 +159,7 @@ fi
# changed unless we also bump EAPI, which usually implies (rev-)bumping.
# Version will later be used to differentiate between KF5/Qt5 and KF6/Qt6.
if [[ ${CATEGORY} = kde-frameworks ]]; then
- : ${KFMIN:=${PV}}
+ : ${KFMIN:=$(ver_cut 1-2)}
fi
: ${KFMIN:=5.64.0}
diff --git a/media-plugins/vdr-joystick/vdr-joystick-0.0.3.ebuild b/media-plugins/vdr-joystick/vdr-joystick-0.0.3.ebuild
index cf1cb9847878..6438dc52b0d4 100644
--- a/media-plugins/vdr-joystick/vdr-joystick-0.0.3.ebuild
+++ b/media-plugins/vdr-joystick/vdr-joystick-0.0.3.ebuild
@@ -1,20 +1,20 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit vdr-plugin-2
DESCRIPTION="VDR plugin: allows using a joystick as a remote control for VDR"
-HOMEPAGE="http://www.powarman.de/vdr_plugins.htm"
-SRC_URI="http://home.arcor.de/andreas.regel/files/joystick/${P}.tgz"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="http://vdr.websitec.de/download/${PN}/${P}.tgz"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND=">=media-video/vdr-1.4.6"
+DEPEND="media-video/vdr"
RDEPEND="${DEPEND}"
src_install() {
@@ -27,9 +27,8 @@ src_install() {
pkg_postinst() {
vdr-plugin-2_pkg_postinst
- echo
- elog "To use the plugin your joystick has to be connected to your game port and its kernel module has to be loaded."
+ elog "To use the plugin your joystick has to be connected to your"
+ elog "game port and its kernel module has to be loaded."
elog "Check configuration file:"
- elog "/etc/vdr/plugins/joystick/mapping.conf"
- echo
+ elog "/etc/vdr/plugins/joystick/mapping.conf\n"
}
diff --git a/media-plugins/xbmc-addon-xvdr/xbmc-addon-xvdr-9999.ebuild b/media-plugins/xbmc-addon-xvdr/xbmc-addon-xvdr-9999.ebuild
index 0c3fcf9b0dad..8f64cf07d266 100644
--- a/media-plugins/xbmc-addon-xvdr/xbmc-addon-xvdr-9999.ebuild
+++ b/media-plugins/xbmc-addon-xvdr/xbmc-addon-xvdr-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit autotools multilib git-r3
@@ -17,6 +17,7 @@ RDEPEND="${DEPEND}"
src_prepare() {
default
+ export STRIP=true
eautoreconf
}
diff --git a/media-sound/csound/csound-9999.ebuild b/media-sound/csound/csound-9999.ebuild
index b0de613cfe23..60dad6bb9926 100644
--- a/media-sound/csound/csound-9999.ebuild
+++ b/media-sound/csound/csound-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit cmake-utils java-pkg-opt-2 python-single-r1 toolchain-funcs
+inherit cmake-utils python-single-r1 toolchain-funcs
if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://github.com/csound/csound.git"
@@ -31,8 +31,6 @@ fltk +fluidsynth +image jack keyboard linear lua luajit nls osc portaudio
portaudio portmidi pulseaudio python samples static-libs stk test +threads +utils
vim-syntax websocket"
-IUSE_LANGS=" de en_US es es_CO fr it ro ru"
-
REQUIRED_USE="
linear? ( double-precision )
lua? ( cxx )
@@ -41,7 +39,6 @@ REQUIRED_USE="
# java? ( cxx )
BDEPEND="
- dev-libs/boost:=
sys-devel/flex
virtual/yacc
chua? ( dev-libs/boost )
@@ -85,10 +82,13 @@ CDEPEND="
python? ( ${PYTHON_DEPS} )
stk? ( media-libs/stk )
utils? ( !media-sound/snd )
- websocket? ( net-libs/libwebsockets )
+ websocket? ( net-libs/libwebsockets:= )
"
RDEPEND="${CDEPEND}"
-DEPEND="${CDEPEND}"
+DEPEND="
+ ${CDEPEND}
+ dev-libs/boost
+"
if [[ ${PV} != "9999" ]]; then
DEPEND+="doc? ( app-arch/unzip )"
@@ -109,14 +109,6 @@ src_prepare() {
sed -e '/set(PLUGIN_INSTALL_DIR/s/-${APIVERSION}//' \
-e '/-O3/d' \
-i CMakeLists.txt || die
-
- local lang
-
- for lang in ${IUSE_LANGS} ; do
- if ! has ${lang} ${LINGUAS-${lang}} ; then
- sed -i "/compile_po(${lang}/d" po/CMakeLists.txt || die
- fi
- done
}
src_configure() {
@@ -216,6 +208,7 @@ src_configure() {
-DPYTHON_MODULE_INSTALL_DIR="$(python_get_sitedir)"
)
+ # this is needed, otherwise it sets LIBRARY INSTALL DIR: lib
[[ $(get_libdir) == "lib64" ]] && mycmakeargs+=(
-DUSE_LIB64=ON
)
diff --git a/sys-apps/cpuid/Manifest b/sys-apps/cpuid/Manifest
index 326f544e1c62..7e34bf03aaf7 100644
--- a/sys-apps/cpuid/Manifest
+++ b/sys-apps/cpuid/Manifest
@@ -1,2 +1 @@
-DIST cpuid-20180419.src.tar.gz 82301 BLAKE2B 6905c0946fb9a930c67718067923c8c238031539c95704664160efde8563b0f56aadf3132abc9833310846802f97330edff833b47c006a4f46fec49358b56e31 SHA512 c8e30e45df7be5bdbff7e449b447b4542326a112f563c114c67cc80764070f3f3815ff4f80ceb57360828061bc9fd5f2f24f8e53ae4db47781f36db32141c951
DIST cpuid-20180519.src.tar.gz 84784 BLAKE2B 87098145a378081d296f0473f9106e7c5b6654c2bd63d385dc27e293079adf3a527801fa644000ede53228e087e9e9afdf807a3c8d9cc8eb93826f01a5a89e9a SHA512 565738c41777669e750a2ef2e122ed0568de5ac8cc2584fa5047ba66d42eb5c3324b283bda25605e055d85402a4e2d109bc6d033ccd34243caab728465792669
diff --git a/sys-apps/cpuid/cpuid-20180419.ebuild b/sys-apps/cpuid/cpuid-20180419.ebuild
deleted file mode 100644
index 0d0367d2cec8..000000000000
--- a/sys-apps/cpuid/cpuid-20180419.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit toolchain-funcs
-
-DESCRIPTION="Utility to get detailed information about the CPU(s) using the CPUID instruction"
-HOMEPAGE="http://www.etallen.com/cpuid.html"
-SRC_URI="http://www.etallen.com/${PN}/${P}.src.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-DEPEND="
- app-arch/gzip
- dev-lang/perl"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-20170122-Makefile.patch
- "${FILESDIR}"/${PN}-20170122-missing-include-sysmacros.patch
-)
-
-src_configure() {
- tc-export CC
-}
-
-src_install() {
- emake BUILDROOT="${ED}" install
- einstalldocs
-}
diff --git a/sys-apps/cpuid/files/cpuid-20170122-Makefile.patch b/sys-apps/cpuid/files/cpuid-20170122-Makefile.patch
deleted file mode 100644
index 9a02a54563aa..000000000000
--- a/sys-apps/cpuid/files/cpuid-20170122-Makefile.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-diff -ru cpuid-20170122.orig/Makefile cpuid-20170122/Makefile
---- cpuid-20170122.orig/Makefile 2017-06-16 06:54:32.993875817 -0700
-+++ cpuid-20170122/Makefile 2017-06-16 06:55:56.622875498 -0700
-@@ -1,9 +1,3 @@
--CFLAGS+=-g
--CPPFLAGS?=
--LDFLAGS?=
--ifneq (,$(findstring arch=i386,$(CFLAGS)))
--CISA=-m32
--endif
- CFL=$(CPPFLAGS) $(CFLAGS) $(CISA) -Wall -Wshadow -Wcast-align -Wredundant-decls -Wbad-function-cast -Wcast-qual -Wwrite-strings -Waggregate-return -Wstrict-prototypes -Wmissing-prototypes -D_FILE_OFFSET_BITS=64 -DVERSION=$(VERSION)
-
- PACKAGE=cpuid
-@@ -51,10 +45,10 @@
- gzip < $< > $@
-
- install: $(PROG) $(PROG).man.gz cpuinfo2cpuid cpuinfo2cpuid.man.gz
-- install -D -s -m 755 $(PROG) $(BUILDROOT)/usr/bin/$(PROG)
-- install -D -m 444 $(PROG).man.gz $(BUILDROOT)/usr/share/man/man1/$(PROG).1.gz
-- install -D -m 755 cpuinfo2cpuid $(BUILDROOT)/usr/bin/cpuinfo2cpuid
-- install -D -m 444 cpuinfo2cpuid.man.gz $(BUILDROOT)/usr/share/man/man1/cpuinfo2cpuid.1.gz
-+ install -D -m 755 $(PROG) $(BUILDROOT)/usr/bin/$(PROG)
-+ install -D -m 444 $(PROG).man.gz $(BUILDROOT)/usr/share/man/man1/$(PROG).1.gz
-+ install -D -m 755 cpuinfo2cpuid $(BUILDROOT)/usr/bin/cpuinfo2cpuid
-+ install -D -m 444 cpuinfo2cpuid.man.gz $(BUILDROOT)/usr/share/man/man1/cpuinfo2cpuid.1.gz
-
- clean:
- rm -f $(PROG) $(PROG).i386 $(PROG).x86_64
diff --git a/sys-apps/cpuid/files/cpuid-20170122-missing-include-sysmacros.patch b/sys-apps/cpuid/files/cpuid-20170122-missing-include-sysmacros.patch
deleted file mode 100644
index bba18a3b3543..000000000000
--- a/sys-apps/cpuid/files/cpuid-20170122-missing-include-sysmacros.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Bug: https://bugs.gentoo.org/show_bug.cgi?id=604406
-
---- a/cpuid.c
-+++ b/cpuid.c
-@@ -30,6 +30,7 @@
- #define _GNU_SOURCE
- #include <stdio.h>
- #include <sys/types.h>
-+#include <sys/sysmacros.h>
- #include <sys/stat.h>
- #include <fcntl.h>
- #include <errno.h>
diff --git a/x11-plugins/pidgin-telegram/Manifest b/x11-plugins/pidgin-telegram/Manifest
index ab08164bedf9..aab75ef96c38 100644
--- a/x11-plugins/pidgin-telegram/Manifest
+++ b/x11-plugins/pidgin-telegram/Manifest
@@ -1,2 +1 @@
-DIST telegram-purple_1.4.1.orig.tar.gz 482389 BLAKE2B 84c753c5dcdb8e66d1ec56d5307d3489780e932032f382e2d026ad4b6529d4c161e677483a794e56e6388cd76164d9b93955828f5cfc7b199ff8fa8314ad8951 SHA512 335da688021d2401122065f9089b86b6ccba6e812b06d8d8bc96e0defbbe693b35c1f981f5bf772ebc2577ab60ac7e97ce08d72361bcd17b27fc11740084ff1a
DIST telegram-purple_1.4.2.orig.tar.gz 484790 BLAKE2B d198ce3d1a5f4d226d48b6ff1cdf6f0899a5a1b79ef74c8ac77afa613aae5ec1cf53c8de69cfbab6b2f70df896be0315a90470f2b0da34d1644103be8e7d96ad SHA512 f2f88de8dd4038adaa1a63f2fa3678dd45ddda051be700d6eca563f4bd5b7c8dcb61fdf60bffb01b3fce0ffd01f7b2524686d997bfe4ca8b191cc7b6ce7375a1
diff --git a/x11-plugins/pidgin-telegram/pidgin-telegram-1.4.1.ebuild b/x11-plugins/pidgin-telegram/pidgin-telegram-1.4.1.ebuild
deleted file mode 100644
index 21c27ac8d19b..000000000000
--- a/x11-plugins/pidgin-telegram/pidgin-telegram-1.4.1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="A libpurple protocol plugin that adds support for the Telegram messenger"
-HOMEPAGE="https://github.com/majn/telegram-purple"
-SRC_URI="https://github.com/majn/telegram-purple/releases/download/v${PV}/telegram-purple_${PV}.orig.tar.gz"
-
-LICENSE="GPL-2+"
-KEYWORDS="amd64 x86"
-SLOT="0"
-IUSE="gcrypt libressl +nls +webp"
-
-RDEPEND="net-im/pidgin
- sys-libs/zlib:=
- gcrypt? ( dev-libs/libgcrypt:0= )
- !gcrypt? (
- libressl? ( dev-libs/libressl:0= )
- !libressl? ( dev-libs/openssl:0= )
- )
- webp? ( media-libs/libwebp:= )"
-
-DEPEND="${RDEPEND}"
-
-BDEPEND="
- nls? ( sys-devel/gettext )
- virtual/pkgconfig
-"
-
-S="${WORKDIR}/telegram-purple"
-
-DOCS=( "AUTHORS" "CHANGELOG.md" "HACKING.md" "HACKING.BUILD.md" "README.md" )
-
-src_prepare() {
- default
-
- # Remove '-Werror' to make it compile
- find -name 'Makefile*' -exec sed -i -e 's/-Werror //' {} + || die
-}
-
-src_configure() {
- local myeconfargs=(
- $(use_enable gcrypt)
- $(use_enable nls translation)
- $(use_enable webp libwebp)
- )
-
- econf "${myeconfargs[@]}"
-}