summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/jaraco-text/jaraco-text-3.11.1-r1.ebuild7
-rw-r--r--dev-python/pyproject-api/Manifest2
-rw-r--r--dev-python/pyproject-api/pyproject-api-1.5.1.ebuild41
-rw-r--r--dev-python/pyproject-api/pyproject-api-1.5.2.ebuild41
-rw-r--r--dev-python/virtualenv/virtualenv-20.23.1.ebuild8
-rw-r--r--dev-python/virtualenv/virtualenv-20.24.0.ebuild8
-rw-r--r--eclass/distutils-r1.eclass16
-rw-r--r--eclass/multibuild.eclass6
-rw-r--r--eclass/pypi.eclass1
-rw-r--r--eclass/python-any-r1.eclass6
-rw-r--r--eclass/python-r1.eclass2
-rw-r--r--eclass/python-utils-r1.eclass17
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-6.5_rc2.ebuild41
-rw-r--r--sys-libs/timezone-data/timezone-data-2023c.ebuild2
15 files changed, 68 insertions, 131 deletions
diff --git a/dev-python/jaraco-text/jaraco-text-3.11.1-r1.ebuild b/dev-python/jaraco-text/jaraco-text-3.11.1-r1.ebuild
index 31140137334d..c1747da85d28 100644
--- a/dev-python/jaraco-text/jaraco-text-3.11.1-r1.ebuild
+++ b/dev-python/jaraco-text/jaraco-text-3.11.1-r1.ebuild
@@ -25,13 +25,6 @@ RDEPEND="
>=dev-python/jaraco-context-4.1.1-r1[${PYTHON_USEDEP}]
>=dev-python/jaraco-functools-3.5.0-r1[${PYTHON_USEDEP}]
"
-BDEPEND="
- test? (
- $(python_gen_cond_dep '
- dev-python/pathlib2[${PYTHON_USEDEP}]
- ' 3.9)
- )
-"
distutils_enable_tests pytest
diff --git a/dev-python/pyproject-api/Manifest b/dev-python/pyproject-api/Manifest
index c551f70376db..bdfd9819129c 100644
--- a/dev-python/pyproject-api/Manifest
+++ b/dev-python/pyproject-api/Manifest
@@ -1,3 +1 @@
-DIST pyproject_api-1.5.1.tar.gz 22081 BLAKE2B 53ee778b4e04cac2f16ecd054adc7fd86373d6402f80d485fe22457252684f774b6a5df23d08cf6c6b1f96964d6dc1b1cc9014415f3d9105ffbb09421f69a11e SHA512 31936d242861027ea892e86219f430371aae18631c92893cefc8fb8fc02315906857ee57e5412eed62bf584e0bd24cca7ba82471c0ac6a72c71e8e93b8285a3e
-DIST pyproject_api-1.5.2.tar.gz 21926 BLAKE2B 337fa749273273e0d4c761876ac1b9ec25c02ad206dd222790717dde44ad82409d5200b94c2b5d35984116b1c88cfa10b93c699e684ff51b3235b936e35fe0ee SHA512 ee12ec0dccce0130bca703886c40ac21802f58fb7683370592f9dabbf83366939f5032d7f55c6b712cfa4fa0cf34d88fc37a05eae9d811b34fe9c7377886b8d7
DIST pyproject_api-1.5.3.tar.gz 22128 BLAKE2B 0004682932717db0926e0e080ee78a9b24a9fc0025769e0cbe300bcf0ed50ddbabb52c257e2860718f87707072701ba2912e0fbf32b5481bd2993fb2b304e7c7 SHA512 719c4a9d747d8b5fbf3ac86c5f828c9fe10592a5dd71f68ffe308a8b73036de6777e32ddbcbaa7a45dcb23d0963555abab3e0fc4ddfc5eaac864b8892a1b67b8
diff --git a/dev-python/pyproject-api/pyproject-api-1.5.1.ebuild b/dev-python/pyproject-api/pyproject-api-1.5.1.ebuild
deleted file mode 100644
index c4ca49c47427..000000000000
--- a/dev-python/pyproject-api/pyproject-api-1.5.1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="API to interact with the python pyproject.toml based projects"
-HOMEPAGE="
- https://github.com/tox-dev/pyproject-api/
- https://pypi.org/project/pyproject-api/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/packaging-23[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
- ' 3.{8..10})
-"
-BDEPEND="
- >=dev-python/hatch-vcs-0.3.0[${PYTHON_USEDEP}]
- test? (
- >=dev-python/pytest-mock-3.10[${PYTHON_USEDEP}]
- >=dev-python/wheel-0.38.4[${PYTHON_USEDEP}]
- >=dev-python/virtualenv-20.17.1[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # requires Python 2 installed
- tests/test_frontend.py::test_can_build_on_python_2
-)
diff --git a/dev-python/pyproject-api/pyproject-api-1.5.2.ebuild b/dev-python/pyproject-api/pyproject-api-1.5.2.ebuild
deleted file mode 100644
index 3bc4973c1714..000000000000
--- a/dev-python/pyproject-api/pyproject-api-1.5.2.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="API to interact with the python pyproject.toml based projects"
-HOMEPAGE="
- https://github.com/tox-dev/pyproject-api/
- https://pypi.org/project/pyproject-api/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-RDEPEND="
- >=dev-python/packaging-23.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
- ' 3.{8..10})
-"
-BDEPEND="
- >=dev-python/hatch-vcs-0.3.0[${PYTHON_USEDEP}]
- test? (
- >=dev-python/pytest-mock-3.10[${PYTHON_USEDEP}]
- >=dev-python/setuptools-67.8[${PYTHON_USEDEP}]
- >=dev-python/wheel-0.40[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # requires Python 2 installed
- tests/test_frontend.py::test_can_build_on_python_2
-)
diff --git a/dev-python/virtualenv/virtualenv-20.23.1.ebuild b/dev-python/virtualenv/virtualenv-20.23.1.ebuild
index ed08b28c6102..97762e957311 100644
--- a/dev-python/virtualenv/virtualenv-20.23.1.ebuild
+++ b/dev-python/virtualenv/virtualenv-20.23.1.ebuild
@@ -48,14 +48,6 @@ BDEPEND="
>=dev-python/packaging-20.0[${PYTHON_USEDEP}]
)
"
-# https://github.com/pypa/virtualenv/issues/2554
-BDEPEND+="
- test? (
- $(python_gen_cond_dep '
- !!<dev-python/virtualenv-20.22[${PYTHON_USEDEP}]
- ' 3.9)
- )
-"
distutils_enable_tests pytest
diff --git a/dev-python/virtualenv/virtualenv-20.24.0.ebuild b/dev-python/virtualenv/virtualenv-20.24.0.ebuild
index 6d1b74b0bebf..c19439bd8ea7 100644
--- a/dev-python/virtualenv/virtualenv-20.24.0.ebuild
+++ b/dev-python/virtualenv/virtualenv-20.24.0.ebuild
@@ -48,14 +48,6 @@ BDEPEND="
>=dev-python/packaging-20.0[${PYTHON_USEDEP}]
)
"
-# https://github.com/pypa/virtualenv/issues/2554
-BDEPEND+="
- test? (
- $(python_gen_cond_dep '
- !!<dev-python/virtualenv-20.22[${PYTHON_USEDEP}]
- ' 3.9)
- )
-"
distutils_enable_tests pytest
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index fd9bf47aa963..658d26f2a440 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -191,6 +191,7 @@ esac
if [[ -z ${_DISTUTILS_R1_ECLASS} ]]; then
_DISTUTILS_R1_ECLASS=1
+inherit flag-o-matic
inherit multibuild multilib multiprocessing ninja-utils toolchain-funcs
if [[ ! ${DISTUTILS_SINGLE_IMPL} ]]; then
@@ -271,8 +272,7 @@ _distutils_set_globals() {
;;
setuptools)
bdep+='
- >=dev-python/setuptools-67.7.2[${PYTHON_USEDEP}]
- >=dev-python/wheel-0.40.0[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-67.8.0-r1[${PYTHON_USEDEP}]
'
;;
sip)
@@ -292,7 +292,7 @@ _distutils_set_globals() {
eqawarn "is enabled."
fi
else
- local setuptools_dep='>=dev-python/setuptools-67.7.2[${PYTHON_USEDEP}]'
+ local setuptools_dep='>=dev-python/setuptools-67.8.0-r1[${PYTHON_USEDEP}]'
case ${DISTUTILS_USE_SETUPTOOLS:-bdepend} in
no|manual)
@@ -1718,7 +1718,7 @@ distutils-r1_python_install() {
# python likes to compile any module it sees, which triggers sandbox
# failures if some packages haven't compiled their modules yet.
addpredict "${EPREFIX}/usr/lib/${EPYTHON}"
- addpredict "${EPREFIX}/usr/lib/pypy3.9"
+ addpredict "${EPREFIX}/usr/lib/pypy3.10"
addpredict "${EPREFIX}/usr/local" # bug 498232
if [[ ! ${DISTUTILS_SINGLE_IMPL} ]]; then
@@ -1836,6 +1836,12 @@ distutils-r1_run_phase() {
local -x CYTHON_FORCE_REGEN=1
fi
+ # Rust extensions are incompatible with C/C++ LTO compiler
+ # see e.g. https://bugs.gentoo.org/910220
+ if has cargo ${INHERITED}; then
+ filter-lto
+ fi
+
# How to build Python modules in different worlds...
local ldopts
case "${CHOST}" in
@@ -1974,7 +1980,7 @@ _distutils-r1_post_python_compile() {
die "${rscriptdir} should not exist!"
if [[ -d ${bindir} ]]; then
mkdir -p "${rscriptdir}" || die
- cp -a --reflink=auto "${bindir}"/. "${rscriptdir}"/ || die
+ cp -a "${bindir}"/. "${rscriptdir}"/ || die
fi
# enable venv magic inside the install tree
diff --git a/eclass/multibuild.eclass b/eclass/multibuild.eclass
index 33edb9312a86..d8a5862731bf 100644
--- a/eclass/multibuild.eclass
+++ b/eclass/multibuild.eclass
@@ -170,8 +170,7 @@ multibuild_copy_sources() {
_multibuild_create_source_copy() {
einfo "${MULTIBUILD_VARIANT}: copying to ${BUILD_DIR}"
- # enable reflinking if possible to make this faster
- cp -p -R --reflink=auto \
+ cp -p -R \
"${_MULTIBUILD_INITIAL_BUILD_DIR}" "${BUILD_DIR}" || die
}
@@ -190,8 +189,7 @@ multibuild_merge_root() {
local src=${1}
local dest=${2}
- # enable reflinking if possible to make this faster
- cp -a --reflink=auto "${src}"/. "${dest}"/ || die "${MULTIBUILD_VARIANT:-(unknown)}: merging image failed"
+ cp -a "${src}"/. "${dest}"/ || die "${MULTIBUILD_VARIANT:-(unknown)}: merging image failed"
rm -rf "${src}" || die
}
diff --git a/eclass/pypi.eclass b/eclass/pypi.eclass
index 594216a7fd96..b80ff9c95d36 100644
--- a/eclass/pypi.eclass
+++ b/eclass/pypi.eclass
@@ -105,6 +105,7 @@ _pypi_translate_version() {
local version=${1}
version=${version/_alpha/a}
version=${version/_beta/b}
+ version=${version/_pre/.dev}
version=${version/_rc/rc}
_PYPI_TRANSLATED_VERSION=${version/_p/.post}
}
diff --git a/eclass/python-any-r1.eclass b/eclass/python-any-r1.eclass
index d7d44a87f516..4e2e12e228ad 100644
--- a/eclass/python-any-r1.eclass
+++ b/eclass/python-any-r1.eclass
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: python-any-r1.eclass
@@ -176,7 +176,7 @@ _python_any_set_globals() {
_python_export "${i}" PYTHON_PKG_DEP
# note: need to strip '=' slot operator for || deps
- deps="${PYTHON_PKG_DEP/:0=/:0} ${deps}"
+ deps="${PYTHON_PKG_DEP/:=} ${deps}"
done
deps="|| ( ${deps})"
@@ -259,7 +259,7 @@ python_gen_any_dep() {
local i_depstr=${depstr//\$\{PYTHON_USEDEP\}/${PYTHON_USEDEP}}
i_depstr=${i_depstr//\$\{PYTHON_SINGLE_USEDEP\}/${PYTHON_SINGLE_USEDEP}}
# note: need to strip '=' slot operator for || deps
- out="( ${PYTHON_PKG_DEP%=} ${i_depstr} ) ${out}"
+ out="( ${PYTHON_PKG_DEP%:=} ${i_depstr} ) ${out}"
done
echo "|| ( ${out})"
}
diff --git a/eclass/python-r1.eclass b/eclass/python-r1.eclass
index 4758defe6493..b816e3b6f855 100644
--- a/eclass/python-r1.eclass
+++ b/eclass/python-r1.eclass
@@ -522,7 +522,7 @@ python_gen_any_dep() {
local i_depstr=${depstr//\$\{PYTHON_USEDEP\}/${PYTHON_USEDEP}}
i_depstr=${i_depstr//\$\{PYTHON_SINGLE_USEDEP\}/${PYTHON_SINGLE_USEDEP}}
# note: need to strip '=' slot operator for || deps
- out="( ${PYTHON_PKG_DEP/:0=/:0} ${i_depstr} ) ${out}"
+ out="( ${PYTHON_PKG_DEP/:=} ${i_depstr} ) ${out}"
fi
done
echo "|| ( ${out})"
diff --git a/eclass/python-utils-r1.eclass b/eclass/python-utils-r1.eclass
index 40c15b65d7a5..a883135eaa41 100644
--- a/eclass/python-utils-r1.eclass
+++ b/eclass/python-utils-r1.eclass
@@ -238,12 +238,11 @@ _python_impl_matches() {
fi
return 0
;;
- 3.9|3.10)
- # <pypy3-7.3.12 is 3.9, >=7.3.12 is 3.10
+ 3.10)
[[ ${impl} == python${pattern/./_} || ${impl} == pypy3 ]] &&
return 0
;;
- 3.8|3.1[1-2])
+ 3.8|3.9|3.1[1-2])
[[ ${impl} == python${pattern/./_} ]] && return 0
;;
*)
@@ -447,14 +446,12 @@ _python_export() {
PYTHON_PKG_DEP)
local d
case ${impl} in
- python3.10)
- PYTHON_PKG_DEP=">=dev-lang/python-3.10.12:3.10";;
- python3.11)
- PYTHON_PKG_DEP=">=dev-lang/python-3.11.4:3.11";;
- python3.12)
- PYTHON_PKG_DEP=">=dev-lang/python-3.12.0_beta3:3.12";;
+ python*)
+ PYTHON_PKG_DEP="dev-lang/python:${impl#python}"
+ ;;
pypy3)
- PYTHON_PKG_DEP='>=dev-python/pypy3-7.3.11_p1:0=';;
+ PYTHON_PKG_DEP="dev-python/${impl}:="
+ ;;
*)
die "Invalid implementation: ${impl}"
esac
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index adb8ab145f9e..911c9652a8c2 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -1,2 +1,3 @@
DIST linux-6.4.tar.xz 137794856 BLAKE2B b59eb04a8715af9f686978812e6d4a466172bb859f80657076de14cd0828b4fac15b688ff8959f5c65485f7f6bef26590412c66821e720de843cb8666f226c90 SHA512 11a48b25e0b513782d3b89101c2ec8dd9cefd6ce08dc63a91137903b66392aa72ca1fe32816710673af84dd47de3ab8738056a6af93dc0d5e60ef4b869b49928
DIST patch-6.5-rc1.patch 78732464 BLAKE2B b075400393c866b64193e651350457e7f653d26bb67d3e14de002ebbaf2c5cb683b687afd415a063f2fd8738910650c2d303533d0b26e6af904416bf959a9c94 SHA512 a0cce4013ad2281809a770615101cf620f33e3e4774f41942b1705e60fb1180065dd1226bf7b24eb4f4e5e9bcab2591383619dad8a460b94c1f011e779607226
+DIST patch-6.5-rc2.patch 79061119 BLAKE2B 2e993384d957ddcee5798ebe9fdd04dc9a133490b66d9f196eb36379cef3b5e56b75e96cc7baa0a57d40cfbb71517ccf000951b7dbb309277211048fdcbb5583 SHA512 a2c6f329a6cb5f33094735b144cd695f4592d42145f8eb76141a8d37708f35919a613e41f694789a9e06a1171b5830f7c514b37dad54c8b3a4005573267db485
diff --git a/sys-kernel/git-sources/git-sources-6.5_rc2.ebuild b/sys-kernel/git-sources/git-sources-6.5_rc2.ebuild
new file mode 100644
index 000000000000..ddb3116ab32a
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-6.5_rc2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="6.4"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+K_NODRYRUN="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.6-r4"
+
+pkg_postinst() {
+ postinst_sources
+}
diff --git a/sys-libs/timezone-data/timezone-data-2023c.ebuild b/sys-libs/timezone-data/timezone-data-2023c.ebuild
index f5e201286221..30eabb58071a 100644
--- a/sys-libs/timezone-data/timezone-data-2023c.ebuild
+++ b/sys-libs/timezone-data/timezone-data-2023c.ebuild
@@ -14,7 +14,7 @@ SRC_URI="https://www.iana.org/time-zones/repository/releases/tzdata${MY_DATA_VER
LICENSE="BSD public-domain"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
IUSE="nls leaps-timezone zic-slim"
DEPEND="nls? ( virtual/libintl )"