summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/rosdistro/rosdistro-0.8.0.ebuild6
-rw-r--r--dev-python/rosdistro/rosdistro-9999.ebuild7
2 files changed, 13 insertions, 0 deletions
diff --git a/dev-python/rosdistro/rosdistro-0.8.0.ebuild b/dev-python/rosdistro/rosdistro-0.8.0.ebuild
index 5b587a80181e..cf60a935e58c 100644
--- a/dev-python/rosdistro/rosdistro-0.8.0.ebuild
+++ b/dev-python/rosdistro/rosdistro-0.8.0.ebuild
@@ -43,6 +43,12 @@ DEPEND="${RDEPEND}
"
PATCHES=( "${FILESDIR}/yaml.patch" )
+src_prepare() {
+ # Requires network access
+ rm -f test/test_manifest_providers.py
+ default
+}
+
python_test() {
nosetests --with-xunit test || die
}
diff --git a/dev-python/rosdistro/rosdistro-9999.ebuild b/dev-python/rosdistro/rosdistro-9999.ebuild
index 1cf2e00b257c..cf60a935e58c 100644
--- a/dev-python/rosdistro/rosdistro-9999.ebuild
+++ b/dev-python/rosdistro/rosdistro-9999.ebuild
@@ -41,6 +41,13 @@ DEPEND="${RDEPEND}
dev-python/mock[${PYTHON_USEDEP}]
)
"
+PATCHES=( "${FILESDIR}/yaml.patch" )
+
+src_prepare() {
+ # Requires network access
+ rm -f test/test_manifest_providers.py
+ default
+}
python_test() {
nosetests --with-xunit test || die