summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/owslib/Manifest1
-rw-r--r--dev-python/owslib/metadata.xml15
-rw-r--r--dev-python/owslib/owslib-0.16.0.ebuild44
-rw-r--r--sci-geosciences/qgis/qgis-9999.ebuild5
-rw-r--r--sys-auth/elogind/Manifest1
-rw-r--r--sys-auth/elogind/elogind-235.1.ebuild125
-rw-r--r--sys-auth/elogind/files/elogind-235.1-docs.patch20
7 files changed, 209 insertions, 2 deletions
diff --git a/dev-python/owslib/Manifest b/dev-python/owslib/Manifest
new file mode 100644
index 000000000000..54d45a8500a3
--- /dev/null
+++ b/dev-python/owslib/Manifest
@@ -0,0 +1 @@
+DIST owslib-0.16.0.tar.gz 658145 BLAKE2B 8e32de48192579f10515771c1682b1d1319deb8195ff9c0f9168ea82bb30bbc8bcf7c457c794a79b1121d40f3f544624f0a9789b0f6f36632c6457f396fa78c9 SHA512 a468352dfdb62bea1e6189efcc198237cb909051e51782abb15093e328ca7d3d379e88d0466e42c39ce9bc201a3be828a779193666bf9befe8d501355aaddbf4
diff --git a/dev-python/owslib/metadata.xml b/dev-python/owslib/metadata.xml
new file mode 100644
index 000000000000..01e0addb55f2
--- /dev/null
+++ b/dev-python/owslib/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-geosciences@gentoo.org</email>
+ <name>Gentoo Geosciences Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">geopython/OWSLib</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/owslib/owslib-0.16.0.ebuild b/dev-python/owslib/owslib-0.16.0.ebuild
new file mode 100644
index 000000000000..905b9c4e1098
--- /dev/null
+++ b/dev-python/owslib/owslib-0.16.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_5 )
+inherit distutils-r1
+
+DESCRIPTION="Library for client programming with Open Geospatial Consortium web service"
+HOMEPAGE="https://geopython.github.io/OWSLib"
+SRC_URI="https://github.com/geopython/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/pyproj[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ || (
+ dev-python/elementtree[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/tox[${PYTHON_USEDEP}]
+ )
+"
+
+RESTRICT="test" # tests require WAN access
+
+S="${WORKDIR}/OWSLib-${PV}"
+
+python_test() {
+ "${EPYTHON}" "${S}/setup.py" test || die
+}
diff --git a/sci-geosciences/qgis/qgis-9999.ebuild b/sci-geosciences/qgis/qgis-9999.ebuild
index 3bb8a29f2390..a167a5305cf5 100644
--- a/sci-geosciences/qgis/qgis-9999.ebuild
+++ b/sci-geosciences/qgis/qgis-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python3_{4,5,6} )
+PYTHON_COMPAT=( python3_5 )
PYTHON_REQ_USE="sqlite"
QT_MIN_VER="5.9.1"
@@ -67,6 +67,7 @@ COMMON_DEPEND="
dev-python/httplib2[${PYTHON_USEDEP}]
dev-python/jinja[${PYTHON_USEDEP}]
dev-python/markupsafe[${PYTHON_USEDEP}]
+ dev-python/owslib[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]
dev-python/PyQt5[sql,svg,webkit?,${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
diff --git a/sys-auth/elogind/Manifest b/sys-auth/elogind/Manifest
index 881f2e6c750d..9466285a9383 100644
--- a/sys-auth/elogind/Manifest
+++ b/sys-auth/elogind/Manifest
@@ -1 +1,2 @@
DIST elogind-234.4.tar.gz 973370 BLAKE2B 4fe00d2e22e3f94dfb6385fe61825be72ad2200f1368807ea816a971104cf384e3508ecf2877fa08394c6d0259874b2ceb7c4014f9e861dcd3b19c01bcd04602 SHA512 2df4fa318074d4f5e5dbba353cf817068a2703ffed40cdeae4cba2dea4ee143d1c5fc076b19419f1c4299392088c2c14b430d8aa1ded03b62117311802305d5e
+DIST elogind-235.1.tar.gz 975726 BLAKE2B 2497be9bfc89e8d7eef1cc0a0880b5801940df282ba1c8e62031dcf888bcc107d071fe6d61f0e383a779829eafb060f421140d8c3c998937eec1c333ed7d0d13 SHA512 96442d073f4437c4432419cfaed3dc6f0323fc6967ae01b64ee07ae9a91d99084ba0066825a723a8a58ffff4c0a47150d64d40ff4dcc15a6250423dd5c358c38
diff --git a/sys-auth/elogind/elogind-235.1.ebuild b/sys-auth/elogind/elogind-235.1.ebuild
new file mode 100644
index 000000000000..ca89c99114d7
--- /dev/null
+++ b/sys-auth/elogind/elogind-235.1.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info meson pam udev xdg-utils
+
+DESCRIPTION="The systemd project's logind, extracted to a standalone package"
+HOMEPAGE="https://github.com/elogind/elogind"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="CC0-1.0 LGPL-2.1+ public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+acl debug doc +pam +policykit selinux"
+
+COMMON_DEPEND="
+ sys-apps/util-linux
+ sys-libs/libcap
+ virtual/libudev:=
+ acl? ( sys-apps/acl )
+ pam? ( virtual/pam )
+ selinux? ( sys-libs/libselinux )
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.2
+ app-text/docbook-xml-dtd:4.5
+ app-text/docbook-xsl-stylesheets
+ dev-util/gperf
+ dev-util/intltool
+ sys-devel/libtool
+ virtual/pkgconfig
+"
+RDEPEND="${COMMON_DEPEND}
+ !sys-apps/systemd
+"
+PDEPEND="
+ sys-apps/dbus
+ policykit? ( sys-auth/polkit )
+"
+
+PATCHES=( "${FILESDIR}/${P}-docs.patch" )
+
+pkg_setup() {
+ local CONFIG_CHECK="~CGROUPS ~EPOLL ~INOTIFY_USER ~SIGNALFD ~TIMERFD"
+
+ if use kernel_linux; then
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ default
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs cgroupmode rccgroupmode
+
+ rccgroupmode="$(grep rc_cgroup_mode /etc/rc.conf | cut -d '"' -f 2)"
+ cgroupmode="legacy"
+
+ if [ "xhybrid" = "x${rccgroupmode}" ] ; then
+ cgroupmode="hybrid"
+ elif [ "xunified" = "x${rccgroupmode}" ] ; then
+ cgroupmode="unified"
+ fi
+
+ emesonargs=(
+ -Ddocdir="${EPREFIX}/usr/share/doc/${P}" \
+ -Dhtmldir="${EPREFIX}/usr/share/doc/${P}/html" \
+ -Dpamlibdir=$(getpam_mod_dir) \
+ -Dudevrulesdir="$(get_udevdir)"/rules.d \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ -Drootlibdir="${EPREFIX}"/$(get_libdir) \
+ -Drootlibexecdir="${EPREFIX}"/$(get_libdir)/elogind \
+ -Drootprefix="${EPREFIX}/" \
+ -Dsmack=true \
+ -Dman=auto \
+ -Dhtml=$(usex doc auto false) \
+ -Dcgroup-controller=openrc \
+ -Ddefault-hierarchy=${cgroupmode} \
+ -Ddebug=$(usex debug elogind false) \
+ --buildtype $(usex debug debug release) \
+ -Dacl=$(usex acl true false) \
+ -Dpam=$(usex pam true false) \
+ -Dselinux=$(usex selinux true false)
+ -Dbashcompletiondir="${EPREFIX}/usr/share/bash-completion/completions" \
+ -Dzsh-completion="${EPREFIX}/usr/share/zsh/site-functions" \
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ newinitd "${FILESDIR}"/${PN}.init ${PN}
+
+ sed -e "s/@libdir@/$(get_libdir)/" "${FILESDIR}"/${PN}.conf.in > ${PN}.conf || die
+ newconfd ${PN}.conf ${PN}
+}
+
+pkg_postinst() {
+ if [ "$(rc-config list boot | grep elogind)" != "" ]; then
+ ewarn "elogind is currently started from boot runlevel."
+ elif [ "$(rc-config list default | grep elogind)" != "" ]; then
+ ewarn "elogind is currently started from default runlevel."
+ ewarn "Please remove elogind from the default runlevel and"
+ ewarn "add it to the boot runlevel by:"
+ ewarn "# rc-update del elogind default"
+ ewarn "# rc-update add elogind boot"
+ else
+ ewarn "elogind is currently not started from any runlevel."
+ ewarn "You may add it to the boot runlevel by:"
+ ewarn "# rc-update add elogind boot"
+ fi
+ ewarn "Alternatively you can leave elogind out of any"
+ ewarn "runlevel. It will then be started automatically"
+ if use pam; then
+ ewarn "when the first service calls it via dbus, or the"
+ ewarn "first user logs into the system."
+ else
+ ewarn "when the first service calls it via dbus."
+ fi
+}
diff --git a/sys-auth/elogind/files/elogind-235.1-docs.patch b/sys-auth/elogind/files/elogind-235.1-docs.patch
new file mode 100644
index 000000000000..bb28bf412d4a
--- /dev/null
+++ b/sys-auth/elogind/files/elogind-235.1-docs.patch
@@ -0,0 +1,20 @@
+--- a/meson.build 2018-01-14 18:59:36.141461154 +0100
++++ b/meson.build 2018-01-14 19:00:46.208461781 +0100
+@@ -2634,16 +2634,7 @@
+ # install_data('modprobe.d/systemd.conf',
+ # install_dir : modprobedir)
+ #endif // 0
+-install_data('README',
+- 'NEWS',
+- 'CODING_STYLE',
+-#if 0 /// UNNEEDED by elogind
+-# 'DISTRO_PORTING',
+-# 'ENVIRONMENT.md',
+-#endif // 0
+- 'LICENSE.GPL2',
+- 'LICENSE.LGPL2.1',
+- 'src/libelogind/sd-bus/GVARIANT-SERIALIZATION',
++install_data('src/libelogind/sd-bus/GVARIANT-SERIALIZATION',
+ install_dir : docdir)
+
+ meson.add_install_script('sh', '-c', mkdir_p.format(systemdstatedir))