summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/PyGithub/Manifest1
-rw-r--r--dev-python/PyGithub/PyGithub-1.54.1.ebuild28
-rw-r--r--dev-python/cssutils/cssutils-1.0.2-r2.ebuild2
-rw-r--r--dev-python/fakeredis/Manifest1
-rw-r--r--dev-python/fakeredis/fakeredis-1.4.4.ebuild44
-rw-r--r--dev-python/pypeg2/pypeg2-2.15.2-r1.ebuild2
-rw-r--r--dev-python/thrift/Manifest1
-rw-r--r--dev-python/thrift/thrift-0.13.0.ebuild26
-rw-r--r--dev-ruby/webmock/Manifest1
-rw-r--r--dev-ruby/webmock/webmock-3.11.0.ebuild65
-rw-r--r--www-apps/baikal/Manifest2
-rw-r--r--www-apps/baikal/baikal-0.6.1.ebuild2
-rw-r--r--www-apps/baikal/baikal-0.7.1.ebuild2
-rw-r--r--www-apps/baikal/baikal-0.7.2.ebuild (renamed from www-apps/baikal/baikal-0.6.0.ebuild)9
-rw-r--r--www-client/qutebrowser/qutebrowser-1.14.1.ebuild2
-rw-r--r--www-client/qutebrowser/qutebrowser-9999.ebuild2
16 files changed, 134 insertions, 56 deletions
diff --git a/dev-python/PyGithub/Manifest b/dev-python/PyGithub/Manifest
index 44fa66eabf28..ad10311466ac 100644
--- a/dev-python/PyGithub/Manifest
+++ b/dev-python/PyGithub/Manifest
@@ -1,2 +1,3 @@
DIST PyGithub-1.53.gh.tar.gz 3026570 BLAKE2B 7204c5934b94d5629b38e841a9c9011ea561ca8aa8d3d169915975fb02fe8db059fcb521d11bbb2350a806457d98abbfe36a19c4e5f633c82cdf06b8b7203c6d SHA512 f98d013d5fdf31ee59405c52edb35942ca5a3d2c1ff9653c71f03871bb28d0c247412bfc2593991026ddb989e1a33dfe91d19b4ebb1e89386b54493d51071768
+DIST PyGithub-1.54.1.gh.tar.gz 3117667 BLAKE2B 1cf44acf8e69674dee8440162151236eead3af78e2ea9d1c57d7c9217b7249fbc1d8ca10f15e79f8f27ae9cd5ad126376b1702ac4d9758e4f0b0acf6e85eab22 SHA512 72aecef168c8741b773560bee31b0b6159abeea97cc9f659363ff9204eed610686fdaf6461dab0c643adf00140a53aa86d70b9011b39522650aa872f02e5e67e
DIST PyGithub-1.54.gh.tar.gz 3117061 BLAKE2B d180b9c0192ad22b84cb17ff6c9a7c4ad4d490c149549515727a0f1ab4e572461d461cdcd4138a0d9f03f26b0a689579bd7ec875896330a3c43e5cfb45411dc7 SHA512 c716df1f6dc64ea6bc56db82b0f0263dc0ec29994ea9fa967c22a0eee07c4ccd206f14168e36df7d913cfa387ecca703cd2331cd549bd42ebbec0e33ecd15c44
diff --git a/dev-python/PyGithub/PyGithub-1.54.1.ebuild b/dev-python/PyGithub/PyGithub-1.54.1.ebuild
new file mode 100644
index 000000000000..f261af35e044
--- /dev/null
+++ b/dev-python/PyGithub/PyGithub-1.54.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to access the Github API v3"
+HOMEPAGE="https://github.com/PyGithub/PyGithub/"
+# Use github since pypi is missing test data
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/deprecated[${PYTHON_USEDEP}]
+ <dev-python/pyjwt-2[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.0[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/httpretty-0.9.6[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
diff --git a/dev-python/cssutils/cssutils-1.0.2-r2.ebuild b/dev-python/cssutils/cssutils-1.0.2-r2.ebuild
index 7b4f6a4808cb..363407545582 100644
--- a/dev-python/cssutils/cssutils-1.0.2-r2.ebuild
+++ b/dev-python/cssutils/cssutils-1.0.2-r2.ebuild
@@ -4,7 +4,7 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
inherit distutils-r1
diff --git a/dev-python/fakeredis/Manifest b/dev-python/fakeredis/Manifest
index da15d3e30829..da5d1c5cd15a 100644
--- a/dev-python/fakeredis/Manifest
+++ b/dev-python/fakeredis/Manifest
@@ -1,2 +1 @@
-DIST fakeredis-1.4.4.gh.tar.gz 65483 BLAKE2B 500346bb96d2c1308d0565a006ca037784ff25670fd313c94df13f0ceb6d90dbec044c71c95bdabbd593823e26b47a8f8f2a2f7f5b3fa9307b9ccea407b2872c SHA512 04b85675b088e698f11edf8727b88544640cac0caa0048f009371a4c9a9ebc17443d8f03c9ead20ca40608f618c4d394cd6ba4c9d1e5e59b058713756856e450
DIST fakeredis-1.4.5.gh.tar.gz 66197 BLAKE2B f0f36d1e209673f7722849e835c2a33fac9f7e8bfb1294ecf2e69478295f14af514d0fc4a5732a20ce099333b136d682591fef031ce90d6262fa8c9025cbfa2e SHA512 e16ae5c5947a924b0c9c40ae68efebad5cccea9f88d1b5c3f1677e1ccb8c1fa75dbafc9b413c2359b774f3043c387ff91ecd4e2e21204036883175944338d59b
diff --git a/dev-python/fakeredis/fakeredis-1.4.4.ebuild b/dev-python/fakeredis/fakeredis-1.4.4.ebuild
deleted file mode 100644
index 989b57bc2d0b..000000000000
--- a/dev-python/fakeredis/fakeredis-1.4.4.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{6..9} )
-inherit distutils-r1
-
-DESCRIPTION="Fake implementation of redis API for testing purposes"
-HOMEPAGE="
- https://github.com/jamesls/fakeredis/
- https://pypi.org/project/fakeredis/"
-SRC_URI="
- https://github.com/jamesls/fakeredis/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ppc ~ppc64 x86"
-
-RDEPEND="
- dev-python/redis-py[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/sortedcontainers[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local excludes=(
- # tests for use with aioredis, not packaged in ::gentoo
- --ignore test/test_aioredis.py
- # tests requiring lupa (lua support)
- -k 'not test_eval and not test_lua and not test_script'
- )
-
- pytest -vv "${excludes[@]}" || die "Tests failed with ${EPYTHON}"
-}
diff --git a/dev-python/pypeg2/pypeg2-2.15.2-r1.ebuild b/dev-python/pypeg2/pypeg2-2.15.2-r1.ebuild
index 75770fae21af..c89a5bf748d7 100644
--- a/dev-python/pypeg2/pypeg2-2.15.2-r1.ebuild
+++ b/dev-python/pypeg2/pypeg2-2.15.2-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
inherit distutils-r1
diff --git a/dev-python/thrift/Manifest b/dev-python/thrift/Manifest
index 1294d7e40874..fce62f8684ff 100644
--- a/dev-python/thrift/Manifest
+++ b/dev-python/thrift/Manifest
@@ -1 +1,2 @@
DIST thrift-0.11.0.tar.gz 52467 BLAKE2B 72dca118476dc5d618f6434614e5d72c6f496088731de9b62fcf47e76dcf707a171721df2aa4c87fdcf90670b8fd11c3a1cdb2b090b78683a3f4a204ef8121cb SHA512 cba59eef2841fa008a19cd36b322491b67d711698205d6671c76e38a3de2b330db8aa54516de8cdd4020dc795e67ed55913df53466f5dbf07d38fed2d10f9349
+DIST thrift-0.13.0.tar.gz 59911 BLAKE2B b45363c2e8bbc5c7fae25533c7df9be49e6ea88b5ce077e9a580c28decf06de608d50100ba77cdb1ce8c7e56b87608d193b8579a4f89cc4fb74d672da0ba7e93 SHA512 063440db324efdae1fc4466133deaedeb1edd2f953f6924191ad819476f7b62a434d52960837e94516a673063ceab8b446b4f7dc8c94bb2d1fb84e95d2fa3d78
diff --git a/dev-python/thrift/thrift-0.13.0.ebuild b/dev-python/thrift/thrift-0.13.0.ebuild
new file mode 100644
index 000000000000..7845b01a7354
--- /dev/null
+++ b/dev-python/thrift/thrift-0.13.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of Thrift"
+HOMEPAGE="https://pypi.org/project/thrift/ https://thrift.apache.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_install() {
+ distutils-r1_python_install
+ python_optimize
+}
+
diff --git a/dev-ruby/webmock/Manifest b/dev-ruby/webmock/Manifest
index 71c55a952e10..a93538b330c4 100644
--- a/dev-ruby/webmock/Manifest
+++ b/dev-ruby/webmock/Manifest
@@ -1,3 +1,4 @@
+DIST webmock-3.11.0.gem 125440 BLAKE2B 8c57ca5b49922a61590595cdeeb5d3306edb3be616fd8e5c68617838831537f2106664201580f645de58322f11e684dfc8404d91139eaead5810c0cb40d5dc1f SHA512 dda7318d32dd88dcd4bc1fee9d1f4644f272348b532cbb59afde2e6a1fc42f359125b28d605ff1a18edac4ed71c00aceb1c67a364c15cfa56092e226588b449c
DIST webmock-3.7.6.gem 122368 BLAKE2B 9bc40971f1eec96d88217544acc67b7abfe6c0815a0696119e12fc5629b4f51e1164ecc982525d2c02fa50c7b1b09548c4831c1d597f06acde04a83227ba0dc9 SHA512 85455495476b22d94b23e34a92db3f0f8cf1aa5bb52ea6a8eb71f5f0bcbdad1edc13dff778c62806ec27850320e9f4e17f12525bbac552e5e105ee1ecd771efd
DIST webmock-3.8.1.gem 122368 BLAKE2B ba956c72f20e2c21cea90b107ef445e42a6995fdb31f9af65c3b561e9e1fbb9fbd299db009a1d83ddfdb473ce030d40aadf6633e23afbd072ee3b4debf7e0be2 SHA512 b1137fabb000469ee88fdd5521756f368463ee49988d5d89b51fa8352362ff249a4849159504834933e5e1248ed9b6791d254528b3cdea461fc9e8e5d92a334c
DIST webmock-3.8.2.gem 122880 BLAKE2B 0cd10f391377749c6420d08434c8e66230612c50bdff86b4dfd098690c006426e241c32bf716e2f8b9ee6c0ce6488d1975b54f3e4cd85cc14d6c7f0880f65701 SHA512 ae6bdda341bea804257d9f9b57d17a65a25d030ee2f5a9b7fff125a5f7881a34584c6b5d26a1e6dd5a49bba56ad5b6e731defecd109e19a5144df4caf90561d4
diff --git a/dev-ruby/webmock/webmock-3.11.0.ebuild b/dev-ruby/webmock/webmock-3.11.0.ebuild
new file mode 100644
index 000000000000..b19c68e80241
--- /dev/null
+++ b/dev-ruby/webmock/webmock-3.11.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26"
+
+RUBY_FAKEGEM_TASK_TEST="test spec NO_CONNECTION=true"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Allows stubbing HTTP requests and setting expectations on HTTP requests"
+HOMEPAGE="https://github.com/bblimke/webmock"
+
+LICENSE="GPL-2"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/addressable-2.3.6
+ >=dev-ruby/crack-0.3.2
+ >=dev-ruby/hashdiff-0.4.0:0
+"
+
+ruby_add_bdepend "test? (
+ dev-ruby/minitest:5
+ dev-ruby/rspec:3
+ >=dev-ruby/test-unit-3.0.0
+ dev-ruby/rack
+ >=dev-ruby/httpclient-2.8.0
+ || ( dev-ruby/http:4 dev-ruby/http:3 ) )"
+
+all_ruby_prepare() {
+ # Remove bundler support
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+ sed -i -e '/simplecov/I s:^:#:' spec/spec_helper.rb || die
+ sed -i -e '1igem "test-unit"' test/test_helper.rb || die
+
+ # There is now optional support for curb and typhoeus which we don't
+ # have in Gentoo yet. em_http_request is available in Gentoo but its
+ # version is too old. patron's latest version is not compatible.
+ sed -i -e '/\(curb\|typhoeus\|em-http\|patron\)/d' spec/spec_helper.rb || die
+ rm spec/acceptance/{typhoeus,curb,excon,em_http_request,patron,async_http_client}/* || die
+
+ # Avoid httpclient specs that require network access, most likely
+ # because mocking does not fully work.
+ sed -i -e '/httpclient streams response/,/^ end/ s:^:#:' \
+ -e '/are detected when manually specifying Authorization header/,/^ end/ s:^:#:' \
+ spec/acceptance/httpclient/httpclient_spec.rb
+
+ # Avoid specs that require network access
+ sed -i -e '/when request is not stubbed/,/^ end/ s:^:#:' spec/acceptance/shared/callbacks.rb
+}
+
+each_ruby_test() {
+ ${RUBY} -S rake test NO_CONNECTION=true || die
+ ${RUBY} -S rspec-3 spec || die
+
+ einfo "Delay to allow the test server to stop"
+ sleep 10
+}
diff --git a/www-apps/baikal/Manifest b/www-apps/baikal/Manifest
index f6f42ce4b17a..fc5ed08bf4d8 100644
--- a/www-apps/baikal/Manifest
+++ b/www-apps/baikal/Manifest
@@ -1,3 +1,3 @@
-DIST baikal-0.6.0.zip 3432758 BLAKE2B db55008e2e971fd8d6edabe38f333c32564ef34cf7f3a93ad9d67083646c9575cdf9ba1d51108c5fe9f5d385a53bd78d1406318f3a72672126b5f31cc032b104 SHA512 75cd3e30c3df4bc5057e14215b320647c9683702171671ed58ac83e12f7770454d81970f036fd96dbb9aefe0928fcf40ae11128687fd261a0dccadf15d148905
DIST baikal-0.6.1.zip 3437686 BLAKE2B f28d3a63166a73571116759df3662c2b19c2eeeebcd7070574dfc3ee8cb046f2d94fdbc4701669291c1bb2cb2b9b92665726127c852c5457cd285f6ffbcc9b00 SHA512 d88ed9fbe1f934d52fd798165675b90972c47c9e138de61e17a14777590ebad5006c1a414a4e0119eb8fa718e01f2aadb6e1d180e23a51fb33e1b5a3539c9e38
DIST baikal-0.7.1.zip 3596673 BLAKE2B ab32dd922a4af0f3858db89c6349f258429d744341a2a362e8d42980e6fb6f5a5892cf4b47b4bd5d0427a7ecd599705a42d3c11a391c110f2757f6b78cee35b5 SHA512 4a04624ba3158d89d01536e01238b4ea36a40df0c95e93fa676f3e8ebe65eeaa99b241ef346fd4fc71a2f44fab9b6f2ed2bca8c69c780725e424602f4d7d6f54
+DIST baikal-0.7.2.zip 3602276 BLAKE2B 160c1b45944c897e368450da935850749e4dc5c6fdb9607dc6da926a0a05d63b4921193a31fbd64be0c9ddad336ac49f5fc49c23fca5bbb251adca8793265ba9 SHA512 df1fd10c5fb63e6aa89ae4b733eacf102b11f6322c3fa6007d0308574395389c0c6bfd62b7a0d358c54baaa96a5ccdb40bd509258a59e417617bea8d0b3d42a3
diff --git a/www-apps/baikal/baikal-0.6.1.ebuild b/www-apps/baikal/baikal-0.6.1.ebuild
index b8a74120fedd..ba407dd2359c 100644
--- a/www-apps/baikal/baikal-0.6.1.ebuild
+++ b/www-apps/baikal/baikal-0.6.1.ebuild
@@ -15,7 +15,7 @@ IUSE="+mysql sqlite"
REQUIRED_USE="|| ( mysql sqlite )"
DEPEND="app-arch/unzip"
-RDEPEND=">=dev-lang/php-6[ctype,filter,json,pdo,session,xml,xmlreader,xmlwriter,mysql?,sqlite?]
+RDEPEND=">=dev-lang/php-6[ctype,filter,json(+),pdo,session,xml,xmlreader,xmlwriter,mysql?,sqlite?]
mysql? ( virtual/mysql )
sqlite? ( dev-db/sqlite )
virtual/httpd-php"
diff --git a/www-apps/baikal/baikal-0.7.1.ebuild b/www-apps/baikal/baikal-0.7.1.ebuild
index 1c55957ab51e..450d04422760 100644
--- a/www-apps/baikal/baikal-0.7.1.ebuild
+++ b/www-apps/baikal/baikal-0.7.1.ebuild
@@ -15,7 +15,7 @@ IUSE="+mysql sqlite"
REQUIRED_USE="|| ( mysql sqlite )"
DEPEND="app-arch/unzip"
-RDEPEND=">=dev-lang/php-6[ctype,filter,json,pdo,session,xml,xmlreader,xmlwriter,mysql?,sqlite?]
+RDEPEND=">=dev-lang/php-6[ctype,filter,json(+),pdo,session,xml,xmlreader,xmlwriter,mysql?,sqlite?]
mysql? ( virtual/mysql )
sqlite? ( dev-db/sqlite )
virtual/httpd-php"
diff --git a/www-apps/baikal/baikal-0.6.0.ebuild b/www-apps/baikal/baikal-0.7.2.ebuild
index b8a74120fedd..39d0aca079d3 100644
--- a/www-apps/baikal/baikal-0.6.0.ebuild
+++ b/www-apps/baikal/baikal-0.7.2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
inherit webapp
@@ -15,7 +15,7 @@ IUSE="+mysql sqlite"
REQUIRED_USE="|| ( mysql sqlite )"
DEPEND="app-arch/unzip"
-RDEPEND=">=dev-lang/php-6[ctype,filter,json,pdo,session,xml,xmlreader,xmlwriter,mysql?,sqlite?]
+RDEPEND=">=dev-lang/php-6[ctype,filter,json(+),pdo,session,xml,xmlreader,xmlwriter,mysql?,sqlite?]
mysql? ( virtual/mysql )
sqlite? ( dev-db/sqlite )
virtual/httpd-php"
@@ -32,7 +32,7 @@ src_install() {
doins -r html/* html/.htaccess Core vendor
einfo "Setting up container for configuration"
- insinto /etc/${PN}
+ dodir /etc/${PN}
einfo "Fixing symlinks"
local link target
@@ -42,9 +42,10 @@ src_install() {
rm "${link}" && ln -s "${target}" "${link}"
done
dosym /etc/${PN} "${MY_HTDOCSDIR}"/Specific
+ dosym /etc/${PN} "${MY_HTDOCSDIR}"/config
dosym . "${MY_HTDOCSDIR}"/html
- webapp_postinst_txt en "${FILESDIR}/postinstall-en.txt"
+ webapp_postinst_txt en "${FILESDIR}/postinstall-v0.7-en.txt"
webapp_src_install
if has_version www-servers/apache ; then
diff --git a/www-client/qutebrowser/qutebrowser-1.14.1.ebuild b/www-client/qutebrowser/qutebrowser-1.14.1.ebuild
index 2b939071df40..259f9bb5ed56 100644
--- a/www-client/qutebrowser/qutebrowser-1.14.1.ebuild
+++ b/www-client/qutebrowser/qutebrowser-1.14.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{3_7,3_8} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
DISTUTILS_USE_SETUPTOOLS="rdepend"
inherit desktop distutils-r1 optfeature xdg-utils
diff --git a/www-client/qutebrowser/qutebrowser-9999.ebuild b/www-client/qutebrowser/qutebrowser-9999.ebuild
index da981f610aa3..a1932f04f051 100644
--- a/www-client/qutebrowser/qutebrowser-9999.ebuild
+++ b/www-client/qutebrowser/qutebrowser-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
DISTUTILS_USE_SETUPTOOLS="rdepend"
inherit desktop distutils-r1 optfeature xdg-utils