summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/ansi2html/Manifest1
-rw-r--r--dev-python/ansi2html/ansi2html-1.7.0.ebuild51
-rw-r--r--dev-python/ansi2html/ansi2html-1.8.0.ebuild41
3 files changed, 0 insertions, 93 deletions
diff --git a/dev-python/ansi2html/Manifest b/dev-python/ansi2html/Manifest
index 005196d5adea..9f3f47c56933 100644
--- a/dev-python/ansi2html/Manifest
+++ b/dev-python/ansi2html/Manifest
@@ -1,2 +1 @@
-DIST ansi2html-1.7.0.tar.gz 42189 BLAKE2B 91c7409b4f8b7503e719489b18e9d7267d80c5259b7481f127cb8d1e6429649249b0832746285efc3e8a4f90ca8f21b872b002634d47a4a54ddfdcc74df0f576 SHA512 bcae0de9874899bd8440853b8279f3b2c4ed46e24bf807221ddc9d1bfa39647e2efd178aefc2fd39bad27b53890270b6ff7c150a0b8e74581b8323ef7a16c977
DIST ansi2html-1.8.0.tar.gz 44146 BLAKE2B 66672927a64ad38dce0b0819fabc3778f6aba82d176e992630a8db076988a21af8dd445306b8bb580f1539b35044b95de749d6bfb65c27f9b431e4cb6bd562c7 SHA512 cbdda41f206ced5b19761a1ff9747acc6cadca3a5a2f58c97c6073db7d517e59fea7601bba28a8e7e105f3c0c9c4d78ca4f242100cbded6c8a9ca2d598de0ab4
diff --git a/dev-python/ansi2html/ansi2html-1.7.0.ebuild b/dev-python/ansi2html/ansi2html-1.7.0.ebuild
deleted file mode 100644
index a9e347c708c9..000000000000
--- a/dev-python/ansi2html/ansi2html-1.7.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_USE_SETUPTOOLS=pyproject.toml
-
-inherit distutils-r1
-
-DESCRIPTION="Convert text with ANSI color codes to HTML"
-HOMEPAGE="https://pypi.org/project/ansi2html/ https://github.com/pycontribs/ansi2html"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-3+"
-SLOT="0"
-KEYWORDS="amd64 arm ~riscv x86"
-IUSE="doc"
-
-RDEPEND=">=dev-python/six-1.7.3[${PYTHON_USEDEP}]"
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
- doc? (
- app-text/asciidoc
- )
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests --install pytest
-
-src_prepare() {
- # Workaround man page compilation issue with removed setup.py file
- # https://bugs.gentoo.org/841134
- echo '.PHONY: setup.py' >> Makefile
- eapply_user
-}
-
-python_install_all() {
- use doc && doman man/${PN}.1
- distutils-r1_python_install_all
-}
-
-src_compile() {
- # Upstream https://github.com/pycontribs/ansi2html/issues/124
- use doc && emake _MANUAL_VERSION="${PV}" man/ansi2html.1
- distutils-r1_src_compile
-}
diff --git a/dev-python/ansi2html/ansi2html-1.8.0.ebuild b/dev-python/ansi2html/ansi2html-1.8.0.ebuild
deleted file mode 100644
index 5ec4a4804d68..000000000000
--- a/dev-python/ansi2html/ansi2html-1.8.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Convert text with ANSI color codes to HTML"
-HOMEPAGE="https://pypi.org/project/ansi2html/
- https://github.com/pycontribs/ansi2html"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~riscv ~x86"
-IUSE="doc"
-
-RDEPEND=">=dev-python/six-1.7.3[${PYTHON_USEDEP}]"
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
- doc? (
- app-text/asciidoc
- )
-"
-
-distutils_enable_tests pytest
-
-python_install_all() {
- use doc && doman man/${PN}.1
- distutils-r1_python_install_all
-}
-
-src_compile() {
- # Upstream https://github.com/pycontribs/ansi2html/issues/124
- use doc && emake _MANUAL_VERSION="${PV}" man/ansi2html.1
- distutils-r1_src_compile
-}