summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.19.100.ebuild58
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.17.100.ebuild56
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.20.100.ebuild59
-rw-r--r--dev-python/commentjson/Manifest1
-rw-r--r--dev-python/commentjson/commentjson-0.9.0.ebuild28
-rw-r--r--dev-python/commentjson/metadata.xml11
-rw-r--r--dev-python/numpy/files/numpy-1.21.0-no-hardcode-blasv2.patch51
-rw-r--r--profiles/package.mask5
-rw-r--r--sci-libs/scikit-learn/Manifest1
-rw-r--r--sci-libs/scikit-learn/scikit-learn-0.22.2_p1-r1.ebuild71
13 files changed, 267 insertions, 77 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 8307e4a39da6..f95d21cbf10d 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -1,3 +1,4 @@
+DIST awscli-1.19.100.tar.gz 2022522 BLAKE2B 0af348e5e01cc9f3ab421ebdb0bcfe7578bd7578355130951d58ec5b842499527a175c1cb7fae2381f35faab47e7183315c020fcc1d87c29658d45a84c2178f0 SHA512 10a7edf826982e0f1978fe5bb3bb83c1960c1baa353c94533da8877bfb35b022b8a7aae307db9cf526dbc3a80a5f88d16d4f864d3c858d28114afa73e518fcec
DIST awscli-1.19.47.tar.gz 1990843 BLAKE2B c894aaf84d5fe7cb8998fcd682783a1f2e75dd9273a2aa22babe4d57175a1716aefccda50edb96a1203f010dbb2af29cd47d43b5d5f94adfdee1730ab98345af SHA512 7d51022e13609f5f5ab3155e3ac09670c7e49508d67eca8cb477e556e4b06b7643e86bdfe5fa8db59360f6d73e5774b433cb7093c25d6b688f98847b502872b7
DIST awscli-1.19.78.tar.gz 2006020 BLAKE2B 6def90848e033413136865b0176c8d435fb70465f700a82673e9b20378be3792c8e3e59715466a93199358d698c9b58daaa88d6c2e921474460fdef0a214fdba SHA512 ff48f06158d401bf27e2f63c86ade91009dd9a48edf20156d3511ec2685a2dc93e8129a766eb0cc979e81121804dff9f18524e72f8ac1cffc43c4d3ed3595c83
DIST awscli-1.19.79.tar.gz 2006413 BLAKE2B 40b806b7987dcbb83f0d5f7411dd36c5acfddf3927bff00d396724ed178dd114b91a6852fce9f1f1dea44644c3be26c2d1b63f114b5a9eb9b1832cc2f7e5c69e SHA512 1255b2439ba5061987af7f7b418e564c8bccd6d837614405512628a259c2f89acee3a41386b2507c596d9f52b432fa34c615d06ad15787a131bd06397a3b2aab
diff --git a/app-admin/awscli/awscli-1.19.100.ebuild b/app-admin/awscli/awscli-1.19.100.ebuild
new file mode 100644
index 000000000000..ff429f8d3a3e
--- /dev/null
+++ b/app-admin/awscli/awscli-1.19.100.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="https://pypi.org/project/awscli/"
+#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/aws/aws-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/aws-cli-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# botocore is x.(y+1).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 1)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.4.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install nose
+
+PATCHES=(
+ "${FILESDIR}"/awscli-1.19.47-py39.patch
+)
+
+python_test() {
+ distutils_install_for_testing
+ # integration tests require AWS credentials and Internet access
+ nosetests -v tests/{functional,unit} ||
+ die "Tests failed for ${EPYTHON}"
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index fa6b9dd10f2f..ca43a4aa70a4 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -1,3 +1,4 @@
+DIST boto3-1.17.100.tar.gz 385310 BLAKE2B fef5fb0cf4862819c05efa3eb793cf2c9756c003aa4de2c8288a0b46d2f6f2cace53ba09429761437073fac366ad73cc1e816b480a22d42f1d3b9c5160fc3a07 SHA512 2d137d2dc6265a784af961b4e61faddf2a9b9493fc281da9764fd1ef8e855777d48daeaef7380e9d83408c6358e33c2898ad60c95e685bc04a9821cb0b2cfc3b
DIST boto3-1.17.54.tar.gz 362224 BLAKE2B d67ea9a2833d4cf6ec50fc4eab9c194f813f92ef00fa0d1638e0dca0bf03a92fa5208707b3ceda70759231aa69c35bf83028eada42d04209a55d05daf37ce764 SHA512 795a78807e8aad9ba53b196ac6b3547e23d2f7cc962a34121280fe47dfa8f99eac19765c87817918c6ee36dfb7e2b647e5646b7da27eb67900f29430bfe2fb5c
DIST boto3-1.17.74.tar.gz 371719 BLAKE2B f6d44206a14cdf395c8963be048e81391ecbf6817b1c00e1cd081abf111df8bd85c05fa1c04b013de7e6d916835e4876cc961891c8d52d8a32e41713080ed96e SHA512 a79012072238286561ab43ca7bb9f24236e858e0bf550be9a074517145445d0d520cc207683d99f6f704416f617b5f89468c87357223db9564e4310a2a2676f1
DIST boto3-1.17.78.tar.gz 374487 BLAKE2B 8a83cb32db8336351454251a3cf78efad6197885a66c10a4e3f9e13770d92d7cd9e9b51bfc7c4bfdb2f5183c5246872d7f3075d55b5129606ad9d977ecbf9891 SHA512 8ab9f13360f63342219d7b0278e2ca5613f8d051d006ef26da14307e83fcaaf1a546c566cb4b8ba012fa5e8e6b5e409722228da0989e56f50e40df4a733602de
diff --git a/dev-python/boto3/boto3-1.17.100.ebuild b/dev-python/boto3/boto3-1.17.100.ebuild
new file mode 100644
index 000000000000..666cbfa63e3f
--- /dev/null
+++ b/dev-python/boto3/boto3-1.17.100.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 72e78200f120..c2c5ca83d412 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -1,3 +1,4 @@
+DIST botocore-1.20.100.tar.gz 7870739 BLAKE2B 0af8337b44f78f0d66062c3e351e6c2805ab4e205e1404a698bad7240abf37f4fd47206c9b3f9a302053c933ab774e8842edefa38979b09d5b111b836137119f SHA512 af20cf638e48375b0adbadac5329aa62008def72e158159acbcdc200b250c0ac27e0ea568cd216ad8e81772b42491efed5a271f186d9caf0dc7e3bbf0197b7c6
DIST botocore-1.20.54.tar.gz 7650344 BLAKE2B 2dd0a3f8c7c5665e849cf74b663a88e63416f1dea8ca3ee7dbdf10cf35239d466919f2ae4b3c9a639b9e25a23d982b723b24f32ece43715d40283e96e3bf10f6 SHA512 77cdaf68378836205c94c7dfd8424f9ca44ac822fd418d323df30639157bb38e5534fcfbc5bb6cdd7695bec62e24a1d52b81a0be54b0f69f16d20c5182db004b
DIST botocore-1.20.74.tar.gz 7729804 BLAKE2B 0693da2be219ee140c5c00a540756d31651d3e4c78976a7f766705123e9fba23e98d73e551b86a6b661530c20abb560b0e36fea8e1c13600303894b3163d2274 SHA512 51bcf78c6804b4a8cddd57eeff96d7ecb65731dfbd87eb665de1356c1daedb4317323b3a0d905e3d459800d800ce6d6ffd8fd1239b26ecf56884bee37159f2b7
DIST botocore-1.20.78.tar.gz 7758829 BLAKE2B af13d6c1aa918e2c49c6dc931c9a78e1899c83e62657c063e20ba2a5544c48e4946018628e47d6a56db456a3a8d43fe3b577824bd76bbc339abaef375459932e SHA512 fc96ed8b6b4af05404654e470a4f83419b885fa32d9dc704727f4ffb3d5deeefa752d235b37fd81448b7f3b101bc0f8e7ea09ae8641f8961566f77f6a039cef9
diff --git a/dev-python/botocore/botocore-1.20.100.ebuild b/dev-python/botocore/botocore-1.20.100.ebuild
new file mode 100644
index 000000000000..762144aabf71
--- /dev/null
+++ b/dev-python/botocore/botocore-1.20.100.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/commentjson/Manifest b/dev-python/commentjson/Manifest
new file mode 100644
index 000000000000..e90fbebd7c55
--- /dev/null
+++ b/dev-python/commentjson/Manifest
@@ -0,0 +1 @@
+DIST commentjson-0.9.0.gh.tar.gz 15297 BLAKE2B a857b0fa5551079d3d37bff94fb51a903e998c4fb84e0f62a5de28d6eafe0cb8a38b3215515e72c56de0cddb661f109921c801d15b9ba93771290135adaaa5b1 SHA512 cd3d28adecbc445ed3faed7847c65a23829f408cf8aa3fa85544a0f0cf9fa5544b8aff560725cf51921f249123daf9ce9953069e99ca64a312bb4bff652512fe
diff --git a/dev-python/commentjson/commentjson-0.9.0.ebuild b/dev-python/commentjson/commentjson-0.9.0.ebuild
new file mode 100644
index 000000000000..b64b47221b1b
--- /dev/null
+++ b/dev-python/commentjson/commentjson-0.9.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Add Python and JavaScript style comments in your JSON files"
+HOMEPAGE="
+ https://pypi.org/project/commentjson/
+ https://github.com/vaidik/commentjson/"
+SRC_URI="
+ https://github.com/vaidik/commentjson/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/lark-parser[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/six[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests unittest
diff --git a/dev-python/commentjson/metadata.xml b/dev-python/commentjson/metadata.xml
new file mode 100644
index 000000000000..f4168a14251e
--- /dev/null
+++ b/dev-python/commentjson/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">commentjson</remote-id>
+ <remote-id type="github">vaidik/commentjson</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/numpy/files/numpy-1.21.0-no-hardcode-blasv2.patch b/dev-python/numpy/files/numpy-1.21.0-no-hardcode-blasv2.patch
new file mode 100644
index 000000000000..bc3fbda4bf29
--- /dev/null
+++ b/dev-python/numpy/files/numpy-1.21.0-no-hardcode-blasv2.patch
@@ -0,0 +1,51 @@
+diff --git a/numpy/distutils/system_info.py b/numpy/distutils/system_info.py
+index 82e864a5c..1d77e5854 100644
+--- a/numpy/distutils/system_info.py
++++ b/numpy/distutils/system_info.py
+@@ -501,33 +501,7 @@ def get_info(name, notfound_action=0):
+ 1 - display warning message
+ 2 - raise error
+ """
+- cl = {'atlas': atlas_info, # use lapack_opt or blas_opt instead
+- 'atlas_threads': atlas_threads_info, # ditto
+- 'atlas_blas': atlas_blas_info,
+- 'atlas_blas_threads': atlas_blas_threads_info,
+- 'lapack_atlas': lapack_atlas_info, # use lapack_opt instead
+- 'lapack_atlas_threads': lapack_atlas_threads_info, # ditto
+- 'atlas_3_10': atlas_3_10_info, # use lapack_opt or blas_opt instead
+- 'atlas_3_10_threads': atlas_3_10_threads_info, # ditto
+- 'atlas_3_10_blas': atlas_3_10_blas_info,
+- 'atlas_3_10_blas_threads': atlas_3_10_blas_threads_info,
+- 'lapack_atlas_3_10': lapack_atlas_3_10_info, # use lapack_opt instead
+- 'lapack_atlas_3_10_threads': lapack_atlas_3_10_threads_info, # ditto
+- 'flame': flame_info, # use lapack_opt instead
+- 'mkl': mkl_info,
+- # openblas which may or may not have embedded lapack
+- 'openblas': openblas_info, # use blas_opt instead
+- # openblas with embedded lapack
+- 'openblas_lapack': openblas_lapack_info, # use blas_opt instead
+- 'openblas_clapack': openblas_clapack_info, # use blas_opt instead
+- 'blis': blis_info, # use blas_opt instead
+- 'lapack_mkl': lapack_mkl_info, # use lapack_opt instead
+- 'blas_mkl': blas_mkl_info, # use blas_opt instead
+- 'accelerate': accelerate_info, # use blas_opt instead
+- 'openblas64_': openblas64__info,
+- 'openblas64__lapack': openblas64__lapack_info,
+- 'openblas_ilp64': openblas_ilp64_info,
+- 'openblas_ilp64_lapack': openblas_ilp64_lapack_info,
++ cl = {'flame': flame_info, # use lapack_opt instead
+ 'x11': x11_info,
+ 'fft_opt': fft_opt_info,
+ 'fftw': fftw_info,
+@@ -947,10 +921,7 @@ def get_libs(self, key, default):
+ return [b for b in [a.strip() for a in libs.split(',')] if b]
+
+ def get_libraries(self, key='libraries'):
+- if hasattr(self, '_lib_names'):
+- return self.get_libs(key, default=self._lib_names)
+- else:
+- return self.get_libs(key, '')
++ return self.get_libs(key, '')
+
+ def library_extensions(self):
+ c = customized_ccompiler()
diff --git a/profiles/package.mask b/profiles/package.mask
index 2ee622348cb7..0bec4a6b853e 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -32,11 +32,6 @@
#--- END OF EXAMPLES ---
-# Sam James <sam@gentoo.org> (2021-06-25)
-# Missing patch file for now.
-# bug #798471
-=dev-python/numpy-1.21.0
-
# Volkmar W. Pogatzki <gentoo@pogatzki.net> (2021-06-21)
# library with no consumer, removal in 30 days
# see https://bugs.gentoo.org/794562
diff --git a/sci-libs/scikit-learn/Manifest b/sci-libs/scikit-learn/Manifest
index ca041d4e5182..f406527664be 100644
--- a/sci-libs/scikit-learn/Manifest
+++ b/sci-libs/scikit-learn/Manifest
@@ -1,2 +1 @@
-DIST scikit-learn-0.22.2_p1.tar.gz 7034850 BLAKE2B 41c362ef6594e837a9fc798837e666fbb51e33954fdf700292650204fd9d1ab4fc4d1695890d02a24ad68f4dcc2d3cde8f0827eca70c6fb9a6f0e5c0d9c04fd5 SHA512 20bcda5c65f76bce9b71c5b5fb1b499f7f3a7a3f6fa5fade80a38dc658cb434e16e9d5a4906a9657157a5cc90a6d51080575d6e510207baa9f8b06c4fa761d5b
DIST scikit-learn-0.24.2.tar.gz 7589697 BLAKE2B a5a32db690e76d6ecfcb12d57a7f84ebcc7e67ecb73258c1d923f9b98a9d87c46aac96918ef7c3d8741f5dbeb46f169c73a7744fb7b92e6ab5cf42101a6bc2f1 SHA512 2159baf63414b9594918b40e1b72af2ab47349335ad4e3afd9756921f786737ed41d6deb333881e8c5c6e1f7ce9cfa10691b966dc2476c48c051621f9049d2ee
diff --git a/sci-libs/scikit-learn/scikit-learn-0.22.2_p1-r1.ebuild b/sci-libs/scikit-learn/scikit-learn-0.22.2_p1-r1.ebuild
deleted file mode 100644
index 65589e8274da..000000000000
--- a/sci-libs/scikit-learn/scikit-learn-0.22.2_p1-r1.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8} )
-inherit distutils-r1
-
-MY_PV="${PV//_p/.post}"
-
-DESCRIPTION="Machine learning library for Python"
-HOMEPAGE="https://scikit-learn.org/stable/"
-SRC_URI="https://github.com/scikit-learn/scikit-learn/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
-#ffhttps://github.com/scikit-learn/scikit-learn/archive/0.22.2.post1.tar.gz
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~ppc64 x86"
-IUSE="examples"
-
-RDEPEND="
- dev-python/wheel[${PYTHON_USEDEP}]
- dev-python/cython[${PYTHON_USEDEP}]
- dev-python/joblib[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- virtual/blas:=
- virtual/cblas:=
-"
-DEPEND="
- virtual/blas:=
- virtual/cblas:=
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # scikits-learn now uses the horrible numpy.distutils automagic
- export SCIPY_FCONFIG="config_fc --noopt --noarch"
-
- # remove bundled cblas
- rm -rf sklearn/src || die "failed to remove bundled cblas"
-
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- distutils-r1_python_compile ${SCIPY_FCONFIG}
-}
-
-python_test() {
- distutils_install_for_testing ${SCIPY_FCONFIG}
- pushd "${TEST_DIR}/lib" >/dev/null || die
- pytest -vv || die "testing failed with ${EPYTHON}"
- popd >/dev/null || die
-}
-
-python_install() {
- distutils-r1_python_install ${SCIPY_FCONFIG}
-}
-
-python_install_all() {
- find "${S}" -name \*LICENSE.txt -delete
- distutils-r1_python_install_all
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
-}