summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/botocore/botocore-1.15.48.ebuild7
-rw-r--r--eclass/distutils-r1.eclass4
2 files changed, 9 insertions, 2 deletions
diff --git a/dev-python/botocore/botocore-1.15.48.ebuild b/dev-python/botocore/botocore-1.15.48.ebuild
index 1c38902f7a11..cc5f5d311549 100644
--- a/dev-python/botocore/botocore-1.15.48.ebuild
+++ b/dev-python/botocore/botocore-1.15.48.ebuild
@@ -43,6 +43,13 @@ DEPEND="
PATCHES=( "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch" )
+src_prepare() {
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
python_compile_all() {
use doc && emake -C docs html
}
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 8fa343ae75f7..d29abf71fe30 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -403,13 +403,13 @@ distutils_enable_tests() {
local test_pkg
case ${1} in
nose)
- test_pkg="dev-python/nose"
+ test_pkg=">=dev-python/nose-1.3.7-r4"
python_test() {
nosetests -v || die "Tests fail with ${EPYTHON}"
}
;;
pytest)
- test_pkg="dev-python/pytest"
+ test_pkg=">=dev-python/pytest-4.5.0"
python_test() {
pytest -vv || die "Tests fail with ${EPYTHON}"
}