summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/xinetd/xinetd-2.3.15-r3.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/sys-apps/xinetd/xinetd-2.3.15-r3.ebuild b/sys-apps/xinetd/xinetd-2.3.15-r3.ebuild
index e0667ddfa98b..b22a4d57198e 100644
--- a/sys-apps/xinetd/xinetd-2.3.15-r3.ebuild
+++ b/sys-apps/xinetd/xinetd-2.3.15-r3.ebuild
@@ -30,11 +30,13 @@ src_prepare() {
}
src_configure() {
- if ! use rpc ; then
+ tc-export AR PKG_CONFIG
+ if use rpc ; then
+ append-cflags $(${PKG_CONFIG} --cflags libtirpc)
+ else
append-cppflags -DNO_RPC
export ac_cv_header_{rpc_{rpc,rpcent,pmap_clnt},netdb}_h=no
fi
- tc-export AR PKG_CONFIG
LIBS=$(${PKG_CONFIG} --libs libtirpc) \
econf \
$(use_with tcpd libwrap) \