summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--eclass/distutils-r1.eclass4
-rw-r--r--eclass/python-utils-r1.eclass11
-rw-r--r--media-gfx/entangle/entangle-2.0.ebuild5
-rw-r--r--sys-apps/help2man/Manifest2
-rw-r--r--sys-apps/help2man/help2man-1.47.13.ebuild (renamed from sys-apps/help2man/help2man-1.47.11.ebuild)2
5 files changed, 17 insertions, 7 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index f3df05eeb670..114ccc8041cc 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -120,10 +120,10 @@ _distutils_set_globals() {
local bdep=${rdep}
if [[ ! ${DISTUTILS_SINGLE_IMPL} ]]; then
- local sdep="dev-python/setuptools[${PYTHON_USEDEP}]"
+ local sdep=">=dev-python/setuptools-42.0.2[${PYTHON_USEDEP}]"
else
local sdep="$(python_gen_cond_dep '
- dev-python/setuptools[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/setuptools-42.0.2[${PYTHON_MULTI_USEDEP}]
')"
fi
diff --git a/eclass/python-utils-r1.eclass b/eclass/python-utils-r1.eclass
index 325964e0e0e8..f144cbbb1279 100644
--- a/eclass/python-utils-r1.eclass
+++ b/eclass/python-utils-r1.eclass
@@ -978,7 +978,7 @@ python_wrapper_setup() {
# Clean up, in case we were supposed to do a cheap update.
rm -f "${workdir}"/bin/python{,2,3}{,-config} || die
rm -f "${workdir}"/bin/2to3 || die
- rm -f "${workdir}"/pkgconfig/python{,2,3}.pc || die
+ rm -f "${workdir}"/pkgconfig/python{2,3}{,-embed}.pc || die
local EPYTHON PYTHON
python_export "${impl}" EPYTHON PYTHON
@@ -1021,8 +1021,13 @@ python_wrapper_setup() {
# Python 2.7+.
ln -s "${EPREFIX}"/usr/$(get_libdir)/pkgconfig/${EPYTHON/n/n-}.pc \
- "${workdir}"/pkgconfig/python.pc || die
- ln -s python.pc "${workdir}"/pkgconfig/python${pyver}.pc || die
+ "${workdir}"/pkgconfig/python${pyver}.pc || die
+
+ # Python 3.8+.
+ if [[ ${EPYTHON} != python[23].[67] ]]; then
+ ln -s "${EPREFIX}"/usr/$(get_libdir)/pkgconfig/${EPYTHON/n/n-}-embed.pc \
+ "${workdir}"/pkgconfig/python${pyver}-embed.pc || die
+ fi
else
nonsupp+=( 2to3 python-config "python${pyver}-config" )
fi
diff --git a/media-gfx/entangle/entangle-2.0.ebuild b/media-gfx/entangle/entangle-2.0.ebuild
index a8563923bc55..8e23c27d8c65 100644
--- a/media-gfx/entangle/entangle-2.0.ebuild
+++ b/media-gfx/entangle/entangle-2.0.ebuild
@@ -48,6 +48,11 @@ src_compile() {
# prevent gst from loading system plugins which causes
# sandbox violations on device access
local -x GST_PLUGIN_SYSTEM_PATH_1_0=
+ # pre-generate enums to resolve race conditions
+ # https://bugs.gentoo.org/709740
+ meson_src_compile \
+ src/backend/entangle-{camera,colour-profile}-enums.h \
+ src/frontend/entangle-image-display-enums.h
meson_src_compile
}
diff --git a/sys-apps/help2man/Manifest b/sys-apps/help2man/Manifest
index 2d74e1e0dfb8..dbd5a412b6a5 100644
--- a/sys-apps/help2man/Manifest
+++ b/sys-apps/help2man/Manifest
@@ -1,3 +1,3 @@
DIST help2man-1.47.10.tar.xz 202176 BLAKE2B 57c19072b1fb696b8ae1fc269d4c44672e692b45f1afe91871621dbed008298154d94813711b8ab89a9ad2e9fffa5ba1e738a613e5e50681b0abea4bfcc92677 SHA512 071383f38fb5264137200439a460e70298fc23d88069a96f150bf50a4e2a08d1d5d29555053b0ea36c809eec8484c4432b55d7d0bddd68f33b07b1abb97556ff
-DIST help2man-1.47.11.tar.xz 202312 BLAKE2B 6baba7fb28f2b28aba8a05eb5df0a8596918767cf43d730052e0bae9293a4a27f207136c22cad246ca7220fb639fabce3bb135edf4e84f866f1ea9b0af26f41d SHA512 786a6bd4336c591cfeb0b4f2dc1429f6545e36514e7b238453c91368b8f531c46db2be025f02dc52e6dd8b971d6edbb4ff1a8e1b519f9253a3957ad7157790be
DIST help2man-1.47.12.tar.xz 202252 BLAKE2B 6a474d62999b2fe6750a0ec7662b9b33546d82ce72edd628f41008243cd3467cad783516d5ad06edb37f471a2aaefd837bd9957a7fd10b6e3c3b6dd33398b79b SHA512 fb71e48e4a7a0f4316148295ea539b667a131149f4467da0f3e283389c9d9f2a5f1e9124ca8d64d6c3250d332a713d4e8de204ca9e7088840e74f316fa5221be
+DIST help2man-1.47.13.tar.xz 202480 BLAKE2B 0c9e854a29ab563b7bc86d4873b2669c82bbd9226d3940ddf60fcbf8bfc48197013c7cde5b55e47e6463d26e1b3512a24bb9591a77009f47992b2a3df9bde198 SHA512 7bf4c75a42c103dd8413a94505f383c6e2b215f9a4cc506e11935acc7f108caad01a5fa489ee157ebef5fa02299145592f65cc828fc016417af557382975d57a
diff --git a/sys-apps/help2man/help2man-1.47.11.ebuild b/sys-apps/help2man/help2man-1.47.13.ebuild
index 884bee09c350..a2e138b9d74e 100644
--- a/sys-apps/help2man/help2man-1.47.11.ebuild
+++ b/sys-apps/help2man/help2man-1.47.13.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7