summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-misc/mc/mc-4.8.23.ebuild108
-rw-r--r--dev-lang/jwasm/jwasm-2.11a-r1.ebuild (renamed from dev-lang/jwasm/jwasm-2.11a.ebuild)14
-rw-r--r--dev-lang/mmix/mmix-20160804-r1.ebuild5
-rw-r--r--dev-lang/mmix/mmix-20160804.ebuild9
-rw-r--r--eclass/autotools.eclass5
-rw-r--r--net-ftp/proftpd/proftpd-1.3.6b.ebuild2
-rw-r--r--net-mail/checkpassword/checkpassword-0.90-r4.ebuild2
7 files changed, 16 insertions, 129 deletions
diff --git a/app-misc/mc/mc-4.8.23.ebuild b/app-misc/mc/mc-4.8.23.ebuild
deleted file mode 100644
index b4513ee07fb6..000000000000
--- a/app-misc/mc/mc-4.8.23.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic
-
-MY_P=${P/_/-}
-
-DESCRIPTION="GNU Midnight Commander is a text based file manager"
-HOMEPAGE="https://www.midnight-commander.org"
-SRC_URI="http://ftp.midnight-commander.org/${MY_P}.tar.xz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
-IUSE="+edit gpm nls samba sftp +slang spell test unicode X +xdg"
-
-REQUIRED_USE="spell? ( edit )"
-
-RDEPEND=">=dev-libs/glib-2.26.0:2
- gpm? ( sys-libs/gpm )
- kernel_linux? ( sys-fs/e2fsprogs )
- samba? ( net-fs/samba )
- sftp? ( net-libs/libssh2 )
- slang? ( >=sys-libs/slang-2 )
- !slang? ( sys-libs/ncurses:0=[unicode?] )
- spell? ( app-text/aspell )
- X? ( x11-libs/libX11
- x11-libs/libICE
- x11-libs/libXau
- x11-libs/libXdmcp
- x11-libs/libSM )"
-DEPEND="${RDEPEND}
- app-arch/xz-utils
- virtual/pkgconfig
- nls? ( sys-devel/gettext )
- test? ( dev-libs/check )
- "
-
-RESTRICT="!test? ( test )"
-
-S=${WORKDIR}/${MY_P}
-
-pkg_pretend() {
- if use slang && use unicode ; then
- ewarn "\"unicode\" USE flag only takes effect when the \"slang\" USE flag is disabled."
- fi
-}
-
-src_configure() {
- [[ ${CHOST} == *-solaris* ]] && append-ldflags "-lnsl -lsocket"
-
- local myeconfargs=(
- --disable-dependency-tracking
- --disable-silent-rules
- --enable-charset
- --enable-vfs
- --with-homedir=$(usex xdg 'XDG' '.mc')
- --with-screen=$(usex slang 'slang' "ncurses$(usex unicode 'w' '')")
- $(use_enable kernel_linux vfs-undelfs)
- # Today mclib does not expose any headers and is linked to
- # single 'mc' binary. Thus there is no advantage of having
- # a library. Let's avoid shared library altogether
- # as it also conflicts with sci-libs/mc: bug #685938
- --disable-mclib
- $(use_enable nls)
- $(use_enable samba vfs-smb)
- $(use_enable sftp vfs-sftp)
- $(use_enable spell aspell)
- $(use_enable test tests)
- $(use_with gpm gpm-mouse)
- $(use_with X x)
- $(use_with edit internal-edit)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_test() {
- # CK_FORK=no to avoid using fork() in check library
- # as mc mocks fork() itself: bug #644462.
- #
- # VERBOSE=1 to make test failures contain detailed
- # information.
- CK_FORK=no emake check VERBOSE=1
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc AUTHORS README NEWS
-
- # fix bug #334383
- if use kernel_linux && [[ ${EUID} == 0 ]] ; then
- fowners root:tty /usr/libexec/mc/cons.saver
- fperms g+s /usr/libexec/mc/cons.saver
- fi
-
- if ! use xdg ; then
- sed 's@MC_XDG_OPEN="xdg-open"@MC_XDG_OPEN="/bin/false"@' \
- -i "${ED}"/usr/libexec/mc/ext.d/*.sh || die
- fi
-}
-
-pkg_postinst() {
- elog "To enable exiting to latest working directory,"
- elog "put this into your ~/.bashrc:"
- elog ". ${EPREFIX}/usr/libexec/mc/mc.sh"
-}
diff --git a/dev-lang/jwasm/jwasm-2.11a.ebuild b/dev-lang/jwasm/jwasm-2.11a-r1.ebuild
index 0eab110f0fbb..2de5e5e9d2b4 100644
--- a/dev-lang/jwasm/jwasm-2.11a.ebuild
+++ b/dev-lang/jwasm/jwasm-2.11a-r1.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils toolchain-funcs versionator
+inherit toolchain-funcs
# 2.10 -> 210s
MY_PN=JWasm
-MY_PV="$(delete_version_separator 1)s"
+MY_PV="$(ver_rs 1 '')s"
MY_P="${MY_PN}${MY_PV}"
DESCRIPTION="MASM-compatible TASM-similar assembler (fork of Wasm)"
@@ -20,11 +20,15 @@ KEYWORDS="~amd64 ~x86"
RDEPEND=""
DEPEND=""
+BDEPEND="app-arch/unzip"
S="${WORKDIR}"
+PATCHES=("${FILESDIR}"/${PN}-2.11-types-test.patch)
+
src_prepare() {
- epatch "${FILESDIR}"/${PN}-2.11-types-test.patch
+ default
+
# don't strip binary
sed -i GccUnix.mak -e 's/ -s / /g' || die
}
diff --git a/dev-lang/mmix/mmix-20160804-r1.ebuild b/dev-lang/mmix/mmix-20160804-r1.ebuild
index 3d8f806d1bb8..65491269b4a1 100644
--- a/dev-lang/mmix/mmix-20160804-r1.ebuild
+++ b/dev-lang/mmix/mmix-20160804-r1.ebuild
@@ -41,8 +41,5 @@ src_install() {
dobin ${PN} ${PN}al m${PN} mmotype abstime
dodoc README ${PN}.1
- if use doc ; then
- insinto /usr/share/doc/${PF}
- doins *.ps
- fi
+ use doc && dodoc *.ps
}
diff --git a/dev-lang/mmix/mmix-20160804.ebuild b/dev-lang/mmix/mmix-20160804.ebuild
index ec72856d158d..95967668d8d0 100644
--- a/dev-lang/mmix/mmix-20160804.ebuild
+++ b/dev-lang/mmix/mmix-20160804.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -36,12 +36,9 @@ src_compile() {
fi
}
-src_install () {
+src_install() {
dobin ${PN} ${PN}al m${PN} mmotype abstime
dodoc README ${PN}.1
- if use doc ; then
- insinto /usr/share/doc/${PF}
- doins *.ps
- fi
+ use doc && dodoc *.ps
}
diff --git a/eclass/autotools.eclass b/eclass/autotools.eclass
index 9143aa454d0d..9df0e1b93663 100644
--- a/eclass/autotools.eclass
+++ b/eclass/autotools.eclass
@@ -109,10 +109,7 @@ if [[ -n ${WANT_LIBTOOL} ]] ; then
export WANT_LIBTOOL
fi
-# Force people (nicely) to upgrade to a newer version of gettext as
-# older ones are known to be crappy. #496454
-AUTOTOOLS_DEPEND="!<sys-devel/gettext-0.18.1.1-r3
- ${_automake_atom}
+AUTOTOOLS_DEPEND="${_automake_atom}
${_autoconf_atom}
${_libtool_atom}"
RDEPEND=""
diff --git a/net-ftp/proftpd/proftpd-1.3.6b.ebuild b/net-ftp/proftpd/proftpd-1.3.6b.ebuild
index 2d371bcb83b3..e8c605dc56e4 100644
--- a/net-ftp/proftpd/proftpd-1.3.6b.ebuild
+++ b/net-ftp/proftpd/proftpd-1.3.6b.ebuild
@@ -26,7 +26,7 @@ SRC_URI="ftp://ftp.proftpd.org/distrib/source/${P/_/}.tar.gz
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 sparc ~x86"
IUSE="acl authfile ban +caps case clamav copy ctrls deflate diskuse dso dynmasq exec ifsession ifversion ident ipv6
kerberos ldap libressl log-forensic memcache msg mysql ncurses nls pam +pcre postgres qos radius
ratio readme rewrite selinux sftp shaper sitemisc snmp sodium softquota sqlite ssl tcpd test unique-id vroot"
diff --git a/net-mail/checkpassword/checkpassword-0.90-r4.ebuild b/net-mail/checkpassword/checkpassword-0.90-r4.ebuild
index 1680029cd0a6..e1691143b63e 100644
--- a/net-mail/checkpassword/checkpassword-0.90-r4.ebuild
+++ b/net-mail/checkpassword/checkpassword-0.90-r4.ebuild
@@ -11,7 +11,7 @@ SRC_URI="https://cr.yp.to/checkpwd/${P}.tar.gz"
LICENSE="all-rights-reserved"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh sparc ~x86"
IUSE="static"
RESTRICT="mirror bindist"