summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ml/ppx_fields_conv/Manifest1
-rw-r--r--dev-ml/ppx_fields_conv/ppx_fields_conv-0.17.0.ebuild24
-rw-r--r--profiles/package.mask1
3 files changed, 26 insertions, 0 deletions
diff --git a/dev-ml/ppx_fields_conv/Manifest b/dev-ml/ppx_fields_conv/Manifest
index be02ffe5df79..e96dd3a9bd2c 100644
--- a/dev-ml/ppx_fields_conv/Manifest
+++ b/dev-ml/ppx_fields_conv/Manifest
@@ -2,3 +2,4 @@ DIST ppx_fields_conv-0.14.1.tar.gz 14348 BLAKE2B 09bd2db4dab314ba50bcd5566c4ba4f
DIST ppx_fields_conv-0.14.2.tar.gz 14314 BLAKE2B d6c28a157c0d5fc73ef6793c23539c9ae6b706445f24b8761a63a932c42e4d75237b4b092122e7049d3526c33bb3fbce52f44deaa8e52ab233b1ede51a02f09f SHA512 19cf14f79bd6425519e08089b6de19a79ed3f435cd453eeae6c7fe88d65ae4de4d5b47cf19d086bb2ba41066b344da7062d5153eaba7389da8dcf95c7284b522
DIST ppx_fields_conv-0.15.0.tar.gz 16432 BLAKE2B 1db37d33228d3090c611b4545cedd8138ae970fde5878d17de740aa231c3c50defcae743bf633e1a42f9610f1815ca9166dd9749ff392fccdf55e16affc07b9e SHA512 5fd20c0bfd0ba9bfd4aad98b0beb2be7978668dea1e6ca4099eeb60f86533b0ea89168af1d5556fea295ea93829c62358c66780550d27177b9f7eb2bd08dd3c8
DIST ppx_fields_conv-0.16.0.tar.gz 21481 BLAKE2B a3a19b935b457fba0aebbe308ee3452df7d698073c1d15fb0e7948f19a64c0d6d5f358d35979e16eaafd220413c1865c22d6dbe197ab6623d30050d72f55b3da SHA512 14bd27628f653aca239c82b528af1dea65446d56ecd2e30c4d9d2f8555854c45e7a0c5c4f6230de7abe3869fe2c8be569b26d6c217296c607c6e8b336a4af575
+DIST ppx_fields_conv-0.17.0.tar.gz 23727 BLAKE2B 752b63c1766e831780748e61835494f4837f890ad627ab673dad033b55fb159b6350c4022a92a69c8ad372f10ad89840f8ffb7a3832a8f19badabe8ecfab6869 SHA512 82e782b7472b1b9ee0325698772357af0f75c8a9b65b3731b01bc7ad75f49a423d28c46bd34376f876b713db0d7d105b56125ccd82dbbd24b1eef42359fc255d
diff --git a/dev-ml/ppx_fields_conv/ppx_fields_conv-0.17.0.ebuild b/dev-ml/ppx_fields_conv/ppx_fields_conv-0.17.0.ebuild
new file mode 100644
index 000000000000..425e9dea61ce
--- /dev/null
+++ b/dev-ml/ppx_fields_conv/ppx_fields_conv-0.17.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Generation of accessor and iteration functions for ocaml records"
+HOMEPAGE="https://github.com/janestreet/ppx_fields_conv"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-5
+ dev-ml/base:${SLOT}[ocamlopt?]
+ dev-ml/fieldslib:${SLOT}[ocamlopt?]
+ >=dev-ml/ppxlib-0.32.1:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}"
+BDEPEND=">=dev-ml/dune-3.11"
diff --git a/profiles/package.mask b/profiles/package.mask
index e9892702e593..775c7a4b301e 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -187,6 +187,7 @@ dev-ml/ppx_globalize:0/0.17
dev-ml/ppx_sexp_conv:0/0.17
dev-ml/ppx_hash:0/0.17
dev-ml/ppx_base:0/0.17
+dev-ml/ppx_fields_conv:0/0.17
# Arthur Zamarin <arthurzam@gentoo.org> (2024-06-08)
# EAPI=6, waiting for a version bump, not maintained for many years.