summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-portage/pkg-testing-tools/pkg-testing-tools-0.2.1.ebuild17
-rw-r--r--app-portage/pkg-testing-tools/pkg-testing-tools-9999.ebuild32
2 files changed, 46 insertions, 3 deletions
diff --git a/app-portage/pkg-testing-tools/pkg-testing-tools-0.2.1.ebuild b/app-portage/pkg-testing-tools/pkg-testing-tools-0.2.1.ebuild
index 41d4e5d3029a..c8cd079994a1 100644
--- a/app-portage/pkg-testing-tools/pkg-testing-tools-0.2.1.ebuild
+++ b/app-portage/pkg-testing-tools/pkg-testing-tools-0.2.1.ebuild
@@ -4,18 +4,29 @@
EAPI=8
DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
DESCRIPTION="Packages testing tools for Gentoo"
HOMEPAGE="https://github.com/APN-Pucky/pkg-testing-tools"
-SRC_URI="https://github.com/APN-Pucky/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+REPO=APN-Pucky
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${REPO}/${PN}"
+else
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+ SRC_URI="https://github.com/APN-Pucky/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+fi
+
+IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="
sys-apps/portage[${PYTHON_USEDEP}]
"
+
+distutils_enable_tests pytest
diff --git a/app-portage/pkg-testing-tools/pkg-testing-tools-9999.ebuild b/app-portage/pkg-testing-tools/pkg-testing-tools-9999.ebuild
new file mode 100644
index 000000000000..c8cd079994a1
--- /dev/null
+++ b/app-portage/pkg-testing-tools/pkg-testing-tools-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Packages testing tools for Gentoo"
+HOMEPAGE="https://github.com/APN-Pucky/pkg-testing-tools"
+
+REPO=APN-Pucky
+LICENSE="BSD"
+SLOT="0"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${REPO}/${PN}"
+else
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+ SRC_URI="https://github.com/APN-Pucky/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+fi
+
+IUSE="test"
+RESTRICT="!test? ( test )"
+RDEPEND="
+ sys-apps/portage[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest