summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-haskell/c2hs/Manifest1
-rw-r--r--dev-haskell/c2hs/c2hs-0.28.8.ebuild41
-rw-r--r--dev-java/commons-httpclient/Manifest1
-rw-r--r--dev-java/commons-httpclient/commons-httpclient-4.5.13.ebuild73
-rw-r--r--eclass/ghc-package.eclass10
-rw-r--r--eclass/haskell-cabal.eclass43
-rw-r--r--net-wireless/iw/iw-5.9.ebuild2
7 files changed, 133 insertions, 38 deletions
diff --git a/dev-haskell/c2hs/Manifest b/dev-haskell/c2hs/Manifest
index ea522395f4f3..175026369304 100644
--- a/dev-haskell/c2hs/Manifest
+++ b/dev-haskell/c2hs/Manifest
@@ -1 +1,2 @@
DIST c2hs-0.28.7.tar.gz 207782 BLAKE2B a9f29506e6aaec3400d844ad85b2a6b6e1b87cb3c6c641665ab6bc5465903da8c2c82c3511b451e54cf30dfac61092dd323f8a2af48b5daa6081a4e9c5f00c9d SHA512 69c877349ae4864763d20664edae07a67aa1c55f5d4fccc3fcb6d06e94eb14d6b4b0201fc2840a9ebbc45a2a21ab55ad0e79f9cd88c00003df67abf5c1fd62d6
+DIST c2hs-0.28.8.tar.gz 207816 BLAKE2B 6d912fd93c6076ccd86ed62e075f1addb7b44378c82acc0cbaf04b6b91a2ed4530cde60a9139316d928a2867474bafde5c14aedb4ab9e78e5faaa99830276a71 SHA512 ff9119acecddd853f2f797385f971c249bcd92d4b141e8e7ea5f5d3e63aa257502c80ded2720a46e3186260026b94c9e518f08f8e452a64c9f888d0183ee1749
diff --git a/dev-haskell/c2hs/c2hs-0.28.8.ebuild b/dev-haskell/c2hs/c2hs-0.28.8.ebuild
new file mode 100644
index 000000000000..38703f4aa688
--- /dev/null
+++ b/dev-haskell/c2hs/c2hs-0.28.8.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.6.7.9999
+
+CABAL_FEATURES="test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="C->Haskell FFI tool that gives some cross-language type safety"
+HOMEPAGE="https://github.com/haskell/c2hs"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="regression"
+
+RESTRICT=test # needs unprefixed 'cpp'
+
+RDEPEND="dev-haskell/dlist:=
+ >=dev-haskell/language-c-0.7.1:= <dev-haskell/language-c-0.10:=
+ >=dev-lang/ghc-8.4.3:=
+ regression? ( >=dev-haskell/shelly-1.9.0:= <dev-haskell/shelly-1.10.0:=
+ dev-haskell/text:=
+ >=dev-haskell/yaml-0.8:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( dev-haskell/hunit
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit
+ !regression? ( >=dev-haskell/shelly-1.9.0 <dev-haskell/shelly-1.10.0
+ dev-haskell/text ) )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag regression regression)
+}
diff --git a/dev-java/commons-httpclient/Manifest b/dev-java/commons-httpclient/Manifest
index a8ecdcddf113..b31577627594 100644
--- a/dev-java/commons-httpclient/Manifest
+++ b/dev-java/commons-httpclient/Manifest
@@ -1 +1,2 @@
DIST commons-httpclient-3.1-src.tar.gz 1882664 BLAKE2B ccf96bedad09011ee20eae38aae1fdfdd6fea5a8226f4b4d156762080c286c71b34c149035abfd61e70c55a1de84ab3cd38d73c3228f591dd8e16c0a7e79c3a5 SHA512 e73ceeba3f34a35c30b24a3c6cb8dfc2102ff21079a5ff9270935908cb2f707d366c2f31a53fbdafa99673cc2b82e05470a2bf40d96767c72b2ab037c0f55490
+DIST httpcomponents-client-4.5.13-src.tar.gz 824131 BLAKE2B 1507c81749a92afcf8b170b606761236d71b02d8b8b257d753a0f09abbdc297057df39661e827dee52804a2138de7d201b2a837418cbec21085fd3ffd558b51c SHA512 421e413fb2206fa95b6428ff067cdf2b440d2d3d4503cc3ca9bcf70ccd8ed1b8273ec4fe0703e6a8cd7612940b7ed966d9f163dbfeb8bf699ae2a8b2e0866d05
diff --git a/dev-java/commons-httpclient/commons-httpclient-4.5.13.ebuild b/dev-java/commons-httpclient/commons-httpclient-4.5.13.ebuild
new file mode 100644
index 000000000000..736ff629cee5
--- /dev/null
+++ b/dev-java/commons-httpclient/commons-httpclient-4.5.13.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom httpcomponents-client-4.5.13/httpclient/pom.xml --download-uri https://github.com/apache/httpcomponents-client/archive/refs/tags/rel/v4.5.13.tar.gz --slot 4 --keywords "~amd64 ~ppc64 ~x86" --ebuild commons-httpclient-4.5.13.ebuild
+
+EAPI=7
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_ID="org.apache.httpcomponents:httpclient:4.5.13"
+JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Apache HttpComponents Client"
+HOMEPAGE="https://hc.apache.org/httpcomponents-client"
+SRC_URI="mirror://apache/httpcomponents/httpclient/source/httpcomponents-client-${PV}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="4"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+# Common dependencies
+# POM: httpcomponents-client-${PV}/httpclient/pom.xml
+# commons-codec:commons-codec:1.11 -> >=dev-java/commons-codec-1.15:0
+# commons-logging:commons-logging:1.2 -> >=dev-java/commons-logging-1.2:0
+# org.apache.httpcomponents:httpcore:4.4.13 -> >=dev-java/httpcore-4.4.14:0
+
+CDEPEND="
+ dev-java/commons-codec:0
+ dev-java/commons-logging:0
+ dev-java/httpcore:0
+"
+
+# Compile dependencies
+# POM: httpcomponents-client-${PV}/httpclient/pom.xml
+# test? junit:junit:4.11 -> >=dev-java/junit-4.13.2:4
+# test? org.mockito:mockito-core:1.10.19 -> >=dev-java/mockito-1.9.5:0
+
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.8:*
+ test? (
+ dev-java/mockito:0
+ )"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.8:*"
+
+DOCS=( ../{LICENSE,NOTICE,README,RELEASE_NOTES}.txt )
+
+S="${WORKDIR}/httpcomponents-client-${PV}/httpclient"
+
+JAVA_GENTOO_CLASSPATH="commons-codec,commons-logging,httpcore"
+JAVA_SRC_DIR=(
+ "src/main/java"
+ "src/main/java-deprecated"
+)
+JAVA_RESOURCE_DIRS="src/main/resources"
+
+JAVA_TEST_GENTOO_CLASSPATH="junit-4,mockito"
+JAVA_TEST_SRC_DIR="src/test/java"
+JAVA_TEST_RESOURCE_DIRS="src/test/resources"
+
+JAVA_TEST_EXCLUDES=(
+ # Tests run: 929, Failures: 1
+ # javax.net.ssl.SSLHandshakeException: Remote host terminated the handshake
+ "org.apache.http.conn.ssl.TestSSLSocketFactory"
+)
+
+src_install() {
+ default
+ java-pkg-simple_src_install
+}
diff --git a/eclass/ghc-package.eclass b/eclass/ghc-package.eclass
index 5decbaa228e8..1d90c7fc383e 100644
--- a/eclass/ghc-package.eclass
+++ b/eclass/ghc-package.eclass
@@ -4,7 +4,7 @@
# @ECLASS: ghc-package.eclass
# @MAINTAINER:
# "Gentoo's Haskell Language team" <haskell@gentoo.org>
-# @SUPPORTED_EAPIS: 0 1 2 3 4 5 6 7
+# @SUPPORTED_EAPIS: 6 7 8
# @AUTHOR:
# Original Author: Andres Loeh <kosmikus@gentoo.org>
# @BLURB: This eclass helps with the Glasgow Haskell Compiler's package configuration utility.
@@ -14,10 +14,10 @@
inherit multiprocessing
# Maintain version-testing compatibility with ebuilds not using EAPI 7.
-case "${EAPI:-0}" in
- 0|1|2|3|7) ;;
- 4|5|6) inherit eapi7-ver ;;
- *) die "EAPI ${EAPI} unsupported." ;;
+case ${EAPI} in
+ 7|8) ;;
+ 6) inherit eapi7-ver ;;
+ *) die "${ECLASS}: EAPI ${EAPI:-0} not supported" ;;
esac
# GHC uses it's own native code generator. Portage's
diff --git a/eclass/haskell-cabal.eclass b/eclass/haskell-cabal.eclass
index 5b67f43f0c5a..0e41325b3061 100644
--- a/eclass/haskell-cabal.eclass
+++ b/eclass/haskell-cabal.eclass
@@ -4,7 +4,7 @@
# @ECLASS: haskell-cabal.eclass
# @MAINTAINER:
# Haskell herd <haskell@gentoo.org>
-# @SUPPORTED_EAPIS: 0 1 2 3 4 5 6 7
+# @SUPPORTED_EAPIS: 6 7 8
# @AUTHOR:
# Original author: Andres Loeh <kosmikus@gentoo.org>
# Original author: Duncan Coutts <dcoutts@gentoo.org>
@@ -40,7 +40,16 @@
# FEATURE can be removed once https://github.com/haskell/cabal/issues/7213
# is fixed.
-inherit eutils ghc-package multilib toolchain-funcs
+case ${EAPI} in
+ # eutils is for eqawarn
+ 6|7) inherit eutils ;;
+ 8) ;;
+ *) die "${ECLASS}: EAPI ${EAPI:-0} not supported" ;;
+esac
+
+inherit ghc-package multilib toolchain-funcs
+
+EXPORT_FUNCTIONS pkg_setup src_configure src_compile src_test src_install pkg_postinst pkg_postrm
# @ECLASS-VARIABLE: CABAL_EXTRA_CONFIGURE_FLAGS
# @USER_VARIABLE
@@ -113,21 +122,11 @@ inherit eutils ghc-package multilib toolchain-funcs
# Set to anything else to disable.
: ${CABAL_REPORT_OTHER_BROKEN_PACKAGES:=yes}
-HASKELL_CABAL_EXPF="pkg_setup src_compile src_test src_install pkg_postinst pkg_postrm"
-
# 'dev-haskell/cabal' passes those options with ./configure-based
# configuration, but most packages don't need/don't accept it:
# #515362, #515362
QA_CONFIGURE_OPTIONS+=" --with-compiler --with-hc --with-hc-pkg --with-gcc"
-case "${EAPI:-0}" in
- 0|1) ;;
- 2|3|4|5|6|7) HASKELL_CABAL_EXPF+=" src_configure" ;;
- *) die "EAPI ${EAPI} unsupported." ;;
-esac
-
-EXPORT_FUNCTIONS ${HASKELL_CABAL_EXPF}
-
for feature in ${CABAL_FEATURES}; do
case ${feature} in
haddock) CABAL_USE_HADDOCK=yes;;
@@ -141,9 +140,6 @@ for feature in ${CABAL_FEATURES}; do
test-suite) CABAL_TEST_SUITE=yes;;
rebuild-after-doc-workaround) CABAL_REBUILD_AFTER_DOC_WORKAROUND=yes;;
- # does nothing, removed 2016-09-04
- bin) ;;
-
*) CABAL_UNKNOWN="${CABAL_UNKNOWN} ${feature}";;
esac
done
@@ -315,7 +311,6 @@ cabal-show-brokens-and-die() {
cabal-configure() {
local cabalconf=()
- has "${EAPI:-0}" 0 1 2 && ! use prefix && EPREFIX=
if [[ -n "${CABAL_USE_HADDOCK}" ]] && use doc; then
# We use the bundled with GHC version if exists
@@ -452,8 +447,6 @@ cabal-build() {
}
cabal-copy() {
- has "${EAPI:-0}" 0 1 2 && ! use prefix && ED=${D}
-
set -- copy --destdir="${D}" "$@"
echo ./setup "$@"
./setup "$@" || die "setup copy failed"
@@ -535,20 +528,8 @@ cabal_src_configure() {
# exported function: cabal-style bootstrap configure and compile
cabal_src_compile() {
- # it's a common mistake when one bumps ebuild to EAPI="2" (and upper)
- # and forgets to separate src_compile() to src_configure()/src_compile().
- # Such error leads to default src_configure and we lose all passed flags.
- if ! has "${EAPI:-0}" 0 1; then
- local passed_flag
- for passed_flag in "$@"; do
- [[ ${passed_flag} == --flags=* ]] && \
- eqawarn "QA Notice: Cabal option '${passed_flag}' has effect only in src_configure()"
- done
- fi
-
cabal-is-dummy-lib && return
- has src_configure ${HASKELL_CABAL_EXPF} || haskell-cabal_src_configure "$@"
cabal-build
if [[ -n "$CABAL_USE_HADDOCK" ]] && use doc; then
@@ -616,8 +597,6 @@ haskell-cabal_src_test() {
# exported function: cabal-style copy and register
cabal_src_install() {
- has "${EAPI:-0}" 0 1 2 && ! use prefix && EPREFIX=
-
if ! cabal-is-dummy-lib; then
cabal-copy
cabal-pkg
diff --git a/net-wireless/iw/iw-5.9.ebuild b/net-wireless/iw/iw-5.9.ebuild
index b380a60c2963..35136ab95b36 100644
--- a/net-wireless/iw/iw-5.9.ebuild
+++ b/net-wireless/iw/iw-5.9.ebuild
@@ -11,7 +11,7 @@ SRC_URI="https://www.kernel.org/pub/software/network/${PN}/${P}.tar.xz"
LICENSE="ISC"
SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc x86 ~amd64-linux ~x86-linux"
+KEYWORDS="amd64 arm arm64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
IUSE=""
RDEPEND="dev-libs/libnl:="