summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-cpp/cpp-taskflow/Manifest1
-rw-r--r--dev-cpp/taskflow/Manifest1
-rw-r--r--dev-cpp/taskflow/files/taskflow-3.3.0-fix_doctest.patch (renamed from dev-cpp/cpp-taskflow/files/cpp-taskflow-3.3.0-fix_doctest.patch)0
-rw-r--r--dev-cpp/taskflow/files/taskflow-9999-fix_doctest.patch (renamed from dev-cpp/cpp-taskflow/files/cpp-taskflow-9999-fix_doctest.patch)0
-rw-r--r--dev-cpp/taskflow/metadata.xml (renamed from dev-cpp/cpp-taskflow/metadata.xml)4
-rw-r--r--dev-cpp/taskflow/taskflow-3.3.0.ebuild (renamed from dev-cpp/cpp-taskflow/cpp-taskflow-9999.ebuild)8
-rw-r--r--dev-cpp/taskflow/taskflow-9999.ebuild (renamed from dev-cpp/cpp-taskflow/cpp-taskflow-3.3.0.ebuild)8
-rw-r--r--profiles/updates/2Q-20221
-rw-r--r--sci-libs/dealii/dealii-9999.ebuild2
9 files changed, 13 insertions, 12 deletions
diff --git a/dev-cpp/cpp-taskflow/Manifest b/dev-cpp/cpp-taskflow/Manifest
deleted file mode 100644
index d70f06ff30fb..000000000000
--- a/dev-cpp/cpp-taskflow/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST cpp-taskflow-3.3.0.tar.gz 64446007 BLAKE2B 07878a03bd90af64914f1dc80850bcf5d4140f20ecfa998237039b6f37cc668e8c2b5dffafb75f4518209b3ac01f9935f5e30a020871334f131e6fe7654748bf SHA512 08ab20bf38927d49c8332fc103cb7b4b6358efa06466cb8471f2004eb27b79b9eadc9971ec4acd110c8f369686b6f99bf3e21192285c3f28b9cb855bfd9ab0b5
diff --git a/dev-cpp/taskflow/Manifest b/dev-cpp/taskflow/Manifest
new file mode 100644
index 000000000000..37d6816e4837
--- /dev/null
+++ b/dev-cpp/taskflow/Manifest
@@ -0,0 +1 @@
+DIST taskflow-3.3.0.tar.gz 64446007 BLAKE2B 07878a03bd90af64914f1dc80850bcf5d4140f20ecfa998237039b6f37cc668e8c2b5dffafb75f4518209b3ac01f9935f5e30a020871334f131e6fe7654748bf SHA512 08ab20bf38927d49c8332fc103cb7b4b6358efa06466cb8471f2004eb27b79b9eadc9971ec4acd110c8f369686b6f99bf3e21192285c3f28b9cb855bfd9ab0b5
diff --git a/dev-cpp/cpp-taskflow/files/cpp-taskflow-3.3.0-fix_doctest.patch b/dev-cpp/taskflow/files/taskflow-3.3.0-fix_doctest.patch
index c5da4fd96eb6..c5da4fd96eb6 100644
--- a/dev-cpp/cpp-taskflow/files/cpp-taskflow-3.3.0-fix_doctest.patch
+++ b/dev-cpp/taskflow/files/taskflow-3.3.0-fix_doctest.patch
diff --git a/dev-cpp/cpp-taskflow/files/cpp-taskflow-9999-fix_doctest.patch b/dev-cpp/taskflow/files/taskflow-9999-fix_doctest.patch
index 323d17e7f535..323d17e7f535 100644
--- a/dev-cpp/cpp-taskflow/files/cpp-taskflow-9999-fix_doctest.patch
+++ b/dev-cpp/taskflow/files/taskflow-9999-fix_doctest.patch
diff --git a/dev-cpp/cpp-taskflow/metadata.xml b/dev-cpp/taskflow/metadata.xml
index 5b4c8bac454b..059a58ff11cd 100644
--- a/dev-cpp/cpp-taskflow/metadata.xml
+++ b/dev-cpp/taskflow/metadata.xml
@@ -10,11 +10,11 @@
<name>Gentoo Science Project</name>
</maintainer>
<longdescription>
- Cpp-Taskflow is faster, more expressive, and easier for drop-in
+ Taskflow is faster, more expressive, and easier for drop-in
integration than many of existing task programming frameworks in
handling complex parallel workloads.
</longdescription>
<upstream>
- <remote-id type="github">cpp-taskflow/cpp-taskflow</remote-id>
+ <remote-id type="github">taskflow/taskflow</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-cpp/cpp-taskflow/cpp-taskflow-9999.ebuild b/dev-cpp/taskflow/taskflow-3.3.0.ebuild
index a00e95ad6e52..c131483350c0 100644
--- a/dev-cpp/cpp-taskflow/cpp-taskflow-9999.ebuild
+++ b/dev-cpp/taskflow/taskflow-3.3.0.ebuild
@@ -6,11 +6,11 @@ EAPI=8
inherit cmake
DESCRIPTION="Modern C++ Parallel Task Programming"
-HOMEPAGE="https://cpp-taskflow.github.io"
+HOMEPAGE="https://taskflow.github.io"
if [[ ${PV} == 9999 ]]; then
- EGIT_REPO_URI="https://github.com/cpp-taskflow/${PN}.git"
+ EGIT_REPO_URI="https://github.com/taskflow/${PN}.git"
inherit git-r3
- S="${WORKDIR}/cpp-taskflow-${PV}"
+ S="${WORKDIR}/taskflow-${PV}"
else
SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
@@ -27,7 +27,7 @@ DEPEND="test? ( dev-cpp/doctest )"
HTML_DOCS=( docs/. )
PATCHES=(
- "${FILESDIR}"/cpp-taskflow-9999-fix_doctest.patch
+ "${FILESDIR}"/taskflow-3.3.0-fix_doctest.patch
)
src_prepare() {
diff --git a/dev-cpp/cpp-taskflow/cpp-taskflow-3.3.0.ebuild b/dev-cpp/taskflow/taskflow-9999.ebuild
index 649d2fa20cc2..67272062e500 100644
--- a/dev-cpp/cpp-taskflow/cpp-taskflow-3.3.0.ebuild
+++ b/dev-cpp/taskflow/taskflow-9999.ebuild
@@ -6,11 +6,11 @@ EAPI=8
inherit cmake
DESCRIPTION="Modern C++ Parallel Task Programming"
-HOMEPAGE="https://cpp-taskflow.github.io"
+HOMEPAGE="https://taskflow.github.io"
if [[ ${PV} == 9999 ]]; then
- EGIT_REPO_URI="https://github.com/cpp-taskflow/${PN}.git"
+ EGIT_REPO_URI="https://github.com/taskflow/${PN}.git"
inherit git-r3
- S="${WORKDIR}/cpp-taskflow-${PV}"
+ S="${WORKDIR}/taskflow-${PV}"
else
SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
@@ -27,7 +27,7 @@ DEPEND="test? ( dev-cpp/doctest )"
HTML_DOCS=( docs/. )
PATCHES=(
- "${FILESDIR}"/cpp-taskflow-3.3.0-fix_doctest.patch
+ "${FILESDIR}"/taskflow-9999-fix_doctest.patch
)
src_prepare() {
diff --git a/profiles/updates/2Q-2022 b/profiles/updates/2Q-2022
index d256ba354a9e..62c9b60b5b1b 100644
--- a/profiles/updates/2Q-2022
+++ b/profiles/updates/2Q-2022
@@ -4,3 +4,4 @@ move sys-auth/solo-python sys-auth/solo1
move dev-python/setuptools_rust dev-python/setuptools-rust
move dev-python/lark-parser dev-python/lark
move dev-python/suds dev-python/suds-community
+move dev-cpp/cpp-taskflow dev-cpp/taskflow
diff --git a/sci-libs/dealii/dealii-9999.ebuild b/sci-libs/dealii/dealii-9999.ebuild
index 2e1f4a47b3ba..dd7a675e4e6e 100644
--- a/sci-libs/dealii/dealii-9999.ebuild
+++ b/sci-libs/dealii/dealii-9999.ebuild
@@ -43,7 +43,7 @@ REQUIRED_USE="
RDEPEND="dev-libs/boost:=
app-arch/bzip2
sys-libs/zlib
- dev-cpp/cpp-taskflow
+ dev-cpp/taskflow
dev-cpp/tbb:=
adolc? ( sci-libs/adolc )
arpack? ( sci-libs/arpack[mpi=] )