summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/best_in_place/best_in_place-3.1.0.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/dev-ruby/best_in_place/best_in_place-3.1.0.ebuild b/dev-ruby/best_in_place/best_in_place-3.1.0.ebuild
index 9bb8d3179203..40a701276a51 100644
--- a/dev-ruby/best_in_place/best_in_place-3.1.0.ebuild
+++ b/dev-ruby/best_in_place/best_in_place-3.1.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-USE_RUBY="ruby20 ruby21"
+USE_RUBY="ruby21 ruby22"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="README.md"
@@ -35,10 +35,8 @@ ruby_add_bdepend "
dev-ruby/rspec-rails:3
>=dev-ruby/nokogiri-1.5.0
>=dev-ruby/capybara-1.1.2:0
- dev-ruby/poltergeist
>=dev-ruby/rails-3.2
>=dev-ruby/sqlite3-1.3.4-r1
- dev-ruby/launchy
dev-ruby/bundler
)"
@@ -53,7 +51,13 @@ all_ruby_prepare() {
-e '2agem "rspec", "~>3.0"' \
-e '2agem "jquery-rails"' -e '2agem "jquery-ui-rails"' \
-e '/byebug/ s:^:#:' \
+ -e '/\(launchy\|poltergeist\)/d' \
Gemfile
+ sed -i -e '/poltergeist/,/javascript_driver/ s:^:#:' spec/rails_helper.rb || die
+
+ # Remove integration tests. They fail to run and depend on obsolete
+ # poltergeist/phantomjs.
+ rm -rf spec/integration || die
}
each_ruby_test() {