summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-db/etcd/Manifest1
-rw-r--r--dev-db/etcd/etcd-3.3.15.ebuild78
-rw-r--r--eclass/check-reqs.eclass25
-rw-r--r--net-analyzer/net-snmp/Manifest4
-rw-r--r--net-analyzer/net-snmp/files/net-snmp-5.7.3-mariadb-10.2.patch56
-rw-r--r--net-analyzer/net-snmp/files/net-snmp-5.7.3-perl524-2.patch70
-rw-r--r--net-analyzer/net-snmp/files/net-snmp-5.8-my_bool.patch23
-rw-r--r--net-analyzer/net-snmp/net-snmp-5.7.3-r5.ebuild192
-rw-r--r--net-analyzer/net-snmp/net-snmp-5.7.3-r6.ebuild194
-rw-r--r--net-analyzer/net-snmp/net-snmp-5.8-r2.ebuild (renamed from net-analyzer/net-snmp/net-snmp-5.7.3_p3-r1.ebuild)17
10 files changed, 129 insertions, 531 deletions
diff --git a/dev-db/etcd/Manifest b/dev-db/etcd/Manifest
index f68a66817d89..71858702c264 100644
--- a/dev-db/etcd/Manifest
+++ b/dev-db/etcd/Manifest
@@ -1,2 +1,3 @@
DIST etcd-3.3.13.tar.gz 3372732 BLAKE2B 241dee0d9843eefc9aaefb35be8f649d242ab1417456cc3028c8eb2ff2af6a7a1c396f04029d87877d384247b8c7a51ec6ea2e0dd51af07ce48ecc91c613c380 SHA512 5b8cf9d8d8b0afd1551f414480f04837668729c10d5d81c5e9ffba3392bd2567f3798267c5e4dbe60f49dbdd859f668c6fe0d7924e0fd65f918ab3bd01d5751a
DIST etcd-3.3.14.tar.gz 6342437 BLAKE2B 4bcf27829045e2f2f34c7628d6ed854a7ef5e6db02bd794d1135bb901486d8f3c1bf598c230fe7491e9db7273d3e5aa83bf4c941476ad3093423c14f377513b2 SHA512 76c8147168030310f0e4fa0c22670fd73369795ab6d98c0632c87b5947acf10af4adae58b46f042a482dc7a002044cfbdfbec962517018e2fdf211c381281dae
+DIST etcd-3.3.15.tar.gz 6271373 BLAKE2B 85786a2a4acaf144f80461a56775b8c91164e8f0c0034ef0741d98383ac400720ca69b855588a076dc174364330c0e12df73a36570983138e33a32cdbe69e22f SHA512 9fbc02c4aacb000335d558e9c5d4df672194d1b1b8511918efa35a6123bcd7f1a06ecc527f7ff01af7c7f0e818b4809918e640fd596ec51898bf511849f0a2c5
diff --git a/dev-db/etcd/etcd-3.3.15.ebuild b/dev-db/etcd/etcd-3.3.15.ebuild
new file mode 100644
index 000000000000..5724a790e2b2
--- /dev/null
+++ b/dev-db/etcd/etcd-3.3.15.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit user systemd golang-vcs-snapshot
+
+KEYWORDS="~amd64"
+EGO_PN="github.com/coreos/etcd"
+GIT_COMMIT="94745a4"
+MY_PV="${PV/_rc/-rc.}"
+DESCRIPTION="Highly-available key value store for shared configuration and service discovery"
+HOMEPAGE="https://github.com/etcd-io/etcd"
+SRC_URI="https://${EGO_PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="doc +server"
+DEPEND=">=dev-lang/go-1.12:="
+RDEPEND="!dev-db/etcdctl"
+
+src_prepare() {
+ default
+ sed -e "s|GIT_SHA=.*|GIT_SHA=${GIT_COMMIT}|"\
+ -i "${S}"/src/${EGO_PN}/build || die
+ sed -e 's:\(for p in \)shellcheck :\1 :' \
+ -e 's:^ gofmt \\$:\\:' \
+ -e 's:^ govet \\$:\\:' \
+ -i "${S}"/src/${EGO_PN}/test || die
+ # missing ... in args forwarded to print-like function
+ sed -e 's:l\.Logger\.Panic(v):l.Logger.Panic(v...):' \
+ -i "${S}"/src/${EGO_PN}/raft/logger.go || die
+}
+
+pkg_setup() {
+ if use server; then
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /var/lib/${PN} ${PN}
+ fi
+}
+
+src_compile() {
+ export -n GOCACHE XDG_CACHE_HOME #651934
+ export GOPATH=${S}
+ pushd src/${EGO_PN} || die
+ GO_BUILD_FLAGS=-v ./build || die
+ popd || die
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin bin/etcdctl
+ use doc && dodoc -r Documentation
+ if use server; then
+ insinto /etc/${PN}
+ doins "${FILESDIR}/${PN}.conf"
+ dobin bin/etcd
+ dodoc README.md
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles.d.conf" ${PN}.conf
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}.logrotated" "${PN}"
+ keepdir /var/lib/${PN}
+ fowners ${PN}:${PN} /var/lib/${PN}
+ fperms 0700 /var/lib/${PN}
+ keepdir /var/log/${PN}
+ fowners ${PN}:${PN} /var/log/${PN}
+ fperms 755 /var/log/${PN}
+ fi
+ popd || die
+}
+
+src_test() {
+ pushd src/${EGO_PN} || die
+ ./test || die
+ popd || die
+}
diff --git a/eclass/check-reqs.eclass b/eclass/check-reqs.eclass
index 689944c87700..95f73a3012eb 100644
--- a/eclass/check-reqs.eclass
+++ b/eclass/check-reqs.eclass
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 2004-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: check-reqs.eclass
@@ -245,6 +245,7 @@ check-reqs_memory() {
local size=${1}
local actual_memory
+ local actual_swap
check-reqs_start_phase \
${size} \
@@ -252,19 +253,29 @@ check-reqs_memory() {
if [[ -r /proc/meminfo ]] ; then
actual_memory=$(awk '/MemTotal/ { print $2 }' /proc/meminfo)
+ actual_swap=$(awk '/SwapTotal/ { print $2 }' /proc/meminfo)
else
- actual_memory=$(sysctl hw.physmem 2>/dev/null )
- [[ "$?" == "0" ]] &&
- actual_memory=$(echo $actual_memory | sed -e 's/^[^:=]*[:=]//' )
+ actual_memory=$(sysctl hw.physmem 2>/dev/null)
+ [[ $? -eq 0 ]] && actual_memory=$(echo "${actual_memory}" \
+ | sed -e 's/^[^:=]*[:=][[:space:]]*//')
+ actual_swap=$(sysctl vm.swap_total 2>/dev/null)
+ [[ $? -eq 0 ]] && actual_swap=$(echo "${actual_swap}" \
+ | sed -e 's/^[^:=]*[:=][[:space:]]*//')
fi
if [[ -n ${actual_memory} ]] ; then
- if [[ ${actual_memory} -lt $(check-reqs_get_kibibytes ${size}) ]] ; then
+ if [[ ${actual_memory} -ge $(check-reqs_get_kibibytes ${size}) ]] ; then
+ eend 0
+ elif [[ -n ${actual_swap} && $((${actual_memory} + ${actual_swap})) \
+ -ge $(check-reqs_get_kibibytes ${size}) ]] ; then
+ ewarn "Amount of main memory is insufficient, but amount"
+ ewarn "of main memory combined with swap is sufficient."
+ ewarn "Build process may make computer very slow!"
+ eend 0
+ else
eend 1
check-reqs_unsatisfied \
${size} \
"RAM"
- else
- eend 0
fi
else
eend 1
diff --git a/net-analyzer/net-snmp/Manifest b/net-analyzer/net-snmp/Manifest
index c95764cf911e..bf783d7727a0 100644
--- a/net-analyzer/net-snmp/Manifest
+++ b/net-analyzer/net-snmp/Manifest
@@ -1,6 +1,2 @@
-DIST net-snmp-5.7.3-patches-2.tar.xz 3312 BLAKE2B 9cf2b3b5ec2f65dc8c017565666c148acb42354f8a03274f67c856fea530df27877026aa2c0477d90cd2f035503e15cd48c33b449a9522c34c9dca370f7ed7a6 SHA512 22ca6cc4dd1fd58a8cff53881d248155dbfdab765e9a3664320c8c4a5cfa35e741adfb0304bb38be7719ba1c7418f9b0f9178719951b82d70257c3c944c450ad
DIST net-snmp-5.7.3-patches-3.tar.xz 3176 BLAKE2B 1a71d6743afb841f664c6058e32c7c411af62b0f36acd3bb9251804893ed12f462a0c5bab828e309eeec7824def2dca8fa866350b90a62ec4f0df1141b51ecae SHA512 d8a91b9668320a1e19d062eb86dd4d16beb7c2d15ac7ebbb9d2a4bd298af39bbb0a2613504dbb0057cccdec731f08f2308c5a15395e1fbc29bb0611ed8aca636
-DIST net-snmp-5.7.3-perl524-2.patch.gz 523 BLAKE2B 6762795cd6bcdccd5b49899cf572d5a498f3ab7fd20af69fad5f3fe45880e40f2aecfb0e9443a2a10773e25323ed5d0f271446d8fc03102e70fa8efd79e0d118 SHA512 bede47234b809d67f33c46654f3d09d0b255d835fb97eea23bfa888922dfb80ad287c305596a6b041ed03ec91dc7c647ecd54c3c79e0b4ce08978332de3cc007
-DIST net-snmp-5.7.3-perl524.patch.gz 9072 BLAKE2B d870e195bccb8178827791c9bd495d5c13a8848d176ae72b1c6b54b38eabc3b5aa4842d1841f422e3a71d9e9129b2acf303e8961ce98f82f5d9310c3a65e671d SHA512 2d3184ac7c96f75af5bf8c8d23f33d5636c701e052a638e5403a8d5aa34985abc38f6a366ba09a1d8499a05fd71d939a7ed4d530661e56a726386603b6f6e6a4
-DIST net-snmp-5.7.3.tar.gz 6382428 BLAKE2B df036da09658fdb4c52a99696fb6374cd582bc8da765e212285478ffb16c8725ddecd37842aba7835bc90ea74437ce00491dff569b1ce2c7499acf46968b3935 SHA512 0758bba5844cfd6c80959ac16b83906a2f830ba49fd0ab1bf9e191dc6a79d312a2e4760bd53b3e1a1c82759481f0064d088d5a3cf475d84b25679a6bd0f049bb
DIST net-snmp-5.8.tar.gz 6591680 BLAKE2B ac1bff4152310da57818a00d752a08a7fc61d697b02479d9952ca12d024d3d68dc8bfa674571e93d6f3597605b2fe91513fb6839057a80f2c3dd8d0cce0077f2 SHA512 27895a583b23f3e14c48562bc32f3ba83513d81aa848e878be9a3650f0458d45950635c937ef627135f80b757b663e71fab9a3bde4fd91889153998ae3468fe7
diff --git a/net-analyzer/net-snmp/files/net-snmp-5.7.3-mariadb-10.2.patch b/net-analyzer/net-snmp/files/net-snmp-5.7.3-mariadb-10.2.patch
deleted file mode 100644
index dea1a0178531..000000000000
--- a/net-analyzer/net-snmp/files/net-snmp-5.7.3-mariadb-10.2.patch
+++ /dev/null
@@ -1,56 +0,0 @@
---- a/apps/snmptrapd_sql.c
-+++ b/apps/snmptrapd_sql.c
-@@ -54,6 +54,7 @@
- #include <my_sys.h>
- #include <mysql.h>
- #include <errmsg.h>
-+#include <mysql_version.h>
-
- netsnmp_feature_require(container_fifo)
-
-@@ -437,6 +438,7 @@ netsnmp_mysql_init(void)
- return -1;
- }
-
-+#if MYSQL_VERSION_ID < 100000
- #ifdef HAVE_BROKEN_LIBMYSQLCLIENT
- my_init();
- #else
-@@ -445,6 +447,7 @@ netsnmp_mysql_init(void)
-
- /** load .my.cnf values */
- load_defaults ("my", _sql.groups, &not_argc, &not_argv);
-+#endif
- for(i=0; i < not_argc; ++i) {
- if (NULL == not_argv[i])
- continue;
-@@ -542,6 +545,10 @@ netsnmp_mysql_init(void)
- return -1;
- }
-
-+#if MYSQL_VERSION_ID > 100000
-+ mysql_options(_sql.conn, MYSQL_READ_DEFAULT_GROUP, "snmptrapd");
-+#endif
-+
- /** try to connect; we'll try again later if we fail */
- (void) netsnmp_mysql_connect();
-
---- a/apps/snmptrapd_sql.c
-+++ b/apps/snmptrapd_sql.c
-@@ -50,11 +50,16 @@
- #undef PACKAGE_STRING
- #undef PACKAGE_TARNAME
- #undef PACKAGE_VERSION
-+#ifdef HAVE_BROKEN_LIBMYSQLCLIENT
-+#include <mysql.h>
-+#include <errmsg.h>
-+#else
- #include <my_global.h>
- #include <my_sys.h>
- #include <mysql.h>
- #include <errmsg.h>
- #include <mysql_version.h>
-+#endif
-
- netsnmp_feature_require(container_fifo)
-
diff --git a/net-analyzer/net-snmp/files/net-snmp-5.7.3-perl524-2.patch b/net-analyzer/net-snmp/files/net-snmp-5.7.3-perl524-2.patch
deleted file mode 100644
index 45855597a867..000000000000
--- a/net-analyzer/net-snmp/files/net-snmp-5.7.3-perl524-2.patch
+++ /dev/null
@@ -1,70 +0,0 @@
---- a/perl/ASN/Makefile.PL
-+++ b/perl/ASN/Makefile.PL
-@@ -1,3 +1,4 @@
-+package ASN;
- use ExtUtils::MakeMaker;
- require 5;
- use Config;
---- a/perl/AnyData_SNMP/Makefile.PL
-+++ b/perl/AnyData_SNMP/Makefile.PL
-@@ -1,3 +1,4 @@
-+package AnyData_SNMP;
- use ExtUtils::MakeMaker;
- # See lib/ExtUtils/MakeMaker.pm for details of how to influence
- # the contents of the Makefile that is written.
---- a/perl/OID/Makefile.PL
-+++ b/perl/OID/Makefile.PL
-@@ -1,3 +1,4 @@
-+package OID;
- # See lib/ExtUtils/MakeMaker.pm for details of how to influence
- # the contents of the Makefile that is written.
-
---- a/perl/SNMP/Makefile.PL
-+++ b/perl/SNMP/Makefile.PL
-@@ -1,3 +1,4 @@
-+package SNMP;
- use ExtUtils::MakeMaker;
- require 5;
- use Config;
---- a/perl/TrapReceiver/Makefile.PL
-+++ b/perl/TrapReceiver/Makefile.PL
-@@ -1,3 +1,4 @@
-+package TrapReceiver;
- use ExtUtils::MakeMaker;
- require 5;
- use Config;
---- a/perl/agent/Makefile.PL
-+++ b/perl/agent/Makefile.PL
-@@ -1,3 +1,4 @@
-+package agent;
- use ExtUtils::MakeMaker;
- require 5;
- use Config;
---- a/perl/agent/Support/Makefile.PL
-+++ b/perl/agent/Support/Makefile.PL
-@@ -1,3 +1,4 @@
-+package agent_Support;
- use ExtUtils::MakeMaker;
- require 5;
- use Config;
---- a/perl/agent/default_store/Makefile.PL
-+++ b/perl/agent/default_store/Makefile.PL
-@@ -1,3 +1,4 @@
-+package agent_default_store;
- use ExtUtils::MakeMaker;
- require 5;
- use Config;
---- a/perl/default_store/Makefile.PL
-+++ b/perl/default_store/Makefile.PL
-@@ -1,3 +1,4 @@
-+package default_store;
- use ExtUtils::MakeMaker;
- require 5;
- use Config;
---- a/perl/manager/Makefile.PL
-+++ b/perl/manager/Makefile.PL
-@@ -1,3 +1,4 @@
-+package manager;
- use ExtUtils::MakeMaker;
- # See lib/ExtUtils/MakeMaker.pm for details of how to influence
- # the contents of the Makefile that is written.
diff --git a/net-analyzer/net-snmp/files/net-snmp-5.8-my_bool.patch b/net-analyzer/net-snmp/files/net-snmp-5.8-my_bool.patch
new file mode 100644
index 000000000000..72127d053c0a
--- /dev/null
+++ b/net-analyzer/net-snmp/files/net-snmp-5.8-my_bool.patch
@@ -0,0 +1,23 @@
+commit 9f4af8c42d515e6b214738cc97212dfbe7f749cf
+Author: Andreas Hasenack <ahasenack2@users.sourceforge.net>
+Date: Tue Feb 5 18:21:40 2019 -0800
+
+ apps/snmptrapd_sql: Fix build against MySQL 8
+
+ See also https://sourceforge.net/p/net-snmp/bugs/2922/.
+
+ [bvanassche: changed 'int' into 'char']
+
+diff --git a/apps/snmptrapd_sql.c b/apps/snmptrapd_sql.c
+index 6126ca916..32a3b1799 100644
+--- a/apps/snmptrapd_sql.c
++++ b/apps/snmptrapd_sql.c
+@@ -199,7 +199,7 @@ typedef struct sql_buf_t {
+ * static bind structures, plus 2 static buffers to bind to.
+ */
+ static MYSQL_BIND _tbind[TBIND_MAX], _vbind[VBIND_MAX];
+-static my_bool _no_v3;
++static char _no_v3;
+
+ static void _sql_process_queue(u_int dontcare, void *meeither);
+
diff --git a/net-analyzer/net-snmp/net-snmp-5.7.3-r5.ebuild b/net-analyzer/net-snmp/net-snmp-5.7.3-r5.ebuild
deleted file mode 100644
index 8d923fa28d7b..000000000000
--- a/net-analyzer/net-snmp/net-snmp-5.7.3-r5.ebuild
+++ /dev/null
@@ -1,192 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-DISTUTILS_SINGLE_IMPL=yesplz
-DISTUTILS_OPTIONAL=yesplz
-WANT_AUTOMAKE=none
-PATCHSET=2
-GENTOO_DEPEND_ON_PERL=no
-
-inherit autotools distutils-r1 eutils perl-module systemd
-
-DESCRIPTION="Software for generating and retrieving SNMP data"
-HOMEPAGE="http://net-snmp.sourceforge.net/"
-SRC_URI="
- mirror://sourceforge/project/${PN}/${PN}/${PV}/${P}.tar.gz
- https://dev.gentoo.org/~jer/${PN}-5.7.3-patches-${PATCHSET}.tar.xz
- https://dev.gentoo.org/~dilfridge/distfiles/${P}-perl524.patch.gz
- https://dev.gentoo.org/~dilfridge/distfiles/${P}-perl524-2.patch.gz
-"
-
-S=${WORKDIR}/${P/_/.}
-
-# GPL-2 for the init scripts
-LICENSE="HPND BSD GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86"
-IUSE="X bzip2 doc elf ipv6 libressl lm_sensors mfd-rewrites minimal mysql netlink pci perl python rpm selinux smux ssl tcpd ucd-compat zlib"
-
-COMMON_DEPEND="
- ssl? (
- !libressl? ( >=dev-libs/openssl-0.9.6d:0= )
- libressl? ( dev-libs/libressl:= )
- )
- tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
- rpm? (
- app-arch/rpm
- dev-libs/popt
- )
- bzip2? ( app-arch/bzip2 )
- zlib? ( >=sys-libs/zlib-1.1.4 )
- elf? ( dev-libs/elfutils )
- python? (
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${PYTHON_DEPS}
- )
- pci? ( sys-apps/pciutils )
- lm_sensors? ( sys-apps/lm_sensors )
- netlink? ( dev-libs/libnl:3 )
- mysql? ( virtual/mysql )
- perl? ( dev-lang/perl:= )
-"
-DEPEND="
- ${COMMON_DEPEND}
- doc? ( app-doc/doxygen )
-"
-RDEPEND="
- ${COMMON_DEPEND}
- perl? (
- X? ( dev-perl/Tk )
- !minimal? ( dev-perl/TermReadKey )
- )
- selinux? ( sec-policy/selinux-snmp )
-"
-
-REQUIRED_USE="
- python? ( ${PYTHON_REQUIRED_USE} )
- rpm? ( bzip2 zlib )
-"
-
-RESTRICT=test
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- # snmpconf generates config files with proper selinux context
- use selinux && epatch "${FILESDIR}"/${PN}-5.1.2-snmpconf-selinux.patch
-
- epatch "${WORKDIR}"/${P}-perl524.patch
- epatch "${WORKDIR}"/${P}-perl524-2.patch
- epatch "${FILESDIR}"/${PN}-5.7.3-include-limits.patch
-
- epatch "${WORKDIR}"/patches/*.patch
-
- epatch_user
-
- eautoconf
-}
-
-src_configure() {
- # keep this in the same line, configure.ac arguments are passed down to config.h
- local mibs="host ucd-snmp/dlmod ucd-snmp/diskio ucd-snmp/extensible mibII/mta_sendmail etherlike-mib/dot3StatsTable"
- use lm_sensors && mibs="${mibs} ucd-snmp/lmsensorsMib"
- use smux && mibs="${mibs} smux"
-
- # Assume /etc/mtab is not present with a recent baselayout/openrc (bug #565136)
- use kernel_linux && export ac_cv_ETC_MNTTAB=/etc/mtab
-
- econf \
- $(use_enable !ssl internal-md5) \
- $(use_enable ipv6) \
- $(use_enable mfd-rewrites) \
- $(use_enable perl embedded-perl) \
- $(use_enable ucd-compat ucd-snmp-compatibility) \
- $(use_with bzip2) \
- $(use_with elf) \
- $(use_with mysql) \
- $(use_with netlink nl) \
- $(use_with pci) \
- $(use_with perl perl-modules INSTALLDIRS=vendor) \
- $(use_with python python-modules) \
- $(use_with rpm) \
- $(use_with ssl openssl) \
- $(use_with tcpd libwrap) \
- $(use_with zlib) \
- --enable-shared --disable-static \
- --with-default-snmp-version="3" \
- --with-install-prefix="${D}" \
- --with-ldflags="${LDFLAGS}" \
- --with-logfile="/var/log/net-snmpd.log" \
- --with-mib-modules="${mibs}" \
- --with-persistent-directory="/var/lib/net-snmp" \
- --with-sys-contact="root@Unknown" \
- --with-sys-location="Unknown"
-}
-
-src_compile() {
- for target in snmplib agent sedscript all; do
- emake OTHERLDFLAGS="${LDFLAGS}" ${target}
- done
-
- use doc && emake docsdox
-}
-
-src_install () {
- # bug #317965
- emake -j1 DESTDIR="${D}" install
-
- if use perl ; then
- perl_delete_localpod
- if ! use X; then
- rm "${D}"/usr/bin/tkmib || die
- fi
- else
- rm -f \
- "${D}"/usr/bin/fixproc \
- "${D}"/usr/bin/ipf-mod.pl \
- "${D}"/usr/bin/mib2c \
- "${D}"/usr/bin/net-snmp-cert \
- "${D}"/usr/bin/snmp-bridge-mib \
- "${D}"/usr/bin/snmpcheck \
- "${D}"/usr/bin/snmpconf \
- "${D}"/usr/bin/tkmib \
- "${D}"/usr/bin/traptoemail \
- "${D}"/usr/share/snmp/mib2c.perl.conf \
- "${D}"/usr/share/snmp/snmp_perl_trapd.pl \
- || die
- fi
-
- dodoc AGENT.txt ChangeLog FAQ INSTALL NEWS PORTING README* TODO
- newdoc EXAMPLE.conf.def EXAMPLE.conf
-
- use doc && dohtml docs/html/*
-
- keepdir /var/lib/net-snmp
-
- newinitd "${FILESDIR}"/snmpd.init.2 snmpd
- newconfd "${FILESDIR}"/snmpd.conf snmpd
-
- newinitd "${FILESDIR}"/snmptrapd.init.2 snmptrapd
- newconfd "${FILESDIR}"/snmptrapd.conf snmptrapd
-
- systemd_dounit "${FILESDIR}"/snmpd.service
- systemd_dounit "${FILESDIR}"/snmptrapd.service
-
- insinto /etc/snmp
- newins "${S}"/EXAMPLE.conf snmpd.conf.example
-
- # Remove everything not required for an agent.
- # Keep only the snmpd, snmptrapd, MIBs, headers and libraries.
- if use minimal; then
- rm -rf \
- "${D}"/**/*.pl \
- "${D}"/usr/bin/{encode_keychange,snmp{get,getnext,set,usm,walk,bulkwalk,table,trap,bulkget,translate,status,delta,test,df,vacm,netstat,inform,check,conf},fixproc,traptoemail} \
- "${D}"/usr/share/snmp/*.conf \
- "${D}"/usr/share/snmp/snmpconf-data \
- || die
- fi
-}
diff --git a/net-analyzer/net-snmp/net-snmp-5.7.3-r6.ebuild b/net-analyzer/net-snmp/net-snmp-5.7.3-r6.ebuild
deleted file mode 100644
index 060479915394..000000000000
--- a/net-analyzer/net-snmp/net-snmp-5.7.3-r6.ebuild
+++ /dev/null
@@ -1,194 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-DISTUTILS_SINGLE_IMPL=yesplz
-DISTUTILS_OPTIONAL=yesplz
-WANT_AUTOMAKE=none
-PATCHSET=2
-GENTOO_DEPEND_ON_PERL=no
-
-inherit autotools distutils-r1 eutils perl-module systemd
-
-DESCRIPTION="Software for generating and retrieving SNMP data"
-HOMEPAGE="http://net-snmp.sourceforge.net/"
-SRC_URI="
- mirror://sourceforge/project/${PN}/${PN}/${PV}/${P}.tar.gz
- https://dev.gentoo.org/~jer/${PN}-5.7.3-patches-${PATCHSET}.tar.xz
- https://dev.gentoo.org/~dilfridge/distfiles/${P}-perl524.patch.gz
- https://dev.gentoo.org/~dilfridge/distfiles/${P}-perl524-2.patch.gz
-"
-
-S=${WORKDIR}/${P/_/.}
-
-# GPL-2 for the init scripts
-LICENSE="HPND BSD GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="X bzip2 doc elf ipv6 libressl lm_sensors mfd-rewrites minimal mysql netlink pci perl python rpm selinux smux ssl tcpd ucd-compat zlib"
-
-COMMON_DEPEND="
- ssl? (
- !libressl? ( >=dev-libs/openssl-0.9.6d:0= )
- libressl? ( dev-libs/libressl:= )
- )
- tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
- rpm? (
- app-arch/rpm
- dev-libs/popt
- )
- bzip2? ( app-arch/bzip2 )
- zlib? ( >=sys-libs/zlib-1.1.4 )
- elf? ( dev-libs/elfutils )
- python? (
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${PYTHON_DEPS}
- )
- pci? ( sys-apps/pciutils )
- lm_sensors? ( sys-apps/lm_sensors )
- netlink? ( dev-libs/libnl:3 )
- mysql? ( virtual/mysql )
- perl? ( dev-lang/perl:= )
-"
-DEPEND="
- ${COMMON_DEPEND}
- doc? ( app-doc/doxygen )
-"
-RDEPEND="
- ${COMMON_DEPEND}
- perl? (
- X? ( dev-perl/Tk )
- !minimal? ( dev-perl/TermReadKey )
- )
- selinux? ( sec-policy/selinux-snmp )
-"
-
-REQUIRED_USE="
- python? ( ${PYTHON_REQUIRED_USE} )
- rpm? ( bzip2 zlib )
-"
-
-RESTRICT=test
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- # snmpconf generates config files with proper selinux context
- use selinux && epatch "${FILESDIR}"/${PN}-5.1.2-snmpconf-selinux.patch
-
- epatch "${WORKDIR}"/${P}-perl524.patch
- epatch "${WORKDIR}"/${P}-perl524-2.patch
- epatch "${FILESDIR}"/${PN}-5.7.3-include-limits.patch
-
- epatch "${WORKDIR}"/patches/*.patch
-
- epatch_user
-
- eautoconf
-}
-
-src_configure() {
- # keep this in the same line, configure.ac arguments are passed down to config.h
- local mibs="host ucd-snmp/dlmod ucd-snmp/diskio ucd-snmp/extensible mibII/mta_sendmail etherlike-mib/dot3StatsTable"
- use lm_sensors && mibs="${mibs} ucd-snmp/lmsensorsMib"
- use smux && mibs="${mibs} smux"
-
- # Assume /etc/mtab is not present with a recent baselayout/openrc (bug #565136)
- use kernel_linux && export ac_cv_ETC_MNTTAB=/etc/mtab
-
- econf \
- $(use_enable !ssl internal-md5) \
- $(use_enable ipv6) \
- $(use_enable mfd-rewrites) \
- $(use_enable perl embedded-perl) \
- $(use_enable ucd-compat ucd-snmp-compatibility) \
- $(use_with bzip2) \
- $(use_with elf) \
- $(use_with mysql) \
- $(use_with netlink nl) \
- $(use_with pci) \
- $(use_with perl perl-modules INSTALLDIRS=vendor) \
- $(use_with python python-modules) \
- $(use_with rpm) \
- $(use_with ssl openssl) \
- $(use_with tcpd libwrap) \
- $(use_with zlib) \
- --enable-shared --disable-static \
- --with-default-snmp-version="3" \
- --with-install-prefix="${D}" \
- --with-ldflags="${LDFLAGS}" \
- --with-logfile="/var/log/net-snmpd.log" \
- --with-mib-modules="${mibs}" \
- --with-persistent-directory="/var/lib/net-snmp" \
- --with-sys-contact="root@Unknown" \
- --with-sys-location="Unknown"
-}
-
-src_compile() {
- for target in snmplib agent sedscript all; do
- emake OTHERLDFLAGS="${LDFLAGS}" ${target}
- done
-
- use doc && emake docsdox
-}
-
-src_install () {
- # bug #317965
- emake -j1 DESTDIR="${D}" install
-
- if use perl ; then
- perl_delete_localpod
- if ! use X; then
- rm "${D}"/usr/bin/tkmib || die
- fi
- else
- rm -f \
- "${D}"/usr/bin/fixproc \
- "${D}"/usr/bin/ipf-mod.pl \
- "${D}"/usr/bin/mib2c \
- "${D}"/usr/bin/net-snmp-cert \
- "${D}"/usr/bin/snmp-bridge-mib \
- "${D}"/usr/bin/snmpcheck \
- "${D}"/usr/bin/snmpconf \
- "${D}"/usr/bin/tkmib \
- "${D}"/usr/bin/traptoemail \
- "${D}"/usr/share/snmp/mib2c.perl.conf \
- "${D}"/usr/share/snmp/snmp_perl_trapd.pl \
- || die
- fi
-
- dodoc AGENT.txt ChangeLog FAQ INSTALL NEWS PORTING README* TODO
- newdoc EXAMPLE.conf.def EXAMPLE.conf
-
- use doc && dohtml docs/html/*
-
- keepdir /var/lib/net-snmp
-
- newinitd "${FILESDIR}"/snmpd.init.2 snmpd
- newconfd "${FILESDIR}"/snmpd.conf snmpd
-
- newinitd "${FILESDIR}"/snmptrapd.init.2 snmptrapd
- newconfd "${FILESDIR}"/snmptrapd.conf snmptrapd
-
- systemd_dounit "${FILESDIR}"/snmpd.service
- systemd_dounit "${FILESDIR}"/snmptrapd.service
-
- insinto /etc/snmp
- newins "${S}"/EXAMPLE.conf snmpd.conf.example
-
- # Remove everything not required for an agent.
- # Keep only the snmpd, snmptrapd, MIBs, headers and libraries.
- if use minimal; then
- rm -rf \
- "${D}"/**/*.pl \
- "${D}"/usr/bin/{encode_keychange,snmp{get,getnext,set,usm,walk,bulkwalk,table,trap,bulkget,translate,status,delta,test,df,vacm,netstat,inform,check,conf},fixproc,traptoemail} \
- "${D}"/usr/share/snmp/*.conf \
- "${D}"/usr/share/snmp/snmpconf-data \
- || die
- fi
-
- prune_libtool_files
-}
diff --git a/net-analyzer/net-snmp/net-snmp-5.7.3_p3-r1.ebuild b/net-analyzer/net-snmp/net-snmp-5.8-r2.ebuild
index 4add1e5486bb..2452860409a7 100644
--- a/net-analyzer/net-snmp/net-snmp-5.7.3_p3-r1.ebuild
+++ b/net-analyzer/net-snmp/net-snmp-5.8-r2.ebuild
@@ -12,20 +12,19 @@ GENTOO_DEPEND_ON_PERL=no
inherit autotools distutils-r1 eutils perl-module systemd
DESCRIPTION="Software for generating and retrieving SNMP data"
-HOMEPAGE="http://net-snmp.sourceforge.net/"
+HOMEPAGE="http://www.net-snmp.org/"
SRC_URI="
mirror://sourceforge/project/${PN}/${PN}/${PV/_p*/}/${P/_p*/}.tar.gz
- https://dev.gentoo.org/~jer/${PN}-5.7.3-patches-${PV/*_p/}.tar.xz
- https://dev.gentoo.org/~dilfridge/distfiles/${P/_p*/}-perl524.patch.gz
+ https://dev.gentoo.org/~jer/${PN}-5.7.3-patches-3.tar.xz
"
S=${WORKDIR}/${P/_/.}
# GPL-2 for the init scripts
LICENSE="HPND BSD GPL-2"
-SLOT="0"
+SLOT="0/35"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="X bzip2 doc elf ipv6 libressl lm_sensors mfd-rewrites minimal mysql netlink pci perl python rpm selinux smux ssl tcpd ucd-compat zlib"
+IUSE="X bzip2 doc elf kmem ipv6 libressl lm_sensors mfd-rewrites minimal mysql netlink pci perl python rpm selinux smux ssl tcpd ucd-compat zlib"
COMMON_DEPEND="
ssl? (
@@ -79,11 +78,12 @@ src_prepare() {
# snmpconf generates config files with proper selinux context
use selinux && eapply "${FILESDIR}"/${PN}-5.1.2-snmpconf-selinux.patch
- eapply "${WORKDIR}"/${PN}-5.7.3-perl524.patch
- eapply "${FILESDIR}"/${PN}-5.7.3-perl524-2.patch
- eapply "${FILESDIR}"/${PN}-5.7.3-mariadb-10.2.patch
eapply "${FILESDIR}"/${PN}-5.7.3-include-limits.patch
+ eapply "${FILESDIR}"/${PN}-5.8-my_bool.patch
+ eapply "${FILESDIR}"/${PN}-5.8-tinfo.patch
+ mv "${WORKDIR}"/patches/0002-Respect-DESTDIR-for-pythoninstall.patch{,.disabled} || die
+ mv "${WORKDIR}"/patches/0004-Don-t-report-CFLAGS-and-LDFLAGS-in-net-snmp-config.patch{,.disabled} || die
eapply "${WORKDIR}"/patches/*.patch
eapply_user
@@ -108,6 +108,7 @@ src_configure() {
$(use_enable ucd-compat ucd-snmp-compatibility) \
$(use_with bzip2) \
$(use_with elf) \
+ $(use_with kmem kmem-usage) \
$(use_with mysql) \
$(use_with netlink nl) \
$(use_with pci) \