summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-devel/lld/lld-13.0.0.9999.ebuild5
-rw-r--r--sys-devel/lld/lld-13.0.0.ebuild5
-rw-r--r--sys-devel/lld/lld-14.0.0.9999.ebuild5
3 files changed, 12 insertions, 3 deletions
diff --git a/sys-devel/lld/lld-13.0.0.9999.ebuild b/sys-devel/lld/lld-13.0.0.9999.ebuild
index 68762b0a03cc..8bcce2b3022a 100644
--- a/sys-devel/lld/lld-13.0.0.9999.ebuild
+++ b/sys-devel/lld/lld-13.0.0.9999.ebuild
@@ -12,7 +12,7 @@ HOMEPAGE="https://llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
KEYWORDS=""
-IUSE="test"
+IUSE="debug test"
RESTRICT="!test? ( test )"
RDEPEND="~sys-devel/llvm-${PV}"
@@ -48,6 +48,9 @@ src_unpack() {
}
src_configure() {
+ # LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
+ use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
+
local mycmakeargs=(
-DBUILD_SHARED_LIBS=ON
-DLLVM_INCLUDE_TESTS=$(usex test)
diff --git a/sys-devel/lld/lld-13.0.0.ebuild b/sys-devel/lld/lld-13.0.0.ebuild
index 28e940174a88..26c283fd6489 100644
--- a/sys-devel/lld/lld-13.0.0.ebuild
+++ b/sys-devel/lld/lld-13.0.0.ebuild
@@ -12,7 +12,7 @@ HOMEPAGE="https://llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
-IUSE="test"
+IUSE="debug test"
RESTRICT="!test? ( test )"
RDEPEND="~sys-devel/llvm-${PV}"
@@ -48,6 +48,9 @@ src_unpack() {
}
src_configure() {
+ # LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
+ use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
+
local mycmakeargs=(
-DBUILD_SHARED_LIBS=ON
-DLLVM_INCLUDE_TESTS=$(usex test)
diff --git a/sys-devel/lld/lld-14.0.0.9999.ebuild b/sys-devel/lld/lld-14.0.0.9999.ebuild
index 68762b0a03cc..8bcce2b3022a 100644
--- a/sys-devel/lld/lld-14.0.0.9999.ebuild
+++ b/sys-devel/lld/lld-14.0.0.9999.ebuild
@@ -12,7 +12,7 @@ HOMEPAGE="https://llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
KEYWORDS=""
-IUSE="test"
+IUSE="debug test"
RESTRICT="!test? ( test )"
RDEPEND="~sys-devel/llvm-${PV}"
@@ -48,6 +48,9 @@ src_unpack() {
}
src_configure() {
+ # LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
+ use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
+
local mycmakeargs=(
-DBUILD_SHARED_LIBS=ON
-DLLVM_INCLUDE_TESTS=$(usex test)