summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/libtirpc/libtirpc-1.0.2-r1.ebuild3
-rw-r--r--sys-apps/systemd/systemd-239-r4.ebuild2
-rw-r--r--sys-libs/queue-standalone/queue-standalone-0.1-r1.ebuild (renamed from sys-libs/queue-standalone/queue-standalone-0.1.ebuild)6
3 files changed, 6 insertions, 5 deletions
diff --git a/net-libs/libtirpc/libtirpc-1.0.2-r1.ebuild b/net-libs/libtirpc/libtirpc-1.0.2-r1.ebuild
index 78e72ddcfc29..effab58d64ba 100644
--- a/net-libs/libtirpc/libtirpc-1.0.2-r1.ebuild
+++ b/net-libs/libtirpc/libtirpc-1.0.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -17,6 +17,7 @@ IUSE="ipv6 kerberos static-libs"
RDEPEND="kerberos? ( >=virtual/krb5-0-r1[${MULTILIB_USEDEP}] )"
DEPEND="${RDEPEND}
+ elibc_musl? ( sys-libs/queue-standalone )
app-arch/xz-utils
>=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]"
diff --git a/sys-apps/systemd/systemd-239-r4.ebuild b/sys-apps/systemd/systemd-239-r4.ebuild
index bf431936e41a..ca4101b83960 100644
--- a/sys-apps/systemd/systemd-239-r4.ebuild
+++ b/sys-apps/systemd/systemd-239-r4.ebuild
@@ -9,7 +9,7 @@ if [[ ${PV} == 9999 ]]; then
else
SRC_URI="https://github.com/systemd/systemd/archive/v${PV}/${P}.tar.gz
https://dev.gentoo.org/~floppym/dist/${P}-patches-2.tar.gz"
- KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+ KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
fi
PYTHON_COMPAT=( python{3_4,3_5,3_6,3_7} )
diff --git a/sys-libs/queue-standalone/queue-standalone-0.1.ebuild b/sys-libs/queue-standalone/queue-standalone-0.1-r1.ebuild
index a9ef63bd65bc..29250dafba9d 100644
--- a/sys-libs/queue-standalone/queue-standalone-0.1.ebuild
+++ b/sys-libs/queue-standalone/queue-standalone-0.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -17,6 +17,6 @@ DEPEND="
S="${WORKDIR}"
src_install() {
- mkdir -p "${D}"/usr/include/sys
- cp "${FILESDIR}"/queue.h "${D}"/usr/include/sys
+ insinto /usr/include/sys
+ doins "${FILESDIR}"/queue.h
}