summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/twisted-web/twisted-web-13.0.0-r1.ebuild6
-rw-r--r--dev-python/twisted-web/twisted-web-13.2.0.ebuild8
-rw-r--r--dev-python/twisted-web/twisted-web-15.1.0.ebuild8
-rw-r--r--dev-python/twisted-web/twisted-web-15.2.1.ebuild8
4 files changed, 19 insertions, 11 deletions
diff --git a/dev-python/twisted-web/twisted-web-13.0.0-r1.ebuild b/dev-python/twisted-web/twisted-web-13.0.0-r1.ebuild
index 1db02f5dbde6..ab9f1dd662f1 100644
--- a/dev-python/twisted-web/twisted-web-13.0.0-r1.ebuild
+++ b/dev-python/twisted-web/twisted-web-13.0.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -12,7 +12,9 @@ DESCRIPTION="Twisted web server, programmable in Python"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="soap"
-DEPEND="=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
+DEPEND="
+ !dev-python/twisted
+ =dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
soap? ( dev-python/soappy[${PYTHON_USEDEP}] )"
RDEPEND="${DEPEND}"
diff --git a/dev-python/twisted-web/twisted-web-13.2.0.ebuild b/dev-python/twisted-web/twisted-web-13.2.0.ebuild
index eee1947b802c..674840c28e90 100644
--- a/dev-python/twisted-web/twisted-web-13.2.0.ebuild
+++ b/dev-python/twisted-web/twisted-web-13.2.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -13,8 +13,10 @@ DESCRIPTION="Twisted web server, programmable in Python"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="soap"
-DEPEND="=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
+DEPEND="
+ !dev-python/twisted
+ =dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
soap? ( dev-python/soappy[${PYTHON_USEDEP}] )"
RDEPEND="${DEPEND}"
diff --git a/dev-python/twisted-web/twisted-web-15.1.0.ebuild b/dev-python/twisted-web/twisted-web-15.1.0.ebuild
index 039a4cbff409..4bb97ff34685 100644
--- a/dev-python/twisted-web/twisted-web-15.1.0.ebuild
+++ b/dev-python/twisted-web/twisted-web-15.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -13,8 +13,10 @@ DESCRIPTION="Twisted web server, programmable in Python"
KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="soap"
-DEPEND="=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
+DEPEND="
+ !dev-python/twisted
+ =dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
soap? ( dev-python/soappy[${PYTHON_USEDEP}] )"
RDEPEND="${DEPEND}"
diff --git a/dev-python/twisted-web/twisted-web-15.2.1.ebuild b/dev-python/twisted-web/twisted-web-15.2.1.ebuild
index 9cccf68580ea..5035760681e1 100644
--- a/dev-python/twisted-web/twisted-web-15.2.1.ebuild
+++ b/dev-python/twisted-web/twisted-web-15.2.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -13,8 +13,10 @@ DESCRIPTION="Twisted web server, programmable in Python"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="soap"
-DEPEND="=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
+DEPEND="
+ !dev-python/twisted
+ =dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
soap? ( dev-python/soappy[${PYTHON_USEDEP}] )"
RDEPEND="${DEPEND}"