summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/libdbh/libdbh-5.0.19.ebuild8
-rw-r--r--dev-libs/libdbh/libdbh-5.0.22.ebuild16
2 files changed, 16 insertions, 8 deletions
diff --git a/dev-libs/libdbh/libdbh-5.0.19.ebuild b/dev-libs/libdbh/libdbh-5.0.19.ebuild
index d545dd68e5e6..81bdaa952a54 100644
--- a/dev-libs/libdbh/libdbh-5.0.19.ebuild
+++ b/dev-libs/libdbh/libdbh-5.0.19.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-inherit autotools eutils ltprune
+inherit autotools eutils
MY_P=${PN}2-${PV}
@@ -31,7 +31,11 @@ src_prepare() {
eautoreconf
}
+src_configure() {
+ econf --disable-static
+}
+
src_install() {
default
- prune_libtool_files
+ find "${ED}" -name '*.la' -delete || die
}
diff --git a/dev-libs/libdbh/libdbh-5.0.22.ebuild b/dev-libs/libdbh/libdbh-5.0.22.ebuild
index a32cdfb61dfe..e15065a43d35 100644
--- a/dev-libs/libdbh/libdbh-5.0.22.ebuild
+++ b/dev-libs/libdbh/libdbh-5.0.22.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
inherit autotools
MY_P=${PN}2-${PV}
@@ -13,9 +14,9 @@ SRC_URI="mirror://sourceforge/dbh/dbh/${PV}/${MY_P}.tar.gz"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND="dev-util/gtk-doc-am
+BDEPEND="
+ dev-util/gtk-doc-am
virtual/pkgconfig"
S="${WORKDIR}/${MY_P}"
@@ -28,8 +29,11 @@ src_prepare() {
eautoreconf
}
+src_configure() {
+ econf --disable-static
+}
+
src_install() {
default
-
- find "${D}" -name '*.la' -delete || die
+ find "${ED}" -name '*.la' -delete || die
}