summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-apps/trac-mercurial/trac-mercurial-0.12.0.29_pre10899-r1.ebuild (renamed from www-apps/trac-mercurial/trac-mercurial-0.12.0.29_pre10899.ebuild)16
-rw-r--r--www-apps/trac-mercurial/trac-mercurial-1.0.0.3_pre20130206-r1.ebuild (renamed from www-apps/trac-mercurial/trac-mercurial-1.0.0.3_pre20130206.ebuild)16
2 files changed, 14 insertions, 18 deletions
diff --git a/www-apps/trac-mercurial/trac-mercurial-0.12.0.29_pre10899.ebuild b/www-apps/trac-mercurial/trac-mercurial-0.12.0.29_pre10899-r1.ebuild
index 5919028edef3..0611467c4ad4 100644
--- a/www-apps/trac-mercurial/trac-mercurial-0.12.0.29_pre10899.ebuild
+++ b/www-apps/trac-mercurial/trac-mercurial-0.12.0.29_pre10899-r1.ebuild
@@ -1,14 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=3
+EAPI=6
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
+PYTHON_COMPAT=( python2_7 )
-inherit distutils
+inherit distutils-r1
MY_PN="TracMercurial"
MY_P="${MY_PN}-${PV/_pre/dev-r}"
@@ -22,8 +20,8 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="dev-python/setuptools"
-RDEPEND=">=www-apps/trac-0.12
- >=dev-vcs/mercurial-1.1"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=">=www-apps/trac-0.12[${PYTHON_USEDEP}]
+ >=dev-vcs/mercurial-1.1[${PYTHON_USEDEP}]"
S="${WORKDIR}/${MY_P}"
diff --git a/www-apps/trac-mercurial/trac-mercurial-1.0.0.3_pre20130206.ebuild b/www-apps/trac-mercurial/trac-mercurial-1.0.0.3_pre20130206-r1.ebuild
index 4158f02d78ac..6989df50ac58 100644
--- a/www-apps/trac-mercurial/trac-mercurial-1.0.0.3_pre20130206.ebuild
+++ b/www-apps/trac-mercurial/trac-mercurial-1.0.0.3_pre20130206-r1.ebuild
@@ -1,14 +1,12 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=6
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
+PYTHON_COMPAT=( python2_7 )
-inherit distutils mercurial
+inherit distutils-r1 mercurial
MY_PN="TracMercurial"
MY_P="${MY_PN}-${PV/_pre/dev-r}"
@@ -23,8 +21,8 @@ SLOT="0"
# KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="dev-python/setuptools"
-RDEPEND=">=www-apps/trac-1.0
- >=dev-vcs/mercurial-1.1"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=">=www-apps/trac-1.0[${PYTHON_USEDEP}]
+ >=dev-vcs/mercurial-1.1[${PYTHON_USEDEP}]"
S="${WORKDIR}/${MY_P}"