summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/micropython/micropython-1.11.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-lang/micropython/micropython-1.11.ebuild b/dev-lang/micropython/micropython-1.11.ebuild
index a7361e69166f..e0c69a12c7ab 100644
--- a/dev-lang/micropython/micropython-1.11.ebuild
+++ b/dev-lang/micropython/micropython-1.11.ebuild
@@ -31,18 +31,18 @@ src_compile() {
-e 's#\/usr\/local#\/usr#g;' \
Makefile || die
- emake CC="$(tc-getCC)" axtls
- emake CC="$(tc-getCC)"
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" axtls
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
}
src_test() {
cd ports/unix || die
- emake CC="$(tc-getCC)" test
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" test
}
src_install() {
pushd ports/unix > /dev/null || die
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" DESTDIR="${D}" install
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" DESTDIR="${D}" install
popd > /dev/null || die
# remove .git files