summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--profiles/arch/x86/package.use.mask5
-rw-r--r--sci-mathematics/coq/coq-8.11.2-r1.ebuild90
-rw-r--r--sci-mathematics/coq/coq-8.12.0-r2.ebuild90
-rw-r--r--sci-mathematics/coq/coq-8.13.0-r1.ebuild88
-rw-r--r--sci-physics/thepeg/Manifest1
-rw-r--r--sci-physics/thepeg/thepeg-2.0.4-r1.ebuild (renamed from sci-physics/thepeg/thepeg-2.0.4.ebuild)26
-rw-r--r--sci-physics/thepeg/thepeg-2.2.2.ebuild97
7 files changed, 385 insertions, 12 deletions
diff --git a/profiles/arch/x86/package.use.mask b/profiles/arch/x86/package.use.mask
index e8c84f7b7376..9889daf8c843 100644
--- a/profiles/arch/x86/package.use.mask
+++ b/profiles/arch/x86/package.use.mask
@@ -1,6 +1,11 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Ionen Wolkens <ionen@gentoo.org> (2021-07-26)
+# nvenc on x86 needs both legacy 390 drivers and old vulnerable
+# <=media-video/ffmpeg-4.2.4, nvidia has no real x86 support.
+media-video/obs-studio nvenc
+
# Marek Szuba <marecki@gentoo.org> (2021-07-17)
# media-libs/rnnoise, media-plugins/gst-plugins-webrtc
# and media-plugins/zam-plugins not keyworded here
diff --git a/sci-mathematics/coq/coq-8.11.2-r1.ebuild b/sci-mathematics/coq/coq-8.11.2-r1.ebuild
new file mode 100644
index 000000000000..d4baaa412f2b
--- /dev/null
+++ b/sci-mathematics/coq/coq-8.11.2-r1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop multilib
+
+MY_PV=${PV/_p/pl}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Proof assistant written in O'Caml"
+HOMEPAGE="http://coq.inria.fr/"
+SRC_URI="https://github.com/coq/coq/archive/V${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk debug +ocamlopt doc"
+
+RESTRICT=test
+
+RDEPEND="
+ dev-ml/camlp5:=[ocamlopt?]
+ || (
+ dev-ml/num
+ <dev-lang/ocaml-4.09.0[ocamlopt?]
+ )
+ gtk? (
+ dev-ml/lablgtk:3=[sourceview,ocamlopt?]
+ dev-ml/lablgtk-sourceview:3=[ocamlopt?]
+ )"
+DEPEND="${RDEPEND}
+ dev-ml/findlib
+ doc? (
+ media-libs/netpbm[png,postscript(+),zlib(+)]
+ virtual/latex-base
+ dev-tex/hevea
+ dev-texlive/texlive-latexrecommended
+ dev-texlive/texlive-pictures
+ dev-texlive/texlive-mathscience
+ dev-texlive/texlive-latexextra
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ ocaml_lib=$(ocamlc -where)
+ local myconf=(
+ -prefix /usr
+ -bindir /usr/bin
+ -libdir /usr/$(get_libdir)/coq
+ -mandir /usr/share/man
+ -coqdocdir /usr/$(get_libdir)/coq/coqdoc
+ -docdir /usr/share/doc/${PF}
+ -configdir /etc/xdg/${PN}
+ )
+
+ use debug && myconf+=( -debug )
+ use doc || myconf+=( -with-doc no )
+
+ if use gtk; then
+ if use ocamlopt; then
+ myconf+=( -coqide opt )
+ else
+ myconf+=( -coqide byte )
+ fi
+ else
+ myconf+=( -coqide no )
+ fi
+
+ use ocamlopt || myconf+=( -byte-only )
+
+ export CAML_LD_LIBRARY_PATH="${S}/kernel/byterun/"
+ ./configure ${myconf[@]} || die "configure failed"
+}
+
+src_compile() {
+ emake STRIP="true" -j1 world VERBOSE=1
+}
+
+src_test() {
+ emake STRIP="true" check VERBOSE=1
+}
+
+src_install() {
+ emake STRIP="true" COQINSTALLPREFIX="${D}" install VERBOSE=1
+ dodoc README.md CREDITS
+
+ use gtk && make_desktop_entry "coqide" "Coq IDE" "${EPREFIX}/usr/share/coq/coq.png"
+}
diff --git a/sci-mathematics/coq/coq-8.12.0-r2.ebuild b/sci-mathematics/coq/coq-8.12.0-r2.ebuild
new file mode 100644
index 000000000000..8ac534f46bf8
--- /dev/null
+++ b/sci-mathematics/coq/coq-8.12.0-r2.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop multilib
+
+MY_PV=${PV/_p/pl}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Proof assistant written in O'Caml"
+HOMEPAGE="http://coq.inria.fr/"
+SRC_URI="https://github.com/coq/coq/archive/V${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk debug +ocamlopt doc"
+
+RESTRICT=test
+
+RDEPEND="
+ dev-ml/camlp5:=[ocamlopt?]
+ || (
+ dev-ml/num
+ <dev-lang/ocaml-4.09.0[ocamlopt?]
+ )
+ gtk? (
+ dev-ml/lablgtk:3=[sourceview,ocamlopt?]
+ dev-ml/lablgtk-sourceview:3=[ocamlopt?]
+ )"
+DEPEND="${RDEPEND}
+ dev-ml/findlib
+ doc? (
+ media-libs/netpbm[png,postscript(+),zlib(+)]
+ virtual/latex-base
+ dev-tex/hevea
+ dev-texlive/texlive-latexrecommended
+ dev-texlive/texlive-pictures
+ dev-texlive/texlive-mathscience
+ dev-texlive/texlive-latexextra
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ ocaml_lib=$(ocamlc -where)
+ local myconf=(
+ -prefix /usr
+ -bindir /usr/bin
+ -libdir /usr/$(get_libdir)/coq
+ -mandir /usr/share/man
+ -coqdocdir /usr/$(get_libdir)/coq/coqdoc
+ -docdir /usr/share/doc/${PF}
+ -configdir /etc/xdg/${PN}
+ )
+
+ use debug && myconf+=( -debug )
+ use doc || myconf+=( -with-doc no )
+
+ if use gtk; then
+ if use ocamlopt; then
+ myconf+=( -coqide opt )
+ else
+ myconf+=( -coqide byte )
+ fi
+ else
+ myconf+=( -coqide no )
+ fi
+
+ use ocamlopt || myconf+=( -byte-only )
+
+ export CAML_LD_LIBRARY_PATH="${S}/kernel/byterun/"
+ ./configure ${myconf[@]} || die "configure failed"
+}
+
+src_compile() {
+ emake STRIP="true" -j1 world VERBOSE=1
+}
+
+src_test() {
+ emake STRIP="true" check VERBOSE=1
+}
+
+src_install() {
+ emake STRIP="true" COQINSTALLPREFIX="${D}" install -j1 VERBOSE=1
+ dodoc README.md CREDITS
+
+ use gtk && make_desktop_entry "coqide" "Coq IDE" "${EPREFIX}/usr/share/coq/coq.png"
+}
diff --git a/sci-mathematics/coq/coq-8.13.0-r1.ebuild b/sci-mathematics/coq/coq-8.13.0-r1.ebuild
new file mode 100644
index 000000000000..2ce871790746
--- /dev/null
+++ b/sci-mathematics/coq/coq-8.13.0-r1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop findlib
+
+MY_PV=${PV/_p/pl}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Proof assistant written in O'Caml"
+HOMEPAGE="http://coq.inria.fr/"
+SRC_URI="https://github.com/coq/coq/archive/V${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk debug +ocamlopt doc"
+
+RESTRICT="test"
+
+RDEPEND="
+ dev-ml/zarith
+ || (
+ dev-ml/num
+ <dev-lang/ocaml-4.09.0[ocamlopt?]
+ )
+ gtk? (
+ dev-ml/lablgtk:3=[sourceview,ocamlopt?]
+ dev-ml/lablgtk-sourceview:3=[ocamlopt?]
+ )"
+DEPEND="${RDEPEND}
+ doc? (
+ media-libs/netpbm[png,postscript(+),zlib(+)]
+ virtual/latex-base
+ dev-tex/hevea
+ dev-texlive/texlive-latexrecommended
+ dev-texlive/texlive-pictures
+ dev-texlive/texlive-mathscience
+ dev-texlive/texlive-latexextra
+ )"
+
+src_configure() {
+ ocaml_lib=$(ocamlc -where)
+ local myconf=(
+ -prefix /usr
+ -bindir /usr/bin
+ -libdir /usr/$(get_libdir)/coq
+ -mandir /usr/share/man
+ -coqdocdir /usr/$(get_libdir)/coq/coqdoc
+ -docdir /usr/share/doc/${PF}
+ -configdir /etc/xdg/${PN}
+ )
+
+ use debug && myconf+=( -debug )
+ use doc || myconf+=( -with-doc no )
+
+ if use gtk; then
+ if use ocamlopt; then
+ myconf+=( -coqide opt )
+ else
+ myconf+=( -coqide byte )
+ fi
+ else
+ myconf+=( -coqide no )
+ fi
+
+ use ocamlopt || myconf+=( -byte-only )
+
+ export CAML_LD_LIBRARY_PATH="${S}/kernel/byterun/"
+ ./configure ${myconf[@]} || die "configure failed"
+}
+
+src_compile() {
+ emake STRIP="true" -j1 world VERBOSE=1
+}
+
+src_test() {
+ emake STRIP="true" check VERBOSE=1
+}
+
+src_install() {
+ emake STRIP="true" COQINSTALLPREFIX="${D}" install -j1 VERBOSE=1
+ dodoc README.md CREDITS
+
+ use gtk && make_desktop_entry "coqide" "Coq IDE" "${EPREFIX}/usr/share/coq/coq.png"
+}
diff --git a/sci-physics/thepeg/Manifest b/sci-physics/thepeg/Manifest
index 8452bd82cff2..64a8a9e21bc1 100644
--- a/sci-physics/thepeg/Manifest
+++ b/sci-physics/thepeg/Manifest
@@ -1,5 +1,6 @@
DIST GRV98nlo.LHgrid 221908 BLAKE2B 01af851928bbcfae110f3f5bc2b7599f86c25adb54e979c19625cf44ce7b633639f4ab99e068f8ae5ce3d9e72289265101ec40882e4af4b4a62abb152644890d SHA512 fce5226a6eb56c9cc970d2d2bb23c5a0cde3afbb1f463e3e062825c2379213100a2d149ff6b25d9726e80ee817f9ae74eafcc85b2b30419aa7f095847dbcd8b6
DIST MRST2001nlo.LHgrid 719692 BLAKE2B 67a58bcf19857a5cee3eeac29bd2aa236f63c96acbf69b944ed14a94422a986e1579549172a2444b109f5bcfe6fd2fea4acc148c78e2e4f7258a836891ba0648 SHA512 126461ec2358e61221445483074a804c915b94be4a4dfd0330a9cf71feff9a9b981c5594a9d2a1efd236122f44891dd25182649803dccb3b383d03e85e96f930
DIST ThePEG-2.0.4.tar.bz2 1921082 BLAKE2B f27dd81b51c28eac547351a7c732969d79abd6c1885a2e52319b6e5807bb4c1824e35e303e3d23b80b7da07a3c7c9e9f5470d538728362a4398bb66e42a00325 SHA512 5c037033daa89748267691df644209f62f46ccdff6865cfeceeda6909cff3de0c474c5ced067db6c5659ba6ebe5a51fc9b8fee46a36886278f8d29e13de2a81c
+DIST ThePEG-2.2.2.tar.bz2 1930050 BLAKE2B a10e966ed090f148b991a6434a2d527353014c25f5a91c92c2ce5302e1c51030fe56c2387f409ea3fb804a8efd7f0039424bd98471f0accb22c3092714df0c31 SHA512 70fa179dc1712b27549d1949c6f144cb899c372ec46606ab6b7dbcbf348961562a0a3ed769bdd8f8b8d62c07859a67c5e646ab357a9cbdd0644e557670fe3a3e
DIST cteq5l.LHgrid 134797 BLAKE2B 1e222631ff00979abf64e95ffa3133d29eacd819325fcdf9d4065a1ce85db5704f0a43c646f9a9a3ee7b1905603e9060fc279405435d412bf06ee14ba9121f32 SHA512 1ba41fd773104a933af6f37745dcb6f8422e1aece74ba2b1e15a5fb69fdaf694336c0ec1dc6fbc964d2cf3fe363d17ca0c01a6c2ba6def0afa4389cb4083f34b
DIST cteq6ll.LHpdf 1461 BLAKE2B 66a8ebd404849a14c1240ff1c7b06e758a78ae47cc4e7818b8b7fcb6faecbb17fd8810279e54c70623a048f78e6f89706bcecca4d4b8174468ff52481da37640 SHA512 b89a87d1c1c7cc910aa4af53abc3cc6550670a5a6332989232d33c7da1ba01ce49bbbf9f3bb454e673312fb5bc1679f86eea18f95a1443d1c80d3a622e2b8728
diff --git a/sci-physics/thepeg/thepeg-2.0.4.ebuild b/sci-physics/thepeg/thepeg-2.0.4-r1.ebuild
index 69fd55af01e8..30b441b5a8e2 100644
--- a/sci-physics/thepeg/thepeg-2.0.4.ebuild
+++ b/sci-physics/thepeg/thepeg-2.0.4-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit autotools elisp-common java-pkg-opt-2
@@ -10,30 +10,32 @@ MY_P=ThePEG-${PV}
DESCRIPTION="Toolkit for High Energy Physics Event Generation"
HOMEPAGE="http://home.thep.lu.se/ThePEG/"
-TEST_URI="http://www.hepforge.org/archive/lhapdf/pdfsets/current"
-SRC_URI="http://www.hepforge.org/archive/thepeg/${MY_P}.tar.bz2
+TEST_URI="https://www.hepforge.org/archive/lhapdf/pdfsets/current"
+SRC_URI="https://www.hepforge.org/archive/thepeg/${MY_P}.tar.bz2
test? ( hepmc? (
- ${TEST_URI}/cteq6ll.LHpdf
- ${TEST_URI}/cteq5l.LHgrid
- ${TEST_URI}/GRV98nlo.LHgrid
- ${TEST_URI}/MRST2001nlo.LHgrid ) )"
-LICENSE="GPL-2"
+ ${TEST_URI}/cteq6ll.LHpdf
+ ${TEST_URI}/cteq5l.LHgrid
+ ${TEST_URI}/GRV98nlo.LHgrid
+ ${TEST_URI}/MRST2001nlo.LHgrid ) )"
+LICENSE="GPL-2"
SLOT="0/20"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="c++11 emacs fastjet hepmc java lhapdf static-libs test zlib"
RESTRICT="!test? ( test )"
-RDEPEND="
+CDEPEND="
sci-libs/gsl:0=
emacs? ( >=app-editors/emacs-23.1:* )
fastjet? ( sci-physics/fastjet:0= )
hepmc? ( sci-physics/hepmc:0= )
- java? ( >=virtual/jre-1.5:* )
lhapdf? ( >=sci-physics/lhapdf-6.0:0= )
zlib? ( sys-libs/zlib:0= )"
-DEPEND="${RDEPEND}
+DEPEND="${CDEPEND}
+ java? ( virtual/jdk:1.8 )
test? ( sys-process/time )"
+RDEPEND="${CDEPEND}
+ java? ( virtual/jre:1.8 )"
S="${WORKDIR}/${MY_P}"
diff --git a/sci-physics/thepeg/thepeg-2.2.2.ebuild b/sci-physics/thepeg/thepeg-2.2.2.ebuild
new file mode 100644
index 000000000000..750ea66b2e33
--- /dev/null
+++ b/sci-physics/thepeg/thepeg-2.2.2.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools elisp-common java-pkg-opt-2
+
+MY_P=ThePEG-${PV}
+
+DESCRIPTION="Toolkit for High Energy Physics Event Generation"
+HOMEPAGE="http://home.thep.lu.se/ThePEG/"
+
+TEST_URI="https://www.hepforge.org/archive/lhapdf/pdfsets/current"
+SRC_URI="https://www.hepforge.org/archive/thepeg/${MY_P}.tar.bz2
+ test? ( hepmc? (
+ ${TEST_URI}/cteq6ll.LHpdf
+ ${TEST_URI}/cteq5l.LHgrid
+ ${TEST_URI}/GRV98nlo.LHgrid
+ ${TEST_URI}/MRST2001nlo.LHgrid ) )"
+
+LICENSE="GPL-2"
+SLOT="0/20"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="emacs fastjet hepmc java lhapdf static-libs test zlib"
+RESTRICT="!test? ( test )"
+
+CDEPEND="
+ sci-libs/gsl:0=
+ emacs? ( >=app-editors/emacs-23.1:* )
+ fastjet? ( sci-physics/fastjet:0= )
+ hepmc? ( sci-physics/hepmc:0= )
+ lhapdf? ( >=sci-physics/lhapdf-6.0:0= )
+ zlib? ( sys-libs/zlib:0= )"
+DEPEND="${CDEPEND}
+ java? ( virtual/jdk:1.8 )
+ test? ( sys-process/time )"
+RDEPEND="${CDEPEND}
+ java? ( virtual/jre:1.8 )"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.8.3-java.patch
+ "${FILESDIR}"/${PN}-2.0.4-gcc6.patch
+)
+
+src_prepare() {
+ find -name 'Makefile.am' -exec \
+ sed -i -e '1ipkgdatadir=$(datadir)/thepeg' {} \; || die
+ # trick to force c++ linking
+ sed -i \
+ -e '1inodist_EXTRA_libThePEG_la_SOURCES = dummy.cxx' \
+ -e '/dist_pkgdata_DATA = ThePEG.el/d' \
+ lib/Makefile.am || die
+ default
+ java-pkg-opt-2_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with fastjet fastjet "${EPREFIX}"/usr) \
+ $(use_with hepmc hepmc "${EPREFIX}"/usr) \
+ $(use_with java javagui) \
+ $(use_with lhapdf lhapdf "${EPREFIX}"/usr) \
+ --without-rivet \
+ $(use_with zlib zlib "${EPREFIX}"/usr)
+}
+
+src_compile() {
+ default
+ use emacs && elisp-compile lib/ThePEG.el
+}
+
+src_test() {
+ emake LHAPATH="${DISTDIR}" check
+}
+
+src_install() {
+ default
+ use emacs && elisp-install ${PN} lib/ThePEG.el{,c}
+ use java && java-pkg_newjar java/ThePEG.jar
+
+ cat <<-EOF > "${T}"/50${PN}
+ LDPATH="${EPREFIX}/usr/$(get_libdir)/ThePEG"
+ EOF
+ doenvd "${T}"/50${PN}
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}