summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-27 08:20:42 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-27 09:03:13 +0200
commita6c0aa03f588f15b8341f1339e9ef4f777fbca2f (patch)
tree2ee2b1ba2bc6b834cd2eb2eed1d8535a3f941347 /xfce-base
parentdev-haskell/cabal: bump up to 2.4.0.1 (ghc-8.6 core lib) (diff)
downloadgentoo-a6c0aa03f588f15b8341f1339e9ef4f777fbca2f.tar.gz
gentoo-a6c0aa03f588f15b8341f1339e9ef4f777fbca2f.tar.bz2
gentoo-a6c0aa03f588f15b8341f1339e9ef4f777fbca2f.zip
xfce-base/exo: Bump to 4.15.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/exo/Manifest1
-rw-r--r--xfce-base/exo/exo-4.15.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/xfce-base/exo/Manifest b/xfce-base/exo/Manifest
index 1e26e43e1964..09c9af61e933 100644
--- a/xfce-base/exo/Manifest
+++ b/xfce-base/exo/Manifest
@@ -1 +1,2 @@
DIST exo-0.12.11.tar.bz2 1333227 BLAKE2B 4e95809c58b6db26ecdf524663c06df9cd70007726091e381a1f0dd58be52efee85ad9721c421c0df6438073bb9de97d56cd039f520e2f7c0f5722a1839ba167 SHA512 ecbf20feddf86178d34a5c70212f0c2310ab1d6ce25291846d6d1d3045270ae3e68102065d7b3d8840137406f826f9bc37fed92a16c1268c3d14f2833a97d533
+DIST exo-4.15.1.tar.bz2 1049760 BLAKE2B 365a51a6be44b36290d1bbe7100bc4e9a164436b2111997c969bdcc2f46306c0532fa41bedc231c5640992910e44acc8d072f5c070fc8d56f02b561002985224 SHA512 46b60bfde133969a25e72a5a80644454b06543888e554e8473145486d1b1952c4e508f2303045f183c49b053969189f50316ce7d18a0be2c404daa691e26d276
diff --git a/xfce-base/exo/exo-4.15.1.ebuild b/xfce-base/exo/exo-4.15.1.ebuild
new file mode 100644
index 000000000000..5089b190c4c8
--- /dev/null
+++ b/xfce-base/exo/exo-4.15.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="Extensions, widgets and framework library with session support for Xfce"
+HOMEPAGE="https://www.xfce.org/projects/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+
+RDEPEND=">=dev-lang/perl-5.6
+ >=dev-libs/glib-2.42
+ dev-perl/URI
+ >=x11-libs/gtk+-3.22:3
+ >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.12:="
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}