summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Michael <fedora.dm0@gmail.com>2021-01-07 19:17:59 -0500
committerMichał Górny <mgorny@gentoo.org>2021-01-12 19:33:36 +0100
commit05fefac10ba726e61a5e92f250584ec5dbc169c7 (patch)
treeb5097f569b01a6db5c686b2137adb7f960efc447 /xfce-base/xfwm4
parentxfce-base/xfce4-session: specify the runtime iceauth path (diff)
downloadgentoo-05fefac10ba726e61a5e92f250584ec5dbc169c7.tar.gz
gentoo-05fefac10ba726e61a5e92f250584ec5dbc169c7.tar.bz2
gentoo-05fefac10ba726e61a5e92f250584ec5dbc169c7.zip
xfce-base/xfwm4: enable libXi and drop the exo dep
The exo dependency appears to have been for calling exo-csource, which was replaced with xdt-csource from xfce4-dev-tools, but this is only used in maintainer mode, so just drop it. Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: David Michael <fedora.dm0@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/18988 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base/xfwm4')
-rw-r--r--xfce-base/xfwm4/xfwm4-4.16.1.ebuild23
1 files changed, 11 insertions, 12 deletions
diff --git a/xfce-base/xfwm4/xfwm4-4.16.1.ebuild b/xfce-base/xfwm4/xfwm4-4.16.1.ebuild
index 0a4b9d4fdacb..52677c1a05f5 100644
--- a/xfce-base/xfwm4/xfwm4-4.16.1.ebuild
+++ b/xfce-base/xfwm4/xfwm4-4.16.1.ebuild
@@ -12,12 +12,16 @@ SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="opengl startup-notification +xcomposite +xpresent"
+IUSE="opengl startup-notification +xpresent"
RDEPEND=">=dev-libs/glib-2.20
>=x11-libs/gtk+-3.22:3
x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
x11-libs/libXinerama
x11-libs/libXrandr
x11-libs/libXrender
@@ -29,12 +33,7 @@ RDEPEND=">=dev-libs/glib-2.20
>=xfce-base/xfconf-4.13:=
opengl? ( media-libs/libepoxy:=[X(+)] )
startup-notification? ( x11-libs/startup-notification )
- xpresent? ( x11-libs/libXpresent )
- xcomposite? (
- x11-libs/libXcomposite
- x11-libs/libXdamage
- x11-libs/libXfixes
- )"
+ xpresent? ( x11-libs/libXpresent )"
# libICE/libSM: not really used anywhere but checked by configure
# https://bugzilla.xfce.org/show_bug.cgi?id=11914
DEPEND="${RDEPEND}
@@ -43,18 +42,18 @@ DEPEND="${RDEPEND}
BDEPEND="
dev-util/intltool
sys-devel/gettext
- xfce-base/exo
virtual/pkgconfig"
src_configure() {
local myconf=(
$(use_enable opengl epoxy)
$(use_enable startup-notification)
- --enable-xsync
- --enable-render
- --enable-randr
$(use_enable xpresent)
- $(use_enable xcomposite compositor)
+ --enable-compositor
+ --enable-randr
+ --enable-render
+ --enable-xi2
+ --enable-xsync
)
econf "${myconf[@]}"