summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-15 20:11:53 +0100
committerSam James <sam@gentoo.org>2022-06-15 20:36:15 +0100
commit7eca9fda6f7b3df54cb1d3772a6141dffdb49d58 (patch)
tree21e227dedc1d15c01c1d6653114512c2e7ec5751 /x11-wm
parentsci-mathematics/polymake: new revision with a few fixes. (diff)
downloadgentoo-7eca9fda6f7b3df54cb1d3772a6141dffdb49d58.tar.gz
gentoo-7eca9fda6f7b3df54cb1d3772a6141dffdb49d58.tar.bz2
gentoo-7eca9fda6f7b3df54cb1d3772a6141dffdb49d58.zip
x11-wm/windowlab: fix build with lld
Closes: https://bugs.gentoo.org/732470 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/windowlab/files/windowlab-1.40-libdir.patch20
-rw-r--r--x11-wm/windowlab/windowlab-1.40-r2.ebuild53
2 files changed, 73 insertions, 0 deletions
diff --git a/x11-wm/windowlab/files/windowlab-1.40-libdir.patch b/x11-wm/windowlab/files/windowlab-1.40-libdir.patch
new file mode 100644
index 000000000000..65c2b662dc62
--- /dev/null
+++ b/x11-wm/windowlab/files/windowlab-1.40-libdir.patch
@@ -0,0 +1,20 @@
+https://bugs.gentoo.org/732470
+--- a/Makefile
++++ b/Makefile
+@@ -51,7 +51,6 @@ BINDIR = $(DESTDIR)$(PREFIX)/bin
+ MANDIR = $(DESTDIR)$(PREFIX)$(MANBASE)/man1
+ CFGDIR = $(DESTDIR)$(SYSCONFDIR)
+ INCLUDES = -I$(XROOT)/include $(EXTRA_INC)
+-LDPATH = -L$(XROOT)/lib
+ LIBS = -lX11 $(EXTRA_LIBS)
+
+ PROG = windowlab
+@@ -62,7 +61,7 @@ HEADERS = windowlab.h
+ all: $(PROG)
+
+ $(PROG): $(OBJS)
+- $(CC) $(CFLAGS) $(LDFLAGS) $(OBJS) $(LDPATH) $(LIBS) -o $@
++ $(CC) $(CFLAGS) $(LDFLAGS) $(OBJS) $(LIBS) -o $@
+
+ $(OBJS): %.o: %.c $(HEADERS)
+ $(CC) $(CFLAGS) $(DEFINES) $(INCLUDES) -c $< -o $@
diff --git a/x11-wm/windowlab/windowlab-1.40-r2.ebuild b/x11-wm/windowlab/windowlab-1.40-r2.ebuild
new file mode 100644
index 000000000000..521a807b40c7
--- /dev/null
+++ b/x11-wm/windowlab/windowlab-1.40-r2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="small and simple window manager of novel design"
+HOMEPAGE="http://www.nickgravgaard.com/windowlab/"
+SRC_URI="http://www.nickgravgaard.com/${PN}/${P}.tar"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~x86"
+IUSE="truetype"
+
+RDEPEND="truetype? ( x11-libs/libXft )
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.34-fixed-font.patch"
+ "${FILESDIR}/${P}-gentoo.diff"
+ "${FILESDIR}/${PN}-1.40-libdir.patch"
+)
+
+src_configure() {
+ if use truetype ; then
+ export DEFINES=-DXFT
+ export EXTRA_INC=$($(tc-getPKG_CONFIG) --cflags xft)
+ export EXTRA_LIBS=$($(tc-getPKG_CONFIG) --libs xft)
+ fi
+
+ tc-export CC
+}
+
+src_install() {
+ default
+
+ exeinto /etc/X11/Sessions
+ cat <<- EOF > "${T}"/${PN}
+ #!/bin/sh
+ exec /usr/bin/${PN}
+ EOF
+ doexe "${T}"/${PN}
+}
+
+pkg_postinst() {
+ elog "${PN}'s menu config file has been changed from"
+ elog "${EROOT}/etc/X11/${PN}/menurc to ${EROOT}/etc/X11/${PN}/${PN}.menurc"
+}