summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-wm/notion/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-wm/notion/files')
-rw-r--r--x11-wm/notion/files/notion2
-rw-r--r--x11-wm/notion/files/notion-3_p2015061300-pkg-config.patch76
-rw-r--r--x11-wm/notion/files/notion.desktop8
3 files changed, 86 insertions, 0 deletions
diff --git a/x11-wm/notion/files/notion b/x11-wm/notion/files/notion
new file mode 100644
index 000000000000..65bf5648ad0b
--- /dev/null
+++ b/x11-wm/notion/files/notion
@@ -0,0 +1,2 @@
+#!/bin/sh
+/usr/bin/notion
diff --git a/x11-wm/notion/files/notion-3_p2015061300-pkg-config.patch b/x11-wm/notion/files/notion-3_p2015061300-pkg-config.patch
new file mode 100644
index 000000000000..fb718caa3158
--- /dev/null
+++ b/x11-wm/notion/files/notion-3_p2015061300-pkg-config.patch
@@ -0,0 +1,76 @@
+--- notion-3-2015061300/system-autodetect.mk
++++ notion-3-2015061300/system-autodetect.mk
+@@ -84,8 +84,8 @@
+ # SunOS/Solaris
+ #X11_PREFIX ?= /usr/openwin
+
+-X11_LIBS=-L$(X11_PREFIX)/lib -lX11 -lXext
+-X11_INCLUDES=-I$(X11_PREFIX)/include
++X11_LIBS=$(shell $(PKG_CONFIG) --libs x11 xext)
++X11_INCLUDES=$(shell $(PKG_CONFIG) --cflags-only-I x11 xext)
+
+ # XFree86 libraries up to 4.3.0 have a bug that can cause a segfault.
+ # The following setting should work around that situation.
+--- notion-3-2015061300/mod_xinerama/Makefile
++++ notion-3-2015061300/mod_xinerama/Makefile
+@@ -9,14 +9,14 @@
+
+ ######################################
+
+-INCLUDES += $(LIBTU_INCLUDES) $(LIBEXTL_INCLUDES) $(X11_INCLUDES) -I$(TOPDIR)
+-CFLAGS += $(XOPEN_SOURCE) $(C99_SOURCE)
++INCLUDES += $(LIBTU_INCLUDES) $(LIBEXTL_INCLUDES) $(X11_INCLUDES) -I$(TOPDIR) $(shell $(PKG_CONFIG) --cflags-only-I xinerama)
++CFLAGS += $(XOPEN_SOURCE) $(C99_SOURCE) $(shell $(PKG_CONFIG) --cflags-only-other xinerama)
+ DOCS=LICENSE README
+
+ SOURCES=mod_xinerama.c
+
+ MAKE_EXPORTS=mod_xinerama
+-LIBS = -L/usr/lib/x86_64-linux-gnu $(X11_LIBS) -lXinerama
++LIBS = $(X11_LIBS) $(shell $(PKG_CONFIG) --libs xinerama)
+ MODULE=mod_xinerama
+ MODULE_STUB=mod_xinerama.lua
+
+@@ -44,7 +44,7 @@
+
+ .PHONY: test
+ test: $(SOURCES)
+- lua test_xinerama.lua
++ $(LUA) test_xinerama.lua
+
+ ######################################
+
+@@ -57,4 +57,4 @@
+ ################ ls_xinerama utility ###############
+
+ ls_xinerama: ls_xinerama.c
+- $(CC) ls_xinerama.c -o ls_xinerama -Wl,--as-needed -lX11 -lXinerama
++ $(CC) $(CFLAGS) ls_xinerama.c -o ls_xinerama $(LDFLAGS) $(LIBS)
+--- notion-3-2015061300/mod_xrandr/Makefile
++++ notion-3-2015061300/mod_xrandr/Makefile
+@@ -9,13 +9,13 @@
+
+ ######################################
+
+-INCLUDES += $(LIBTU_INCLUDES) $(LIBEXTL_INCLUDES) $(X11_INCLUDES) -I$(TOPDIR)
+-CFLAGS += $(XOPEN_SOURCE) $(C99_SOURCE)
++INCLUDES += $(LIBTU_INCLUDES) $(LIBEXTL_INCLUDES) $(X11_INCLUDES) -I$(TOPDIR) $(shell pkg-config --cflags-only-I xrandr)
++CFLAGS += $(XOPEN_SOURCE) $(C99_SOURCE) $(shell $(PKG_CONFIG) --cflags-only-other xrandr)
+
+ SOURCES=mod_xrandr.c
+
+ MAKE_EXPORTS=mod_xrandr
+-LIBS = $(X11_LIBS) -lXrandr
++LIBS = $(X11_LIBS) $(shell $(PKG_CONFIG) --libs xrandr)
+ MODULE=mod_xrandr
+ MODULE_STUB=mod_xrandr.lua
+ ETC=cfg_xrandr.lua
+@@ -45,7 +45,7 @@
+
+ .PHONY: test
+ test: $(SOURCES)
+- for i in test_xrandr*.lua ; do echo 'Testing' $$i ; lua $$i ; done
++ for i in test_xrandr*.lua ; do echo 'Testing' $$i ; $(LUA) $$i ; done
+
+ ######################################
+
diff --git a/x11-wm/notion/files/notion.desktop b/x11-wm/notion/files/notion.desktop
new file mode 100644
index 000000000000..7c9de9a95fd3
--- /dev/null
+++ b/x11-wm/notion/files/notion.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Notion
+Comment=A tiling tabbed window manager designed with keyboard users in mind.
+Exec=notion
+TryExec=notion
+# no icon yet, only the top three are currently used
+Icon=
+Type=Application